Jump to content

Internet suddenly stopped working


Recommended Posts

I've been using uTorrent for years and never had any problems until yesterday.

Around 4 pm on tuesday, my internet connection died. I tried using "repair" on the connection but it didn't work. All it got me was a private IP-address because it couldn't get one off the DHCP. After that I attempted an ipconfig /flushdns, ipconfig /release and ipconfig /renew. Same result.

I had to reboot in order to get internet working again, for a few minutes. Then it happened again and I was forced to reboot. So far rebooting is the ONLY way I've found to get an IP-address again.

It took me half a day to find that bittorrents are the culprit. When uTorrent isn't seeding or downloading anything, everything works just fine. As soon as I attempt to start a torrent or download a new one, I lost internet connection. The connection icon down in the systray goes totally black.

Downloading files (tried both small and large, from multiple servers, simultaneously, to both my harddrives) using Opera and IE works fine. So does FTP, surfing the web, talking through skype, using Live Messenger, filesharing (extensively) using eMule, playing games and everything else I've thrown at it. I tried using BitComet and Azureus, and I lose internet connection as well.

The only thing I tried that works is if I start a virtual machine running Win 2k with uTorrent in VmWare.

My configuration is as follows:

* MSI P35 Neo2-Fir Motherboard

* Core 2 Duo E6750 CPU (overclocked to 3,4 GHz)

* 4 Gb of Crucial BallistiX DDR2-ram

* MSI Nvidia 7600GS gfx-card

* Seagate 7200.11 320 GB as system drive

* Western Digital Caviar GP 1 TB as a storage drive

* Running Windows 2003 Enterprise Server with SP2 on an educational license

My ISP is Bredbandsbolaget 100 mbit and I have no router nor firewall of any kind, only a gigabit-switch and I get the same problem when I try connecting the ethernet-cable directly to the computer.

Other things I've tried in different sorts of combinations without any luck:

* Updating BIOS, Intel motherboard drivers and Realtek 8111C (NIC) drivers

* Turning off TCP offloading in the NIC-driver

* Turning off overclocking of my CPU

* Changing ALL SORT of settings in both Azureus and uTorrent including encryption on/off, port used, number of connections etc

* Running Windows in safe mode with networking

* Shutting off the Windows firewall

* After the connection stopped working, restarting the Windows DHCP Service

* Running no other program but uTorrent

* Shutting all the hardware down for 10 min before starting it up again

* Making sure all cables are connected properly

* Checked for Spyware using HiJackThis, Ad-aware, Spybot, Combofix, GMER and Windows Defender

* Checked for viruses using the retail version of NOD32

* Made sure I have all the latest Windows updates as of today

* Waiting, just waiting for the internet connection to come back up after I quit uTorrent

[Edit: Added:

* Turn off NOD32 and the Windows Firewall

* Tried different torrents from different trackers

* Changing the number of half-open ports using the patch from lvllord.de

* Ran LSPfix (it found nothing wrong)

* Reset the winsock using netsh

* Tried the official Bittorrent-client, Bittornado, uTorrent 1.6 and the 1.8 beta

* Ran Realtek-diagnostics, no errors

* After the net goes down, reset the NIC-driver using the Realtek-diagnostics tool

* Ran Registry Repair

* Checked the Windows System and Software log, no errors in it

* Tried a really old Realtek driver for the NIC

What remains to try that I can think of:

* Run Diskcheck on both harddrives (will take many hours)

* Try using a dedicated NIC (I don't own one though and would need to buy one)

I haven't changed any settings, installed or uninstalled any programs or done anything prior to this happening.

Both uTorrent and Azureus work just fine if I run it in a virtual machine or on my laptop (running Win XP SP3). If I start a few torrents that I'm seeding, and there are no leechers everything works fine. As soon as someone starts downloading, hence making me seed, I lose my connection.

Since I've run out of ideas, I'm all open to suggestions.



Link to comment
Share on other sites

Logfile of Trend Micro HijackThis v2.0.2
Scan saved at 06:51:52, on 2008-05-14
Platform: Windows 2003 SP2 (WinNT 5.02.3790)
MSIE: Internet Explorer v7.00 (7.00.6000.16640)
Boot mode: Normal

Running processes:
C:\Program\Windows Defender\MsMpEng.exe
C:\Program\WIDCOMM\Bluetooth Software\bin\btwdins.exe
C:\Program\NOD32 Antivirus\ekrn.exe
C:\Program\Intel\Intel Matrix Storage Manager\Iaantmon.exe
C:\Program\Delade filer\Microsoft Shared\VS7DEBUG\mdm.exe
C:\Program\Nero\Nero8\Nero BackItUp\NBService.exe
C:\Program\Raxco PerfectDisk 2008\PD91Agent.exe
C:\Program\Delade filer\VMware\VMware Virtual Image Editing\vmount2.exe
C:\Program\VMware\VMware Workstation\vmware-authd.exe
C:\Program\Intel\Intel Matrix Storage Manager\Iaanotif.exe
C:\Program\Microsoft Office\Office12\GrooveMonitor.exe
C:\Program\NOD32 Antivirus\egui.exe
C:\Program\Windows Defender\MSASCui.exe
C:\Program\VMware\VMware Workstation\vmware-tray.exe
C:\Program\VMware\VMware Workstation\hqtray.exe
C:\Program\Realtek\Diagnostics Utility\8169Diag.exe
C:\Program\Weather Watcher\ww.exe
C:\Program\Spybot - Search & Destroy\TeaTimer.exe
C:\Program\Nokia\Nokia PC Suite 6\PCSuite.exe
C:\Program\Nokia\Nokia PC Suite 6\PCSync2.exe
C:\Program\WIDCOMM\Bluetooth Software\BTTray.exe
C:\Program\PC Connectivity Solution\ServiceLayer.exe
C:\Program\Delade filer\Nokia\MPAPI\MPAPI3s.exe
C:\Program\Skype\Plugin Manager\skypePM.exe
C:\Program\PC Connectivity Solution\Transports\NclUSBSrv.exe

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = about:blank
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157
R1 - HKCU\Software\Microsoft\Internet Connection Wizard,ShellNext = http://go.microsoft.com/fwlink/?LinkId=74005
R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyOverride = *.local
R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName = Länkar
F2 - REG:system.ini: UserInit=C:\WINDOWS\system32\userinit.exe,C:\WINDOWS\system32\wmsdkns.exe,
O1 - Hosts: serial.alcohol-soft.com
O2 - BHO: Länkhjälp till Adobe PDF Reader - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program\Delade filer\Adobe\Acrobat\ActiveX\AcroIEHelper.dll
O2 - BHO: (no name) - {15651c7c-e812-44a2-a9ac-b467a2233e7d} - (no file)
O2 - BHO: Skype add-on (mastermind) - {22BF413B-C6D2-4d91-82A9-A0F997BA588C} - C:\Program\Skype\Toolbars\Internet Explorer\SkypeIEPlugin.dll
O2 - BHO: Spybot-S&D IE Protection - {53707962-6F74-2D53-2644-206D7942484F} - C:\Program\Spybot - Search & Destroy\SDHelper.dll
O2 - BHO: (no name) - {622cc208-b014-4fe0-801b-874a5e5e403a} - (no file)
O2 - BHO: Groove GFS Browser Helper - {72853161-30C5-4D22-B7F9-0BBC1D38A37E} - C:\Program\Microsoft Office\Office12\GrooveShellExtensions.dll
O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program\Java\jre1.6.0_05\bin\ssv.dll
O2 - BHO: (no name) - {7E853D72-626A-48EC-A868-BA8D5E23E045} - (no file)
O2 - BHO: (no name) - {9c5b2f29-1f46-4639-a6b4-828942301d3e} - (no file)
O2 - BHO: Google Toolbar Helper - {AA58ED58-01DD-4d91-8333-CF10577473F7} - c:\program\google\googletoolbar1.dll
O2 - BHO: Adobe PDF Conversion Toolbar Helper - {AE7CD045-E861-484f-8273-0445EE161910} - C:\Program\Adobe\Acrobat\Acrobat\AcroIEFavClient.dll
O2 - BHO: Google Toolbar Notifier BHO - {AF69DE43-7D58-4638-B6FA-CE66B5AD205D} - C:\Program\Google\GoogleToolbarNotifier\2.0.301.7164\swg.dll
O2 - BHO: Servicecenter Plugin - {DB87CDE1-EF9C-44EB-A42F-6D0B3C72C516} - C:\Program\Bredbandsbolaget\Servicecenter\IEFixItNowPlugin.dll
O2 - BHO: FlashFXP Helper for Internet Explorer - {E5A1691B-D188-4419-AD02-90002030B8EE} - C:\Program\FlashFXP\IEFlash.dll
O2 - BHO: (no name) - {ffff0001-0002-101a-a3c9-08002b2f49fb} - (no file)
O3 - Toolbar: Adobe PDF - {47833539-D0C5-4125-9FA8-0819E2EAAC93} - C:\Program\Adobe\Acrobat\Acrobat\AcroIEFavClient.dll
O3 - Toolbar: &Google - {2318C2B1-4965-11d4-9B18-009027A5CD4F} - c:\program\google\googletoolbar1.dll
O4 - HKLM\..\Run: [IAAnotif] "C:\Program\Intel\Intel Matrix Storage Manager\Iaanotif.exe"
O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\system32\NvCpl.dll,NvStartup
O4 - HKLM\..\Run: [nwiz] nwiz.exe /install
O4 - HKLM\..\Run: [Logitech Utility] Logi_MwX.Exe
O4 - HKLM\..\Run: [GrooveMonitor] "C:\Program\Microsoft Office\Office12\GrooveMonitor.exe"
O4 - HKLM\..\Run: [Acrobat Assistant 8.0] "C:\Program\Adobe\Acrobat\Acrobat\Acrotray.exe"
O4 - HKLM\..\Run: [egui] "C:\Program\NOD32 Antivirus\egui.exe" /hide /waitservice
O4 - HKLM\..\Run: [Windows Defender] "C:\Program\Windows Defender\MSASCui.exe" -hide
O4 - HKLM\..\Run: [vmware-tray] C:\Program\VMware\VMware Workstation\vmware-tray.exe
O4 - HKLM\..\Run: [VMware hqtray] "C:\Program\VMware\VMware Workstation\hqtray.exe"
O4 - HKLM\..\Run: [kX Mixer] C:\WINDOWS\system32\kxmixer.exe --startup
O4 - HKLM\..\Run: [NvMediaCenter] RUNDLL32.EXE C:\WINDOWS\system32\NvMcTray.dll,NvTaskbarInit
O4 - HKLM\..\Run: [WinampAgent] C:\Program\Winamp\winampa.exe
O4 - HKLM\..\Run: [SunJavaUpdateSched] "C:\Program\Java\jre1.6.0_05\bin\jusched.exe"
O4 - HKLM\..\Run: [Alcmtr] ALCMTR.EXE
O4 - HKLM\..\Run: [8169Diag] C:\Program\Realtek\Diagnostics Utility\8169Diag /hw
O4 - HKCU\..\Run: [uTorrent] "C:\Program\uTorrent\uTorrent.exe"
O4 - HKCU\..\Run: [Skype] "C:\Program\Skype\Phone\Skype.exe" /nosplash /minimized
O4 - HKCU\..\Run: [WeatherWatcher] C:\Program\Weather Watcher\ww.exe
O4 - HKCU\..\Run: [swg] C:\Program\Google\GoogleToolbarNotifier\GoogleToolbarNotifier.exe
O4 - HKCU\..\Run: [SpybotSD TeaTimer] C:\Program\Spybot - Search & Destroy\TeaTimer.exe
O4 - HKCU\..\Run: [PC Suite Tray] "C:\Program\Nokia\Nokia PC Suite 6\PCSuite.exe" -onlytray
O4 - HKCU\..\Run: [Nokia.PCSync] "C:\Program\Nokia\Nokia PC Suite 6\PCSync2.exe" /NoDialog
O4 - HKUS\S-1-5-19\..\RunOnce: [tscuninstall] %systemroot%\system32\tscupgrd.exe (User 'LOKAL TJÄNST')
O4 - HKUS\S-1-5-20\..\RunOnce: [tscuninstall] %systemroot%\system32\tscupgrd.exe (User 'NETWORK SERVICE')
O4 - HKUS\S-1-5-18\..\Run: [Nokia.PCSync] "C:\Program\Nokia\Nokia PC Suite 6\PcSync2.exe" /NoDialog (User 'SYSTEM')
O4 - HKUS\S-1-5-18\..\RunOnce: [tscuninstall] %systemroot%\system32\tscupgrd.exe (User 'SYSTEM')
O4 - HKUS\.DEFAULT\..\Run: [Nokia.PCSync] "C:\Program\Nokia\Nokia PC Suite 6\PcSync2.exe" /NoDialog (User 'Default user')
O4 - HKUS\.DEFAULT\..\RunOnce: [tscuninstall] %systemroot%\system32\tscupgrd.exe (User 'Default user')
O4 - Startup: RivaTuner.lnk = C:\Program\RivaTuner\RivaTuner.exe
O4 - Startup: Trillian.lnk = C:\Program\Trillian\trillian.exe
O4 - Global Startup: BTTray.lnk = ?
O6 - HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions present
O8 - Extra context menu item: Bifoga till befintlig PDF - res://C:\Program\Adobe\Acrobat\Acrobat\AcroIEFavClient.dll/AcroIEAppend.html
O8 - Extra context menu item: E&xportera till Microsoft Excel - res://C:\Program\Microsoft Office\Office12\EXCEL.EXE/3000
O8 - Extra context menu item: Konvertera länkmål till Adobe PDF - res://C:\Program\Adobe\Acrobat\Acrobat\AcroIEFavClient.dll/AcroIECapture.html
O8 - Extra context menu item: Konvertera länkmål till befintlig PDF - res://C:\Program\Adobe\Acrobat\Acrobat\AcroIEFavClient.dll/AcroIEAppend.html
O8 - Extra context menu item: Konvertera markering till Adobe PDF - res://C:\Program\Adobe\Acrobat\Acrobat\AcroIEFavClient.dll/AcroIECapture.html
O8 - Extra context menu item: Konvertera markering till befintlig PDF - res://C:\Program\Adobe\Acrobat\Acrobat\AcroIEFavClient.dll/AcroIEAppend.html
O8 - Extra context menu item: Konvertera till Adobe PDF - res://C:\Program\Adobe\Acrobat\Acrobat\AcroIEFavClient.dll/AcroIECapture.html
O8 - Extra context menu item: Konvertera valda länkar till Adobe PDF - res://C:\Program\Adobe\Acrobat\Acrobat\AcroIEFavClient.dll/AcroIECaptureSelLinks.html
O8 - Extra context menu item: Konvertera valda länkar till befintlig PDF - res://C:\Program\Adobe\Acrobat\Acrobat\AcroIEFavClient.dll/AcroIEAppendSelLinks.html
O8 - Extra context menu item: Skicka till &Bluetooth-enhet... - C:\Program\WIDCOMM\Bluetooth Software\btsendto_ie_ctx.htm
O8 - Extra context menu item: Skicka till Bluetooth - C:\Program\WIDCOMM\Bluetooth Software\btsendto_ie.htm
O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program\Java\jre1.6.0_05\bin\ssv.dll
O9 - Extra 'Tools' menuitem: Sun Java-konsol - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program\Java\jre1.6.0_05\bin\ssv.dll
O9 - Extra button: Skicka till OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\Program\Microsoft Office\Office12\ONBttnIE.dll
O9 - Extra 'Tools' menuitem: Ski&cka till OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\Program\Microsoft Office\Office12\ONBttnIE.dll
O9 - Extra button: Skype - {77BF5300-1474-4EC7-9980-D32B190E9B07} - C:\Program\Skype\Toolbars\Internet Explorer\SkypeIEPlugin.dll
O9 - Extra button: @btrez.dll,-4015 - {CCA281CA-C863-46ef-9331-5C8D4460577F} - C:\Program\WIDCOMM\Bluetooth Software\btsendto_ie.htm
O9 - Extra 'Tools' menuitem: @btrez.dll,-12650 - {CCA281CA-C863-46ef-9331-5C8D4460577F} - C:\Program\WIDCOMM\Bluetooth Software\btsendto_ie.htm
O9 - Extra button: (no name) - {DFB852A3-47F8-48C4-A200-58CAB36FD2A2} - C:\Program\Spybot - Search & Destroy\SDHelper.dll
O9 - Extra 'Tools' menuitem: Spybot - Search & Destroy Configuration - {DFB852A3-47F8-48C4-A200-58CAB36FD2A2} - C:\Program\Spybot - Search & Destroy\SDHelper.dll
O15 - ESC Trusted Zone: http://runonce.msn.com
O16 - DPF: {5BF56AD2-E297-416E-BC49-00B304040507} - https://cve.trust.telia.com/testa/iidsetup.cab
O16 - DPF: {66D393D5-4D80-497C-9F4F-F3839E090202} (PlayerOCX Control) - http://www.pysoft.com/Downloads/WebCamPlayerOCX.cab
O16 - DPF: {67A5F8DC-1A4B-4D66-9F24-A704AD929EEE} (System Requirements Lab) - http://www.systemrequirementslab.com/sysreqlab2.cab
O18 - Protocol: grooveLocalGWS - {88FED34C-F0CA-4636-A375-3CB6248B04CD} - C:\Program\Microsoft Office\Office12\GrooveSystemServices.dll
O18 - Protocol: skype4com - {FFC8B962-9B40-4DFF-9458-1830C7DD7F5D} - C:\Program\DELADE~1\Skype\Skype4COM.dll
O20 - Winlogon Notify: hggghed - C:\WINDOWS\
O23 - Service: Bluetooth Service (btwdins) - Broadcom Corporation. - C:\Program\WIDCOMM\Bluetooth Software\bin\btwdins.exe
O23 - Service: CachemanXP (CachemanXPService) - Outertech - C:\Program\CACHEM~1\CachemanXP.exe
O23 - Service: Eset HTTP Server (EhttpSrv) - ESET - C:\Program\NOD32 Antivirus\EHttpSrv.exe
O23 - Service: Eset Service (ekrn) - ESET - C:\Program\NOD32 Antivirus\ekrn.exe
O23 - Service: FLEXnet Licensing Service - Macrovision Europe Ltd. - C:\Program\Delade filer\Macrovision Shared\FLEXnet Publisher\FNPLicensingService.exe
O23 - Service: Google Updater Service (gusvc) - Google - C:\Program\Google\Common\Google Updater\GoogleUpdaterService.exe
O23 - Service: Intel(R) Matrix Storage Event Monitor (IAANTMON) - Intel Corporation - C:\Program\Intel\Intel Matrix Storage Manager\Iaantmon.exe
O23 - Service: Nero BackItUp Scheduler 3 - Nero AG - C:\Program\Nero\Nero8\Nero BackItUp\NBService.exe
O23 - Service: NMIndexingService - Nero AG - C:\Program\Delade filer\Nero\Lib\NMIndexingService.exe
O23 - Service: NVIDIA-OMEGA Display Driver Service (NVSvc) - NVIDIA Corporation - C:\WINDOWS\system32\nvsvc32.exe
O23 - Service: PD91Agent - Raxco Software, Inc. - C:\Program\Raxco PerfectDisk 2008\PD91Agent.exe
O23 - Service: PD91Engine - Raxco Software, Inc. - C:\Program\Raxco PerfectDisk 2008\PD91Engine.exe
O23 - Service: PD91VMDefrag - Raxco Software, Inc. - C:\Program\Raxco PerfectDisk 2008\PD91VMDefrag.exe
O23 - Service: ServiceLayer - Nokia. - C:\Program\PC Connectivity Solution\ServiceLayer.exe
O23 - Service: VMware Agent Service (ufad-ws60) - VMware, Inc. - C:\Program\VMware\VMware Workstation\vmware-ufad.exe
O23 - Service: VMware Authorization Service (VMAuthdService) - VMware, Inc. - C:\Program\VMware\VMware Workstation\vmware-authd.exe
O23 - Service: VMware DHCP Service (VMnetDHCP) - VMware, Inc. - C:\WINDOWS\system32\vmnetdhcp.exe
O23 - Service: VMware Virtual Mount Manager Extended (vmount2) - VMware, Inc. - C:\Program\Delade filer\VMware\VMware Virtual Image Editing\vmount2.exe
O23 - Service: VMware NAT Service - VMware, Inc. - C:\WINDOWS\system32\vmnat.exe


Link to comment
Share on other sites

Just did, didn't help. :(

Added: I found a workaround. Although I have no explanation why it works, if it has any bad side-effects or if it affects the speed.

I used TCP optimizer and changed the MTU from the default 1500 in windows to 1430.

Anyone care to elaborate on this? :D

Link to comment
Share on other sites


If you are on ADSL, then the largest packet size that ADSL can handle is typically smaller than 1500 bytes. So if your MTU is set to 1500 bytes, then any packets larger than the ADSL can handle gets fragmented...possibly improperly. Maybe the too-large packets are failing to get through your line because they AREN'T fragmented, but instead simply dropped? Or an oversided packet causes a buffer overrun or something equally nasty in the modem's hardware.

By setting MTU lower, the problem doesn't occur.

Generally (but not always) Cable ISPs use MTU values of 1500 bytes, the same as 10/100 ethernet.

Link to comment
Share on other sites

I'm not on either cable nor xDSL, I'm on ethernet with no modem or anything. The only explanation would be that I'm overloading and causing a buffer overrun in the ISP's router. Still, that doesn't explain why it suddenly stopped working one day when it worked beautifully before, why my laptop that has an untouched MTU has no problems and how it's possible for virtual machines with an unchanged MTU work with bittorrents when the host machine cannot.

Added: Just to try it out, I changed the MTU to 1500 (which I assume is the default MTU in Windows?) and rebooted. It's working fine now! The only conclusion I have is that something changed the MTU to a non-standard value at some point yesterday around 4 pm. I'm still eager to hear any plausible explanation for this though.. I haven't came across a bigger mystery since a few years back when a friend couldn't surf homepages that were running the MS IIS webserver, everything else was working fine. Turned out there was something wrong with his modem..

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...