Jump to content

Activate the program window UI settings


Recommended Posts

I'm using uT 1.8 build 11468.

Besides from a few crashes (report sent) I noticed that the program window will show every time on adding a torrent. Activate the program window option is turned off. Also Always activate when clicked is on.

As far as I can tell right now it only happens when uT is active in a window. So if it sits in the tray everything is fine.

Sometimes it only flashes, sometimes it stays open in front of you. Seems to have to do with the order that your windows are opened. If the uT window is next to FF window(s) than it will stay open. If there is a window in between it will only flash.

(Group similar taskbar buttons is turned off)

I'm adding torrents from FF 3.0.1 usually mininova.

Think I've now mentioned all relevant info. If not let me know.

Link to comment
Share on other sites

I noticed this as soon as I started using RC4 - tried toggling the activate option, restarting etc. but no change. Looking through the history there is:

--- 2008-07-15: Version 1.8 RC2 (build 11439)
- Fix: Bring the window to the front correctly when "Activate the program window" under "When adding torrents" is selected on Windows 98/2000+

I'm on Vista SP1 32bit and went directly from RC1 to RC4 as I'm sure many others did (RC2-4 were all released in a short time period) so it's likely this problem started with RC2 although I cannot confirm that. Apart from this small bug everything else works great! :)

@Ultima - I always have the Add New Torrent dialogue disabled as well and it makes no difference - uTorrent still forces it's way to the top of the Z-Order. Before RC2 uTorrent does not react at all upon opening a torrent (except to quietly add it to the listview) - that is not the case now.

As mentioned above closing uTorrent to the system tray prevents uTorrent being shown when adding a torrent - however, you can still observe that whatever window you are working in (firefox for example) loses focus when opening a torrent file (no doubt to the hidden uTorrent window) and that window will no longer receive any keyboard commands until focus is regained (by mouse clicking, alt+tab etc.).

Link to comment
Share on other sites

Fair enough. I can confirm that µTorrent is indeed popping to the front even though the add torrent dialog is completely disabled (default download directory and all), and "Activate the program window" is disabled. Definitely warrants looking into.

Link to comment
Share on other sites

  • 3 years later...


This topic is now archived and is closed to further replies.

  • Create New...