Jump to content

Bug: data files trashed after crash


Recommended Posts

Scenario: I left uTorrent downloading a single 8.1GB torrent (with various files in it). This morning, the Mac Pro was completely frozen showing the screensaver - no option but to power it down and up again. I now find uTorrent reporting 'Downloaded 1.0GB', same amount on the status bar at the bottom - but all the files are zero size, and the progress bar has returned to empty (all white). If this is going to be happening regularly I'd say WTF and go back to Azureus (yuck), which I never saw do this, and it went through system crashes and hard reboots too. Data files should NEVER be destroyed, but ALWAYS resumed. I'll give it one more try, before it feels like installing AmiPro on a PC using 26 floppy disks (circa 1996, the installer would always fail around floppy #20 upwards, making you restart the whole thing from scratch).

Otherwise, thanks for bringing this to the Mac!

Link to comment
Share on other sites

Didn't notice that option, but on the active transfer it's disabled - I'll try it if this happens again, thanks for the tip. In any case, the data files were erased automatically as soon as the app started, as the transfer began automatically, so I never even got a chance to check the files. What I complain about is that data files should -never- be erased, as they were, if the user is to even be given the 'recheck data' option.

Link to comment
Share on other sites

It seems that data retrieval differs greatly from Windows to Mac due to the background operations... where "delete" usually means "remove MFT header data for a file" it instead means "wipe data"...

I think some problems stemming from this would be fixed at the time when uT/Mac actually interfaces with the trash...

An alternate theory I've come up with, uT/Mac doesn't recheck by default FIRST if data is found. Perhaps this is some procedure which needs to be changed.

Link to comment
Share on other sites

  • 1 month later...

Hi there. I've had the same problem. It doesn't seem like you have a solution, but I thought I'd describe my scenario in case it helps you figure out what's causing it:

I'm using utorrent version on a MacBook Pro (2.2GHz, 2GB, OS X 10.5.5).

Went to bed last night with three torrents downloading (each a single file) and several seeding.

Today, when I checked on progress, I found my Mac completely unresponsive. The multi-coloured wheel was spinning, and I couldn't do anything. Tried to open Activity Monitor to identify the problem and force-quit the problematic application (although only utorrent and Skype were open), but Activity Monitor wouldn't open. Eventually I shut down by powering down completely (holding down power button), and restarted.

When I opened utorrent, I noticed that the three downloading files showed 0% in the 'Done' column (which has the grey bar that goes green as the download completes). I tried to force re-check but the option was unavailable (greyed out) so I stopped them. 'Force re-check' was then available so I did that, but they remained at 0%. In the 'downloaded' column, however, and in the status area at the bottom, it's showing the amount that had presumably been downloaded before whatever went wrong had happened, namely:

file 1: size 349 MB, downloaded 146 MB (in area at bottom: Transferred: 146.4 MB of 349.2 MB)

file 2: size 499 MB, downloaded 359 MB (Transferred: 359.9 MB of 499.4 MB)

file 3: size 349 MB, downloaded 216 MB (in area at bottom: Transferred: 216.4 MB of 349.7 MB)

I don't know whether it's the 0% indicator that's gone wrong, or the other stats. If I look at the files themselves (in my 'Downloads' folder) they each show as the complete size in 'get info', which I've noticed is always the case for files that I'm downloading via torrent, even when they're clearly not complete, so no help there.

The files that I'm seeding seem fine. Each shows as complete in the 'Done' column (tick in the middle of full green bar); each shows the correct full size in the 'Downloaded' column; each shows a different amount in the 'Uploaded' column; and in the status area at the bottom, the 'Transferred' details for each tally with these figures, including the ratio in brackets at the end. And they're seeding fine.

Anyway, I'm now going to restart the three dowloading files -- we'll see what happens, though I suspect I'll have to download each of them from scratch again.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...