Jump to content

Upload conundrum


Recommended Posts

I can download around 500 kB/s.

If a torrent has 500+ peers, I upload at 15 kB/s max

If a torrent has only a few peers - 200 peers, upload is nearly non-existent.

The Glasnost test said that my ISP does not restrict traffic.

I've turned off all software and router firewalls.

I always have a green check mark in bit torrent.

I've fooled around with bandwidth settings to no avail.. Currently they are set at the default xx/512k settings as per a speed test.

Only other settings I've changed are encryption settings, tried all three.

I'm using uTorrent 1.8.2

Any suggestion on what to try next?


Link to comment
Share on other sites

I tried turning off all the extra services and it hasn't improved, currently downloading 800 Kb/s while uploading a max of 5 Kb/s.

I stomached a Vuze download to see what would happen, and the exact same thing happens with that software... leading me to believe it's something with my ISP? I don't know why it would allow download but not upload though.

Is there anything else with my router that could be creating this problem? I have firewall turned off and the port is forwarded properly. It is a Motorola cable modem/wireless router combo, I know others have had problems sharing with the combo.

Any suggestions would be helpful, thanks.

Link to comment
Share on other sites

I doubt it's your modem/router...at worst that might make you firewalled in uTorrent, but on busy torrents (with 30+ peers and 10+ seeds) that shouldn't be a problem.

Try 'extreme' hiding tricks to get better speeds:


(Note: My post immediately following that one explains what settings in uTorrent are similar to the Azureus ones.)

Link to comment
Share on other sites

Using v.1.8.3 beta doesn't seem to have any affect.

I started out with default settings with a speed test. Since then I've tried lots of different settings, basic encryption to the 'extreme hiding tricks', turning off all 'extra features', messing with the bandwidth settings... all of which seem to have no effect.

I just opened a torrent with about 60 peers and when I watch the 'Peers' panel at the bottom, I see multiple peers connecting at an upload speed of 0.1 to 4 kB/s, each for around five-ten seconds, after which the upload speed goes to 0.1 and then to nothing.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...