Jump to content

Your Client is not compatible with Falcon Error


Recommended Posts

First, I'm not sure if this is the correct place to post this, and I didnt want to clutter the "Read this first" thread.

I just received my invite. (thank you btw) Followed the instructions, downloaded the client, created a username on the website, tried to activate Remote Access, but receive error:

Failed to connect to remote access:

Your client is not compatible with Falcon. Would you like to download the latest client?

If I select yes, I am prompted to download Falcon again, but it's the exact version I already have: 2.1 Alpha Build 17935

What am I missing?

OS: W7 Ultimate x64

Link to comment
Share on other sites

So following a hunch, I ran set uTorrent to always run as administrator, and I am able to get past the original error about compatibility. I get as far as registering a new account, and now am receiving

Registration failure:

Could not contact the Remote Access Service to register.

I've set both incoming and outgoing rules in Windows Firewall to allow for uTorrent. I can't imagine I need port forwards.

I'm not seeing the error return in a quick forum search...



So I followed the same process at the "Please register your preferred username below:" section of the process, registering a brand new username, and continued as I had previously, following the instructions, and now it works.

This tells me:

- uTorrent Falcon is set up correctly on my PC

- PC & environment related settings (OS, firewall, router, etc) are set up correctly.

- Something is hosed up with the first username I chose during the initial setup? I can only assume this would be server side, but I don't want to jump to conclusions without a firmer grasp of what's going on.

Can any Admins offer some insight?


Link to comment
Share on other sites

Answer posted to other thread:

This was a temporary problem where the minimum client version required by Falcon was inadvertently set ahead of the version available for download from the utorrent-falcon-latest.exe link on utorrent.com (where that dialog directs you). It made it impossible to connect for a few minutes. Give it a try now and you should be able to connect with build 17935.

That explains your first problem, brodie7838. As for your second issue, you shouldn't have to forward any ports. I'm glad to hear the second username worked out. If you send the username you're having trouble with to falcon@utorrent.com, we can take a look at your user record and see if anything looks amiss.

Link to comment
Share on other sites

  • 3 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...