Jump to content

How to downgrade to 1.8?


Jop

Recommended Posts

My previous uttorent was working well and I refused the upgrade to v2 until an accident click updated it. After it upgraded I found the performance of other applications while using bittorent to be unbearably slow.

Performance of browsing is bad even when im only connected to 10 peers and using half my bandwidth. In fact browsing is worse than when I was downloading at full speed with 15 to 20 peers on the old utorrent.

Although at this point I cannot confirm the following issue is uttorent 2 related...I was downloading from all 10 seeds of a torrent at 1 mb/s when I accidentaly hit the upgrade button. After it installed and reconnected to all 10 of those seeds about a minute later, the speed was only 230 kb/s.

Turning off UTP did not help either.

For your info, i am on a 10mbit connection and a network administrator.

So how can I downgrade my version?

Link to comment
Share on other sites

Thankyou for your post that does not really address any of my issues.

I will await an official reply.

At present it is looking like after many many years of using utorrent I am going to have to change to another client.

Link to comment
Share on other sites

While I waiting for a reply, I managed to find version 1.8.5

Installed it and all the issues I had when upgrading have gone away. Browsing is again fine when downloading.

Sorry I wasn't aware your reply was an official one, you really should get a title under your name for it to be more clear :)

So while your official line is you do not support downgrading, its official that it has solved my problems.

Many thanks for your time.

Link to comment
Share on other sites

The problem was utorrent 2. Downgrading it to 1.8.5 solved the issue, whether supported or not.

So it appears I did not cover up a problem as I have no problems on 1.8.5. I removed the problem with was v2.

Whilst I appreciate the work that has gone into utorrent and the ability to use it for free, I have to say I am not impressed with the attitude of the support staff here.

Link to comment
Share on other sites

And I'm not impressed with your refusal to even ATTEMPT to troubleshoot the issue. All you have done is demand how to downgrade, all the while refusing to even attempt to follow our normal troubleshooting guides by refusing to provide the information that we REQUIRE in order to be able to troubleshoot your issue.

Link to comment
Share on other sites

I will supply the info below, but at present see no reason to upgrade again at present. If it aint broke, don't fix it :)

-- Virgin Media

-- 10000 kbps

-- Ethernet connected direct cable modem (Webstar EPC2100)

-- TCP/IP patch - yes (50)

-- Software firewalls - Windows own firewall

-- Nod 32 v4 AV (not full suite - checked with AV disabled, utorrent 2 still causes slowdwn)

-- µTorrent settings

Connection tab

only windows firewall exception checked/port 27500

Bandwidth tab

Maximum upload rate - Currently set at 50

Global connections set to 300

Maximum peers per torrent 25

Number of upload slots per torrent 10

Use additional upload slots if speed is <90% ticked.

Bittorent tab

Ask for tracker scrape information is the only one ticked.

Outgoing encryption set to forced.

Link to comment
Share on other sites

Well thankyou again for your helpful response.

I will not be uninstalling my AV software and for you to suggest to users of your software that they do this is not really responsible considering all the nasties out there.

If there are issues with utorrent v2 with AV software and there is not with version 1.8.* then it suggests that the issue is firmly placed with changes you made in the new utorrent version.

My AV software works fine with 1.8.4, so I will just choose not to upgrade to any newer versions, unless utorrent resolves it issues.

Many thanks for your time.

Link to comment
Share on other sites

1) I have used Nod32 and utorrent together for years without issues.

2) I have not updated to a new version of Nod32 recently

3) I did upgrade my uttorent

4) problems started after the upgrade

Even if is IS a conflict with Nod32, if Nod32 has not been updated but utorrent has, then it is obvious the changes in utorrent have caused the issues to surface. Especially as the issue is not there in 1.8.5

Having worked with computers/software for over 25 years, in both software testing and software support in that time, I can be happily confident with what I am saying.

Link to comment
Share on other sites

I don't require you to believe me but do find it funny that you have chosen to call me a liar ;)

Gotta be the most unfriendly and aggressive support I have ever seen.

Anyway, I am sticking with utorrent 1.8.5. It works, it does the job and I require none of the new features in version 2.

You may now close/finish this thread. Thankyou for your time and your posts, it has been entertaining although it shouldn't have been ;)

Link to comment
Share on other sites

So you just proved that you don't actually want the problem fixed.

I run 2.0 on my systems WITHOUT PROBLEMS.

I also don't use NOD32.

Your refusal to even consider TRYING with it TEMPORARILY uninstalled proves to me that:

1> You don't want the problem fixed.

2> You believe the problem is somewhere that it isn't.

Also, try the 2.0.1 RC and 2.1 alphas before you write it off as broken.

Link to comment
Share on other sites

As I said before I am not prepared to uninstall my AV which works perfectly fine with all other apps, including utorrent 1.8.5. While I always like running the latest version of software, I will not be doing so in the case.

I would have been willing to carry out less invasive tests.

Software often runs ok on one system but not on another. It is obvious that changes to the utorrent code from v1.8.* to v2 have changed in such a way that it causes issues on some systems. Whether it be an issue with another product, its the changes in utorrent that have made it visible and has caused it to show.

This thread has turned more from support and into a debate and frankly I feel I am dealing with someone who is towing the company line of saying there is no issues with their software and wants everyone on their latest version. Along with that I am doubting the intelligence and experience of the person I am debating with. Not to mention their professionalism.

Link to comment
Share on other sites

I would have been willing to carry out less invasive tests.

Then where's the complete list of information the troubleshooting guide requested? I will admit part of it is present, but not all of it is.

I feel I am dealing with someone who is towing the company line of saying there is no issues with their software and wants everyone on their latest version.

Except I'm not saying there are absolutely no issues. And there's something you're excluding from the information you're providing (either purposefully or accidentally) that may reveal the root cause of the problem you're experiencing.

Link to comment
Share on other sites

I provided all the information that this thread said I should include: Index » Troubleshooting » Reminder: Content rules apply here too

In Nod32 I already had utorrent.exe unchecked in the HTTP scanning preferences.

Therefore it is not clear what other information you required.

My OS is windows XP sp3. I have 1gig of memory, 2 sata hard disks with plenty of space.

Browsing was slow in Chrome, firefox (firefox is set to use a ramdisk for temp files etc, so we can rule out disk access issues) and windows explorer, all the latest version.

If there is more specific info you require, then ask for it. I knew giving you the info from the preferences screen would be no use, but I supplied it anyway.

Even if I uninstalled Nod32 and found the problem went away, I would rather use utorrent 1.8.5 and keep using Nod32 than have to ditch it just to use utorrent V2.

Link to comment
Share on other sites

1. No modified advanced settings

2.

Logfile of HijackThis v1.99.1

Scan saved at 12:37:50, on 09/04/2010

Platform: Windows XP SP3 (WinNT 5.01.2600)

MSIE: Internet Explorer v8.00 (8.00.6001.18702)

Running processes:

C:\WINDOWS\System32\smss.exe

C:\WINDOWS\system32\winlogon.exe

C:\WINDOWS\system32\services.exe

C:\WINDOWS\system32\lsass.exe

C:\WINDOWS\system32\svchost.exe

C:\WINDOWS\System32\svchost.exe

C:\WINDOWS\system32\svchost.exe

C:\WINDOWS\system32\spoolsv.exe

C:\WINDOWS\Explorer.EXE

C:\WINDOWS\system32\RUNDLL32.EXE

C:\Program Files\ESET\ESET NOD32 Antivirus\egui.exe

C:\WINDOWS\system32\rundll32.exe

C:\Program Files\Vtune\TBPanel.exe

C:\Program Files\Logitech\SetPoint\SetPoint.exe

C:\Program Files\Common Files\Logishrd\KHAL2\KHALMNPR.EXE

C:\WINDOWS\system32\crypserv.exe

C:\Program Files\ESET\ESET NOD32 Antivirus\ekrn.exe

C:\Program Files\Common Files\MAGIX Services\Database\bin\FABS.exe

C:\Program Files\Java\jre6\bin\jqs.exe

C:\WINDOWS\system32\nvsvc32.exe

C:\WINDOWS\system32\PnkBstrA.exe

C:\WINDOWS\system32\svchost.exe

C:\WINDOWS\system32\wuauclt.exe

C:\WINDOWS\System32\svchost.exe

C:\Documents and Settings\D\Desktop\HijackThis.exe

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.google.co.uk/

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyServer = 127.0.0.1:4444

R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyOverride = local;*.local

O2 - BHO: AcroIEHelperStub - {18DF081C-E8AD-4283-A596-FA578C2EBDC3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelperShim.dll

O2 - BHO: (no name) - {5C255C8A-E604-49b4-9D64-90988571CECB} - (no file)

O2 - BHO: Windows Live Sign-in Helper - {9030D464-4C02-4ABF-8ECC-5164760863C6} - C:\Program Files\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll

O2 - BHO: Java Plug-In 2 SSV Helper - {DBC80044-A445-435b-BC74-9C25C1C588A9} - C:\Program Files\Java\jre6\bin\jp2ssv.dll

O2 - BHO: JQSIEStartDetectorImpl - {E7E6F031-17CE-4C07-BC86-EABFE594F69C} - C:\Program Files\Java\jre6\lib\deploy\jqs\ie\jqs_plugin.dll

O4 - HKLM\..\Run: [NvMediaCenter] RUNDLL32.EXE C:\WINDOWS\system32\NvMcTray.dll,NvTaskbarInit

O4 - HKLM\..\Run: [egui] "C:\Program Files\ESET\ESET NOD32 Antivirus\egui.exe" /hide /waitservice

O4 - HKLM\..\Run: [Kernel and Hardware Abstraction Layer] KHALMNPR.EXE

O4 - HKLM\..\Run: [bluetoothAuthenticationAgent] rundll32.exe bthprops.cpl,,BluetoothAuthenticationAgent

O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\system32\NvCpl.dll,NvStartup

O4 - HKCU\..\Run: [TBPanel] C:\Program Files\Vtune\TBPanel.exe /A

O4 - HKCU\..\Run: [Google Update] "C:\Documents and Settings\D\Local Settings\Application Data\Google\Update\GoogleUpdate.exe" /c

O4 - Global Startup: Logitech SetPoint.lnk = C:\Program Files\Logitech\SetPoint\SetPoint.exe

O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe

O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe

O11 - Options group: [iNTERNATIONAL] International

O17 - HKLM\System\CCS\Services\Tcpip\..\{25CE5356-6C93-4839-86F2-FEDAC6E0A3AA}: NameServer = 4.2.2.2,194.168.8.100

O17 - HKLM\System\CCS\Services\Tcpip\..\{853005F2-2C24-4A4D-9D88-BE92E9078491}: NameServer = 4.2.2.2

O17 - HKLM\System\CCS\Services\Tcpip\..\{EDD06582-C951-46EC-869E-905DDF1A4166}: NameServer = 4.2.2.2

O17 - HKLM\System\CS1\Services\Tcpip\..\{25CE5356-6C93-4839-86F2-FEDAC6E0A3AA}: NameServer = 4.2.2.2,194.168.8.100

O17 - HKLM\System\CS2\Services\Tcpip\..\{25CE5356-6C93-4839-86F2-FEDAC6E0A3AA}: NameServer = 4.2.2.2,194.168.8.100

O18 - Protocol: livecall - {828030A1-22C1-4009-854F-8E305202313F} - C:\PROGRA~1\WI1F86~1\MESSEN~1\MSGRAP~1.DLL

O18 - Protocol: msnim - {828030A1-22C1-4009-854F-8E305202313F} - C:\PROGRA~1\WI1F86~1\MESSEN~1\MSGRAP~1.DLL

O20 - Winlogon Notify: dimsntfy - %SystemRoot%\System32\dimsntfy.dll (file missing)

O20 - Winlogon Notify: LBTWlgn - c:\program files\common files\logishrd\bluetooth\LBTWlgn.dll

O20 - Winlogon Notify: WgaLogon - C:\WINDOWS\SYSTEM32\WgaLogon.dll

O21 - SSODL: WPDShServiceObj - {AAA288BA-9A4C-45B0-95D7-94D524869DB5} - C:\WINDOWS\system32\WPDShServiceObj.dll

O23 - Service: Crypkey License - CrypKey (Canada) Ltd. - C:\WINDOWS\SYSTEM32\crypserv.exe

O23 - Service: ESET HTTP Server (EhttpSrv) - ESET - C:\Program Files\ESET\ESET NOD32 Antivirus\EHttpSrv.exe

O23 - Service: ESET Service (ekrn) - ESET - C:\Program Files\ESET\ESET NOD32 Antivirus\ekrn.exe

O23 - Service: FABS - Helping agent for MAGIX media database (Fabs) - MAGIX AG - C:\Program Files\Common Files\MAGIX Services\Database\bin\FABS.exe

O23 - Service: Firebird Server - MAGIX Instance (FirebirdServerMAGIXInstance) - MAGIX® - C:\Program Files\Common Files\MAGIX Services\Database\bin\fbserver.exe

O23 - Service: Java Quick Starter (JavaQuickStarterService) - Unknown owner - C:\Program Files\Java\jre6\bin\jqs.exe" -service -config "C:\Program Files\Java\jre6\lib\deploy\jqs\jqs.conf (file missing)

O23 - Service: Logitech Bluetooth Service (LBTServ) - Logitech, Inc. - C:\Program Files\Common Files\Logishrd\Bluetooth\LBTServ.exe

O23 - Service: lxbu_device - Lexmark International, Inc. - C:\WINDOWS\system32\lxbucoms.exe

O23 - Service: NVIDIA Display Driver Service (NVSvc) - NVIDIA Corporation - C:\WINDOWS\system32\nvsvc32.exe

O23 - Service: PnkBstrA - Unknown owner - C:\WINDOWS\system32\PnkBstrA.exe

You want a DLL list from process explorer while running v2? Running version 1.8.5 and process explorer shows no child process's or dll's used.

Link to comment
Share on other sites

Process PID CPU Description Company Name

System Idle Process 0 94.62

Interrupts n/a 0.77 Hardware Interrupts

DPCs n/a 0.77 Deferred Procedure Calls

System 4

smss.exe 1580 Windows NT Session Manager Microsoft Corporation

csrss.exe 1676 Client Server Runtime Process Microsoft Corporation

winlogon.exe 1704 Windows NT Logon Application Microsoft Corporation

services.exe 1748 0.77 Services and Controller app Microsoft Corporation

svchost.exe 1948 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 2016 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 928 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 968 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1056 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1356 Generic Host Process for Win32 Services Microsoft Corporation

spoolsv.exe 1564 Spooler SubSystem App Microsoft Corporation

svchost.exe 1480 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1016 Generic Host Process for Win32 Services Microsoft Corporation

Crypserv.exe 1040 CrypKey NT Service CrypKey (Canada) Ltd.

ekrn.exe 1152 ESET Service ESET

FABS.exe 1216 Verzeichnisüberwachung und Hilfsaufgaben für die Medienbibliothek MAGIX AG

jqs.exe 1256 Java Quick Starter Service Sun Microsystems, Inc.

nvsvc32.exe 1308 NVIDIA Driver Helper Service, Version 182.50 NVIDIA Corporation

PnkBstrA.exe 1324

svchost.exe 1468 Generic Host Process for Win32 Services Microsoft Corporation

alg.exe 2704 Application Layer Gateway Service Microsoft Corporation

svchost.exe 2980 Generic Host Process for Win32 Services Microsoft Corporation

lsass.exe 1760 LSA Shell (Export Version) Microsoft Corporation

explorer.exe 452 Windows Explorer Microsoft Corporation

rundll32.exe 892 Run a DLL as an App Microsoft Corporation

egui.exe 900 ESET GUI ESET

rundll32.exe 948 Run a DLL as an App Microsoft Corporation

TBPANEL.exe 1012 Vtune : Display Control Panel

SetPoint.exe 1132 Logitech SetPoint Event Manager (UNICODE) Logitech, Inc.

KHALMNPR.exe 1828 Logitech KHAL Main Process Logitech, Inc.

chrome.exe 3980 Google Chrome Google Inc.

chrome.exe 768 Google Chrome Google Inc.

chrome.exe 2100 Google Chrome Google Inc.

chrome.exe 3768 Google Chrome Google Inc.

utorrent.exe 1488 1.54 µTorrent BitTorrent, Inc.

procexp.exe 2712 1.54 Sysinternals Process Explorer Sysinternals - www.sysinternals.com

Process: utorrent.exe Pid: 1488

Name Description Company Name Version

ACTIVEDS.dll ADs Router Layer DLL Microsoft Corporation 5.1.2600.5512

adsldpc.dll ADs LDAP Provider C DLL Microsoft Corporation 5.1.2600.5512

ADVAPI32.dll Advanced Windows 32 Base API Microsoft Corporation 5.1.2600.5755

ATL.DLL ATL Module for Windows XP (Unicode) Microsoft Corporation 3.5.2284.2

CLBCATQ.DLL Microsoft Corporation 2001.12.4414.700

COMCTL32.dll User Experience Controls Library Microsoft Corporation 6.0.2900.5512

comdlg32.dll Common Dialogs DLL Microsoft Corporation 6.0.2900.5512

COMRes.dll Microsoft Corporation 2001.12.4414.700

CRYPT32.dll Crypto API32 Microsoft Corporation 5.131.2600.5512

ctype.nls

DnsApi.dll DNS Client API DLL Microsoft Corporation 5.1.2600.5625

GameHook.dll Logitech Gaming Hook (UNICODE) Logitech, Inc. 4.72.40.0

GDI32.dll GDI Client DLL Microsoft Corporation 5.1.2600.5698

hnetcfg.dll Home Networking Configuration Manager Microsoft Corporation 5.1.2600.5512

ICMP.DLL ICMP DLL Microsoft Corporation 5.1.2600.5512

IMM32.DLL Windows XP IMM32 API Client DLL Microsoft Corporation 5.1.2600.5512

Iphlpapi.dll IP Helper API Microsoft Corporation 5.1.2600.5512

kernel32.dll Windows NT BASE API Client DLL Microsoft Corporation 5.1.2600.5781

lgscroll.dll Logitech Scroll Enabler (UNICODE) Logitech, Inc. 4.72.40.0

locale.nls

LPK.DLL Language Pack Microsoft Corporation 5.1.2600.5512

MPRAPI.dll Windows NT MP Router Administration DLL Microsoft Corporation 5.1.2600.5512

MSASN1.dll ASN.1 Runtime APIs Microsoft Corporation 5.1.2600.5875

msctfime.ime Microsoft Text Frame Work Service IME Microsoft Corporation 5.1.2600.5768

MSVCR80.dll Microsoft® C Runtime Library Microsoft Corporation 8.0.50727.4053

msvcrt.dll Windows NT CRT DLL Microsoft Corporation 7.0.2600.5512

mswsock.dll Microsoft Windows Sockets 2.0 Service Provider Microsoft Corporation 5.1.2600.5625

netapi32.dll Net Win32 API DLL Microsoft Corporation 5.1.2600.5694

ntdll.dll NT Layer DLL Microsoft Corporation 5.1.2600.5755

NTMARTA.DLL Windows NT MARTA provider Microsoft Corporation 5.1.2600.5512

ole32.dll Microsoft OLE for Windows Microsoft Corporation 5.1.2600.5512

oleaut32.dll Microsoft Corporation 5.1.2600.5512

rasadhlp.dll Remote Access AutoDial Helper Microsoft Corporation 5.1.2600.5512

RPCRT4.dll Remote Procedure Call Runtime Microsoft Corporation 5.1.2600.5795

rsaenh.dll Microsoft Enhanced Cryptographic Provider Microsoft Corporation 5.1.2600.5507

rtutils.dll Routing Utilities Microsoft Corporation 5.1.2600.5512

SAMLIB.dll SAM Library DLL Microsoft Corporation 5.1.2600.5512

Secur32.dll Security Support Provider Interface Microsoft Corporation 5.1.2600.5834

SETUPAPI.dll Windows Setup API Microsoft Corporation 5.1.2600.5512

SHELL32.dll Windows Shell Common Dll Microsoft Corporation 6.0.2900.5622

shfolder.dll Shell Folder Service Microsoft Corporation 6.0.2900.5512

SHLWAPI.dll Shell Light-weight Utility Library Microsoft Corporation 6.0.2900.5912

sortkey.nls

sorttbls.nls

unicode.nls

USER32.dll Windows XP USER API Client DLL Microsoft Corporation 5.1.2600.5512

USERENV.dll Userenv Microsoft Corporation 5.1.2600.5512

USP10.dll Uniscribe Unicode script processor Microsoft Corporation 1.420.2600.5512

utorrent.exe µTorrent BitTorrent, Inc. 2.0.0.18488

uxtheme.dll Microsoft UxTheme Library Microsoft Corporation 6.0.2900.5512

VERSION.dll Version Checking and File Installation Libraries Microsoft Corporation 5.1.2600.5512

WLDAP32.dll Win32 LDAP API DLL Microsoft Corporation 5.1.2600.5512

WS2_32.dll Windows Socket 2.0 32-Bit DLL Microsoft Corporation 5.1.2600.5512

WS2HELP.dll Windows Socket 2.0 Helper for Windows NT Microsoft Corporation 5.1.2600.5512

wshtcpip.dll Windows Sockets Helper DLL Microsoft Corporation 5.1.2600.5512

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...