Jump to content

Bandwidth Allocation isnt working anymore....what happened?


Recommended Posts


I have utorrent version 2.0.4, which I've been using for weeks without a problem.

But just yesterday, the "Bandwidth Allocation" stopped working. For no reason! It's always worked without incident over the last many years I've been using utorrent.

Now, no matter what I set the upload or download speeds to, it seems to uploading/downloading at the same speed as if I'd set it to "unlimited". Of course, it doesnt say it's on Unlimited, it still shows the speeds I choose, but those arent the speeds it's using.

So in a nutshell, when I set the upload/download to say, 1 kb/sec, it's still uploading/downloading at a high speed. Why?

Did I perhaps change something accidentally? I cant find a setting within the setting that seem to control this.


Link to comment
Share on other sites

Thank you!!!

Unfortunately, for noobs like me, knowing what terms like Global rate limit options, and Transport Overhead actually mean, would only come from doing homework on all the workings of utorrent.

And foolish/lazy people sure hate homework.

It would be nice if the preferences were a bit more noob-friendly, as far as the terminology. Us old people certainly dont take to these things as quickly as the younger fish do.

So thanks, what you mentioned certainly solved that problem.

Much appreciated!!

Link to comment
Share on other sites

  • 9 months later...
Apply rate limit to uTP connections and to overhead (in preferences)

Hello, I have the same problem and when I use this setting my overall download speed drops to nearly 0.

Any suggestions ?

In older versions you could put in an upload limit for each torrent. Why isn't that working anymore ?


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...