Jump to content

uTorrent 3 - dl/ul speed limit don't seem to work


Recommended Posts


I upgraded to uTorrent 3 and the Scheduler Speed Limits don't seem to work.

Is it only me or it is a known bug or something?

It's not just scheduler that is affected, it is the speed limits in general. Whatever limit is set, uTorrent always downloads or uploads using the full bandwidth.

Is there a possible fix for that?


Link to comment
Share on other sites

apply rate limit to uTP

just like everyone else with this issue


Thanks for your reply, but this option was already checked. However, there is another option above called: Apply rate limit to transport overhead which I selected now and it seems like that didn't do anything either.

Well, it's weird because when a global upload speed is set to 20kB/s uTorrent's upload speed is still 500kbps.

Link to comment
Share on other sites


I think I'm going back to v2.xx

When an upload limit is applied this is what status bar is showing:


20KB/s is applied, but uTorrent is uploading at 37.1KB/s.

Downgrading to 2.x version didn't help. The problem remains...

Link to comment
Share on other sites

Reset your settings to sane limits. The limits you have (number of active torrents, etc) are the core of your issue.

I see, but regardless the settings, the speed rate limit, when applied, should, as always, work.

I always have them settings, only these settings allowed me to use the maximum of my bandwidth, but when a speed limit was applied, it just worked. Now it doesn't work at all. Version 3.0 messed up something.

Link to comment
Share on other sites

Due to the math involved in connection limits and numbers of active torrents, the settings you're using are NOT supported.

Reset your settings to match the speed limits of your connection using the setup guide (ctrl+g)

Why do I have to do that now? It always worked fine, so why now, when I upgraded to 3.0 (and then downgraded to 2.2.1)?

I understand what these numbers do etc, but my speed limit ALWAYS worked fine prior to 3.0 update...

Anyways, I reset my settings, left them according to the wizard and we'll see.

I bet my upload bandwidth won't get used properly now.

Currently, uTorrent is uploading at avarage speed of 300kbps, less than a half of my upload speed 832kbps.

Link to comment
Share on other sites

  • 2 months later...

Hey, I was reading this because I had the same problem. I was going through all the Utorrent settings and I thought there might be a conflict with the DL/Upload with the "scheduler" For me personally, by disabling the scheduler, it fixed the issue. Without the scheduler enabled, I am able to set my download rate to what I want.

Let me know if this doesn't explain it clearly. Good luck

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...