Jump to content

Uploading to myself???


Recommended Posts


I just discovered an interesting "bug", at least that's all I can think it is with what I see.

I downloaded some torrents and after they completed, I thought I'd just leave them open for sharing reasons (golden rule!). The weird part came when I tried to check to whom I am uploading. As spoiled by the title, I was uploading to non other than myself! The torrents were completed in my torrent list, whereas they were around 72% and 95% on the uploading peers list, that is to myself's system. To provide more details:

I was uploading to "my-ip-address" [uTP], Flags U IEP.

The system I use is Windows XP (yup, still) and I have a network NAS drive, WD 2TB where I was currently downloading the torrents in talk. I have a feeling that the network drive has something to do with it. I also have ftp open, but I checked, no movement was performed at the moment.

So why was that happening??

Thanks, hope we solve the mystery together.

Link to comment
Share on other sites

I am sure, yup. I checked with my neighbours although the possibility of them simultaneously downloading the same torrents from the same private tracker was extremely low. Furthermore, more of my torrents started behaving like that! After I restarted utorrent, this phenomenon stopped.

In general, I think this happened when I downloaded something and left it to upload afterwards without restarting utorrent in the meanwhile. If you want to, I could try to re-create this in the same way. Otherwise, let me know any further information you need!

Link to comment
Share on other sites

Ok it does not only occur under those circumstances, it happened as I re-opened utorrent now.

New screenshot as well, this time my ip appears twice (and it did 3 times, too), with a different utorrent client, as well!


It's getting weirder and weirder. A friend suggested I might be using my WD's Network disk built-in torrent client, but I don't know whether mine has this feature nor I have done anything to launch it.

Link to comment
Share on other sites

Hello again,

after running some restarts on my router/network hdd, the results remained the same.

So, I attempted updating my μtorrent to the latest available for me, 3.1.3. It presented the same behaviour, uploading to myself once again :)

This time, in my attempt for a new torrent download, it appeared that I am downloading from myself as well! The screenshot below is from that phenomenon. The weird part is that it shows that it shows that I'm "self-downloading" from my previous μtorrent version, 3.1.2, whereas I now use 3.1.3.


The only thing I haven't tried is if it behaves similarly when I'm downloading to my inner HDD and not the network HDD. Still though, is there really an issue with the network disks??

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...