Jump to content

No access to WebUI


Recommended Posts

Hi all,

hope someone could help me to solve this issue. For sure there's something I'm missing, but still stuck with no solution. uTorrent is running in a Win7 machine. I am unable to access to the web client neither from another machine in the same LAN (Ubuntu+Firefox/Chrome) nor from the localhost where WebUI is running (Win7+Firefox/Chrome).

The following message is displayed after the browser asks for a user and a password when pointing to this address (

"The µTorrent WebUI does not seem to be installed. Click here to try to install it, or see the guide for more details."

When I click to install in the messages displayed in the browser, nothing happens: no file appears in any folder.

What I did was:

-Install uTorrent (3.2). Change the port for incoming connexions to X. Open the port and forward it to this machine in the router. Everything works flawlessly till here.

-The Win7 machine where uTorrent is running has several users, and I wanted to "unifiy" the management. So I decided to move settings.dat and all the rest from %appdata% to %programfile%. More accurately. this things are now placed in "C:\Program Files (x86)", where I found a uTorrent folder.

-Then I downloaded the client from the "Primary WebUI forum thread" and renamed to "webui.zip". I placed it in the folder where settings.dat is.

-I went to uTorrent and activated WebUI service, ticked "use another port" (now Y), and established a user and a password.

What am I doing wrong? What do I miss here?

Thanks a lot in advance,


Link to comment
Share on other sites

Oops, misstyping. 2 and 5 are too near for my trembling fingers.

Thanks for your answer! I edited the first post.

In fact, it is 3.2 (build 27708) 32 bit. I also downloaded the latest version of WebUI available in the thread.

What keeps me puzzled about this is: the service is hearing in the alternate port and answers when the browser makes the request... isn't it? Because if not, the browser should not retrieve any page at all.

So I could consider WebUI properly installed... It's just then an authentication issue? It should not, because user/password are for the moment trembling fingers proof :)

Maybe accessing the service from a PC in the same LAN.. but I am using my inside IP, not the NAT one given to the router in the outside...

I gave a try to guest account option (user guest, pwd left blank), with no success at all again; I just got an "invalid link 192 168 34550 gui guest" from the browser itself. Since then, until I close the browser every request leads to this "invalid link" message, and if I try "http://myIP:UTport/gui/?action=setsetting&s=webui.cookie&v={}", what I get is a webpage with just a message of "invalid request". Cleaning the cache solves nothing, just closing the browser.

EDIT: it is so strange the message "invalid link 192 168 34550 gui guest". Maybe guest account is not working properly because this message should be "invalid link 192 168 11 34550 gui guest", shouldn't it?

So.. I'm lost. Perhaps everything is related to a faulty uTorrent installation and it's not a WebUI fault? In a multiuser environment, I read moving %appdata/utorrent% stuff to "C:/Program Files(x86)/utorrent" is enough, isn't it?

Link to comment
Share on other sites

uTorrent has "add Firewall exceptions" enabled, as "UPnP" and "NAT" in preferences.

I have just tried the test tool included in uTorrent's setup (clicking in the bottom right corner), and both 2 tests are concluded with success, and values are suggested to improve P2P performance.

Link to comment
Share on other sites

Maybe a faulty installation... I don't like installing, removing, reinstalling in a OS like the one from Redmond, but probably the last option is remove both uTorrent and WebUI and start again frome the very beggining. There's something about uTorrent not displaying a .torrent.loaded that keeps me wondering if something is not going well with it...

Link to comment
Share on other sites

Sorry! That was an error from mine, using remote desktop has this things. I was using another PC from the LAN, so localhost had no sense at all there.

Going to http://localhost:34782/gui/ in the win7 pc where uTorrent is running makes the browser ask for user/pwd.

-With the user/pwd account configured:

"The µTorrent WebUI does not seem to be installed. Click here to try to install it, or see the guide for more details."

-With the guest account:

"Oops broken link"

Sorry again for the error.

Link to comment
Share on other sites

I downloaded the file from the thread (utorrent-webui.2012050518174554.zip) and changed the name to webui.zip. Left it in C:/Program Files(x86)/uTorrent.


But I have found another webui.zip in the user directory (/appdat/roaming/utorrent). I have removed it from there (in fact, removed the entire folder) and rebooted the machine. I will post what happens next.

Link to comment
Share on other sites

Ok, after removing the file I found in %appdata% (maybe it was there after clicking in install in the message "The µTorrent WebUI does not seem to be installed. Click here to try to install it, or see the guide for more details."), when I point to localhost:port/gui/ I get the user/pwd box, as usual.

I write there user and pwd... and browser shows the screen of "oops broken link", and in the url box the following address can be read: localhost:port/gui/guest.html.

If I try with guest account (user:guest, pwd: blank), again the same: broken link.

If I try to log leaving both fields empty, keeps asking for a user and a pwd.

Tomorrow I will try again. It's late here now :)

Link to comment
Share on other sites

Ok, so finally a fresh install solved the problem, WebUI works flawlessly now.

Maybe it was related to something I did wrongly when installing uTorrent itself (less likely) or something related to the fact I found a copy of webui.zip in %appdata/utorrent%, besides the copy that already was in %programfiles/utorrent%.

To sum up -altough it's obvious and well explained in main thread-, for a uTorrent multiuser environment:

-webui.zip should be in %programfiles/utorrent%, with the rest of .dat troop

-leave empty %appdata/utorrent% folders

Many thanks to DreadWingKnight!! You gave a hand in the tshoot process that finally solved the problem.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...