Jump to content

Windows firewall - How to block if not going thru VPN new prob solved


swamibob

Recommended Posts

When I updated to the new 3.3.2 version today and copied my vpn settings for my older version of utorrent in windows firewall(since I was not sure if I was going to stick with the new version, i made a duplicate so if I switched back I wouldn't have to go back into the firewall settings and change it back), then tried to change the path to the new default directory. It was not blocking utorrent when I was not on the VPN like it used to. I figured out that by browsing and selecting the new directory/utorrent.exe, it used the %appdata%/ directory structure. When it was like that, it would not pay attention to the firewall rules I had setup for it. Once i changed it to C:\users\swami\appdata\roaming\utorrent\utorrent.exe in the programs and services tab of the firewall it started working properly again. I guess it needs an absolute path. For anyone else who wants to set this up, I will explain below.

open the windows firewall and add a new inbound rule

In the general tab - tick block the connection

In the program and services tab - make sure it has an absolute path to the utorrent.exe and not the %appdata%

Protocols and Ports - for protocol type select any

Advanced - check the boxes for domain and private (but do not check public) and block edge traversal

The other tabs not mentioned are left blank

Do the same settings for outbound rules

I also deleted the rules the utorrent made by itself when it installed. Also make sure that you uncheck in utorrent connection settings all 4 boxes, the upnp port map, nat-pmp, randomize port, and firewall exception. If you do not, some data may leak by and you will not be secure on your vpn like you think you are.

This works for me since my vpn shows up as a public network, so with the rules you added, you are telling the firewall to block all connections to private and domain, but not public since you left that box unchecked. This way, only when the vpn is running will it allow the connection to go out.

I still don't know why the %appdata% path didn't work right, since I used the browse button in the windows firewall program, but until I changed it to the exact path, it was letting me connect whether I was on the VPN or not.

You can test if the above rules are working for you by either clicking on a torrent without being logged into you vpn and making sure that the torrent won't start getting data, or by being on the vpn and downloading, and then turning off your vpn. If you are on the vpn and turn it off, you should immediately see the upload and download speed start to drop until it stops completely in 10 secs or so. I think it doesn't drop instantly do the the way that utorrent is buffering some of the data or maybe some averaging is involved. Either way, this has worked for me, and I don't worry when I go to bed or leave with transfers going. I know it will not keep transferring data if my VPN goes out on me when I am not watching it.

Hope this helps someone out.

Link to comment
Share on other sites

  • 6 months later...

I followed these step and added the Interface Types option as well. This is found in the Advanced tab of the Windows Firewall Advanced Settings. I applied the blocking rules to Local Area Network and Wireless Network interface types. I also applied it to the Home and Work profiles. I then applied the allowed rules to the Remote Access interface type and the Public profile as suggested here. I felt this better ensured I was only affecting my PPTP connection.  Tested successfully. 

 

Windows 7 Ultimate

uTorrent Plus 3.4.2 (Bld 32354)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...