Jump to content

[Solved] uTorrent slow, Vuze faster


Recommended Posts


First I would like to start off by saying I have a very complicated network connection... I can't tell you exactly how it is set up, because I do not know. My ISP is a wanker, and I am behind some sort of double NAT'd network configuration. Possibly a CGNAT/LSN of some sort. I don't precisely know. The main problem I have is that I cannot forward any ports, and I have a private IP address.

After following many setup guides, recommendations on the forums as well as YouTube guides. I have decided to finally post. I would like to mention that I do have a green network icon in uTorrent. I'll post some screenshots below..

My Speed Test


uTorrent Settings




*I only just recently disabled DHT, as I read somewhere to try that. It didn't make a difference whether it was on or off.

I have not touched the advanced settings.

The torrent in question is Ubuntu 13. In uTorrent I am only achieving speeds of about 5-10kb/s on average. Sometimes it will spike to 50-60kb/s but never anything higher. In Vuze, I am getting around 700-900kb/s on the same torrent. I am not sure, but I think it's worth noting that my upload speed is nearly always maxed (34kb/s).

Now, I hate Vuze. I only installed it to try and see what would happen because some forums recommended it for it's RC4 encryption. I am not sure if this is the solution to my issue or not.. But I don't want to use Vuze and I want to figure out how to fix whatever is going on here. I know it's difficult because of my situation (ISP NAT) but I am hoping somebody can help :)

Link to comment
Share on other sites

Ok... Thanks for the reply.

So I have uninstalled uTorrent 3.4 and reinstalled uTorrent 3.3. I have also removed all the uTorrent files in AppData/Roaming/uTorrent. Followed these two guides:



And still am having the same issues. I am using Windows Firewall, which I have checked to allow incoming and outgoing connections for uTorrent. I have also tried removing the items from the allowed lists and letting Windows recreate them on it's own.


After uninstalling uTorrent, clearing all settings files, downloading uTorrent 2.2.1, and installing that. I followed the guide for conservative torrenting, with a few tweaks to the numbers, and am no longer having issues. Speeds have returned to normal, it's hard to say if this is a version issue, configuration issue on my part, or something my ISP has done. Anyway... Solved.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...