Jump to content

Trouble downloading/finding peers


Recommended Posts

Over the last week utorrent has stopped working for me, up until i just updated it it would just sit at connecting to peers and just now with the update shows downloading but nothing is happening,


I know for sure it's allowed through the firewall and i have both uninstalled and reinstalled it multiple times with and without a anti-virus and checked to see if it would run with no luck.


i have also tried it on a laptop as well and no change.


Would love any help you could pass along and thank you for your time and reading.



Os -  Windows 7 home premium


Version -µTorrent Stable (3.4 build 30596)


Isp - Virgin mobile broadband to go


Others - Windows firewall, Microsoft security essentials.


Edit : Tried Known legal and working torrents (the slackware one and a few others i know for a fact should have no issue)  


Also all trackers (Dht, local peer discovery and peer exchange are showing not allowed and the main tracker is saying connection closed)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...