Jump to content

carrier grade NAT


Recommended Posts

Up until about 3 weeks ago I had used uTorrent with no problems for many years.


Then my ISP implimented carrier grade NAT - I believe because they can not yet impliment IPv6.


Now all my torrents stop on 'Connecting to peers' and my little icon is yellow or red.


I have tried everything (I think)


Tested the incoming port - OK

Changed the incoming port - no change

Ensured the port was open in my router, both UDP and the other one - no change

Stopped my firewall (Windows) - no change

Stopped my anti-virus (again, windows) - no change

Uninstalled then re-installed utorrent after deleting all settings - no change

Tried an older version of uTorrent - no change

I tried another bit torrent agent, Tixati - worked fine


Have I missed anything or is utorrent unable to work with carrier grade NAT?


For those who haven't met carrier grade NAT it means you are going through two NAT processes, first at your router then at the ISP. You can see this as the router shows one IP address but if you check your IP address from elsewhere you get a differnt IP address. It is being done by ISP's who have run out of IPv4 addresses and can not use IPv6 yet and it means that many of their customers show the same IP address to the outside world.



Link to comment
Share on other sites

What tracker status do you end up with?


Sorry, tracker status always ends up as 'connection timed out'


DHT finds a few nodes, sometimes 1, at the moment 9 - a pathetically small number.


Number of peers is 0


As a comparision Tixati, on the same torrents, has only 1 of the 6 trackers timed out and has 256 nodes on DHT. Piratebay shows over 4,000 seeds.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...