Jump to content

uTorrent download problems


Recommended Posts

3.4.5 build 41712 seems broken.

3.4.5 build 41372 downloads at 100 MB/s with no problems while 41712 hits a brick wall at 27 MB/s for no reason. It also connects to peers extremely slowly compared to 41372.

Tested both builds with same torrents, same windows 10 machine and utorrent settings.

Link to comment
Share on other sites

My settings are fine.

I understand you don't see any problem at 100 Mbps, I don't notice problems at that low speed either.

I will say this again: 41372 can reach 1000 Mbps easily, 41712 hits a brick wall at 220 Mbps with exactly the same settings and environment.

Unless you can tell me the devs have significantly rewritten uTorrent overnight and by magic the same settings that worked flawlessly on 41372 produce a 75% performance decrease on 41712 (at gigabit speeds, not 100 mbit), there is absolutely no reason why I should consider the recommendation to improve settings.




Link to comment
Share on other sites

Right, seems like some regression with upload, not giving enough for overhead. Have you tried to limit it to , say -200K, but set it to NOT limit the overhead?

Is it the same with the latest beta (that I am using)?

BTW, is your Internet connection symmetric (1G up too)? Which HD are you using - SSD?

Link to comment
Share on other sites

It's the same with 41801.

Internet connection is not symmetric but it's irrelevant, there is enough upload bandwidth for overhead ( and some 200 Mbps to spare). I don't use any limits.

Hard drive is again irrelevant. Even when writing on them at 100 MB/s while downloading with 41372 they are not overloaded as you can see in the task manager screens. Also, it's the same behaviour on SSD. This has nothing to do with HDD/SSD speeds.

The drives are almost idle, yet 41712 and 41801 won't write faster than 28 MB/s and the write cache fills.

Link to comment
Share on other sites

  • 1 month later...

Strange of you to say so, since you we clearly see in my screenshot tat it is faster then 7MB/s and the only diff now is my settings (plus internet connection speed... ) :P

I completely agree with you, that there might have been some issue "built into" the latest builds at higher speeds. The devs do to have to "rewrite" uT overnoght for it to happen, just some part of it, and they did (see the changelogs, cache/throttling control). So, you can keep blaming everyone and stick with an older release, or provide details that can help, like -  your internet connection speed, and  details of your environment - OS/HD.


Or... try to avoid getting into possible new issues, using the settings (like based on mine @Sig) , even if just for the sake of pinpointing the issue. I'm curious ifthat will change anything for you.

BTW, IMHO, the newly introduced HD/cache control is a likely cause ... so one other test you can try - is to test with it completely disabled (use Windows').

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...