Jump to content

utorrent crashing on windows 98 box


Recommended Posts

hello i keep getting a pop-up menu several times a day that states that utorrent has crashed, and u torrent will now restart. it goes on to ask me if i want to submit a crash dump file to the developers. couple of questions here is there anyway i can get it to stop asking me this & just restart, & any ideas of what i can do to stop these crashes. outside of the obvious of upgrading my operating system.

few details on what i am running

windows98 se with 504 mb of ram, fresh install about 2 weeks ago

mcafee anti-virus (could not find this one listed in the incompatible software)

no firewall

utorrent 1.6 (build 474)

1st i went to faq and found

Be warned that Windows 95/98 are limited to 100 max concurrent connections, unless you apply the following registry tweak (sourced from Windows TCP/IP Registry Entries).

Open the registry editor (Start -> Run -> regedit), go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP

You must create the following entry, it is not present by default.


Data Type: String

Specifies the maximum number of concurrent connections. The default is 100. The maximum is 512.


Common fixes for routers/modems freezing/crashing/etc

Updating the router firmware

Turning off the UPnP (in the client and in the router) and doing manual port forwarding

Restricting the number of global connections to 200 or less (may need to go below 100, depending on the router)

Turning off DHT

Lowering net.max_halfopen and bt.connect_speed

Putting the modem/router into bridge or gateway mode (doesn't apply to modems that aren't routers)

Getting a new router/modem

did the registry edit & set my global connections to less than 100 (80) still had problems so i then searched the troubleshooting forum & found a couple of things. the first was a suggestion to try deleting settings/resume/dht.dat in %appdata%\utorrent. tried this but it didn't seem to help much.

the second one i found was this post by Firon

Mikademus: do you have a firewall or anti-virus? or any net monitoring (or net nanny?) program?

ps: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug

change Auto to 0

and Control Panel -> System -> Advanced -> Error Reporting

"Disable Error reporting"

but can't seem to find either in my pc. i googled disable error reporting windows 98, & found this

Internet Explorer 5.5 SP2 or 6 for Windows 98, Windows 98 Second Edition, Windows Millennium Edition, Windows NT 4, Windows 2000

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

In Registry Editor (Regedit.exe), create a DWORD value called IEWatsonEnabled and set it to 0 in the following registry key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main

tried it, but still happening. any other ideas?

thanks dave

Link to comment
Share on other sites

dreadwingknight my connection settings are

port for incoming connections is 49152.

the enabled upnp mapping is checked.

bandwith limiting is set to

global max upload rate is 30 kbs

alt upload rate when not downloading is 40 kbs

global max download rate is 30kbs

global max download rate is 30 kbs

& ultimia actually i did post "did the registry edit & set my global connections to less than 100 (80)".

Link to comment
Share on other sites

Have you gotten Win 98SE unofficial service pack?

It is an automated installer for all of Microsoft's official tiny Win 98SE patches.

You might also need Internet Explorer cumulative update.

Also, have you run TCP Optimizer from www.speedguide.net -- it is almost a neccessity for Win 9x/ME boxes!

...just don't allow more than 4 connections per web server at once!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...