Jump to content

Error: The Data is Invalid


Invy

Recommended Posts

I was partially downloading a torrent, containing 6700 files to be exact, and all of a sudden the status of the torrent changes to "Error: the Data is Invalid".

I'm not sure what's causing this and I searched already. I only saw 2 other topics from a year ago. I have compact allocation set to false (default).

Any idea what is causing this? This is the first time i've seen this error, but also the first time i've downloaded something with this many files.

Also, I had downloaded over 1.5 GB of the 15.8 GB of it, and all of a sudden it says I only have 250 MB completed now. It's killing my ratio on this site :(

edit: screw it. i'll just download all of it so I don't worry about this error. :P

Link to comment
Share on other sites

  • 3 years later...

even i have been having this prob since i updated last time..i m not sure about the prob..but the error comes after some time and i need to recheck the torrent file every other time..

helppp..it sucks as i have to be in front of the laptop almost 24 hours .

Link to comment
Share on other sites

I to have been getting this message and have to keep force rechecking the file. I'm also running utorrent 3.0 alpha and it's been working fine up until a few weeks ago. Any ideas on a fix!!!!

I also have bittorrent 7.2 and that works just fine. Seems to have something to due with the Alpha version....

Link to comment
Share on other sites

as am I!

there seems to be no rhyme nor reason why it's happening...it doesn't happen constantly, but if it happens, it happens constantly on the same torrent

running windows 7 64bit, and using Utorrent 3.0 Alpha

hope this helps with debugging future releases :)

Link to comment
Share on other sites

same here but i also get cant find path to file

it also seems to be adding my own ip address to the banned list of peers

saying that its already in the pool

nothing seems to fix this but a forced recheck and even then it still happens on the same ones

Link to comment
Share on other sites

I'm having the same problem. Using 3.0 Beta build 25234. The trick may be to stop the torrent, delete the partfile, and force re-check (see below).

The error is definitely caused by deselecting one or more files in the pre-download dialog or setting the Priority to "Skip" (instead of High/Normal/Low) in the Files tab during download. Skipping even small files (like the "Torrent downloaded from _____.txt" files in most torrents) can cause this error.

The issue isn't new, it was supposedly fixed once. This must be a regression. The issue is discussed in an old thread (from 2006) on this forum. Quoted below is the fix that Greg Hazel supplied at the bottom of that thread:

--- 2008-01-08: Version 1.8 alpha (build 7660)

- Fix: elusive "The parameter is incorrect" and "The data is invalid" errors on Win98 (old partfiles with this error are corrupt' date=' sorry)[/quote']

As the changelog says, old partfiles are corrupt. Please stop the torrent, delete the partfile, and force-recheck.

Link to comment
Share on other sites

Same problem, uTorrent 3.0 beta, build 25234.

I tried fixes from the old thread without success. It appears that Skipping files is the major culprit. If I download all files, then the torrent works. If I skip files then the torrent does not.

I have seen this problem repeated many times, with many torrents, for the past two or three builds.

Link to comment
Share on other sites

I have the same problem. This only started with 3.0 and continues with the latest build update.

In my case, when I download file A within a torrent and it finishes and downloads file B, file A will later say that the data is invalid and I have to redownload a certain chunk. File A will finish and go on to download file B or C and file A will give the same error and redownload the same chunk over again.

This has happened with two torrents so far. Both of them being mp3 albums.

Link to comment
Share on other sites

I have 3.0 beta build 25277 running on winxp pro. :o

I was having the same problem, :( when I deslected the extra files I did not want it seemed to trigger the random error to accure (error: the data is invalid.) and it stopped the download. I just chose to download them on low priority instead of do not download. :D

This has fixed the issue for me. :lol:

Hope this helps. :P

Maddog390 :)

Link to comment
Share on other sites

I have 3.0 beta b.25277 win 7 64bit. Keeps getting this error if I have skip files. The only way it works is to change the skip files to Low 1 priority. I didn't want them dl but I have no choice.

Same for me too. the silver bar issue etc all solved only this issue remains. Hoping for a fix soon.

Cheers

Link to comment
Share on other sites

Same here. I think the cause is that overlapping pieces between skipped and non-skipped files are downloaded at first, but later get considered as missing. A Forced recheck also consider these pieces as missing. After resuming, it all happens again, and again.

Gone back to 2.2.1, it's all right here, again.

Edit: reported it in the Found Bugs section: http://forum.utorrent.com/viewtopic.php?pid=585420

Link to comment
Share on other sites

I have 3.0 beta b.25277 win 7 64bit. Keeps getting this error if I have skip files. The only way it works is to change the skip files to Low 1 priority. I didn't want them dl but I have no choice.

Same problem with 25303 (32bit) on Win7 (64bit). On skip file only.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...