Jump to content

Port Blocked Issue


Recommended Posts

Alright, this issue has been driving me to insanity.

I have the utorrent port I use forwarded under my router(DI-624) settings. If I run utorrent WITHOUT NAT-PMP port mapping, the port will still be blocked. If I do run it with the port mapping, the port will be unblocked, but ONLY when utorrent itself is open. The moment I close utorrent and re-check if the port is open, it's closed.

Things I have figured out from self-troubleshooting/Details:

- It is not an issue with the router. If utorrent is running with port mapping, I can disable or re-enable portforwarding for the utorrent port however I want.

- I have no firewall enabled. Windows firewall is not enabled.

- I don't have any anti-virus or security software.

- I can use utorrent just fine, but the issue is the fact I want to be able to forward ports permanently.

- The problem is not the modem sent to me by Sympatico, it is set up on bridge mode and the router takes care of all settings.

- I do not use any proxies.

Here is a HiJackThis log of all my running processes:

Logfile of HijackThis v1.99.1

Scan saved at 7:43:45 PM, on 12/19/2007

Platform: Windows XP SP2 (WinNT 5.01.2600)

MSIE: Internet Explorer v7.00 (7.00.6000.16574)

Running processes:









C:\Program Files\NetLimiter 2 Pro\nlsvc.exe


C:\Program Files\Alcohol Soft\Alcohol 120\StarWind\StarWindServiceAE.exe


C:\Program Files\D-Link\AirPlus G\AirGCFG.exe

C:\Program Files\Java\jre1.6.0_03\bin\jusched.exe



C:\Program Files\uTorrent\uTorrent.exe

C:\Program Files\NetLimiter 2 Pro\NLClient.exe

C:\Program Files\HijackThis\HijackThis.exe

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.google.ca/

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyServer =

R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyOverride = local

O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.6.0_03\bin\ssv.dll

O2 - BHO: (no name) - {7E853D72-626A-48EC-A868-BA8D5E23E045} - (no file)

O2 - BHO: NetXfer - {83B80A9C-D91A-4F22-8DCF-EA7204039F79} - C:\Program Files\Xi\NetXfer\NXIEHelper.dll

O2 - BHO: Windows Live Sign-in Helper - {9030D464-4C02-4ABF-8ECC-5164760863C6} - C:\Program Files\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll

O3 - Toolbar: NetXfer - {C16CBAAC-A75C-4DB5-A0DD-CDF5CAFCDD3A} - C:\Program Files\Xi\NetXfer\NXToolBar.dll

O4 - HKLM\..\Run: [D-Link AirPlus G] C:\Program Files\D-Link\AirPlus G\AirGCFG.exe

O4 - HKLM\..\Run: [sunJavaUpdateSched] "C:\Program Files\Java\jre1.6.0_03\bin\jusched.exe"

O4 - HKCU\..\Run: [MsnMsgr] "C:\Program Files\Windows Live\Messenger\MsnMsgr.Exe" /background

O4 - HKCU\..\Run: [AtiTrayTools] "C:\Program Files\Ray Adams\ATI Tray Tools\atitray.exe"

O4 - HKCU\..\Run: [DAEMON Tools] "C:\Program Files\DAEMON Tools\daemon.exe" -lang 1033

O4 - HKCU\..\Run: [RamBooster] C:\Program Files\RamBooster 2.0\Rambooster.exe

O4 - Startup: Adobe Gamma.lnk = C:\Program Files\Common Files\Adobe\Calibration\Adobe Gamma Loader.exe

O8 - Extra context menu item: Download all by NetXfer - C:\Program Files\Xi\NetXfer\NXAddList.html

O8 - Extra context menu item: Download by NetXfer - C:\Program Files\Xi\NetXfer\NXAddLink.html

O8 - Extra context menu item: Open with WordPerfect - C:\Program Files\WordPerfect Office X3\Programs\WPLauncher.hta

O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_03\bin\npjpi160_03.dll

O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_03\bin\npjpi160_03.dll

O9 - Extra button: (no name) - {e2e2dd38-d088-4134-82b7-f2ba38496583} - %windir%\Network Diagnostic\xpnetdiag.exe (file missing)

O9 - Extra 'Tools' menuitem: @xpsp3res.dll,-20001 - {e2e2dd38-d088-4134-82b7-f2ba38496583} - %windir%\Network Diagnostic\xpnetdiag.exe (file missing)

O11 - Options group: [iNTERNATIONAL] International*

O18 - Protocol: livecall - {828030A1-22C1-4009-854F-8E305202313F} - C:\PROGRA~1\WI1F86~1\MESSEN~1\MSGRAP~1.DLL

O18 - Protocol: msnim - {828030A1-22C1-4009-854F-8E305202313F} - C:\PROGRA~1\WI1F86~1\MESSEN~1\MSGRAP~1.DLL

O20 - AppInit_DLLs:

O20 - Winlogon Notify: WgaLogon - C:\WINDOWS\SYSTEM32\WgaLogon.dll

O21 - SSODL: WPDShServiceObj - {AAA288BA-9A4C-45B0-95D7-94D524869DB5} - C:\WINDOWS\system32\WPDShServiceObj.dll

O23 - Service: Adobe LM Service - Adobe Systems - C:\Program Files\Common Files\Adobe Systems Shared\Service\Adobelmsvc.exe

O23 - Service: ANIWZCSd Service (ANIWZCSdService) - Alpha Networks Inc. - C:\Program Files\ANI\ANIWZCS2 Service\ANIWZCSdS.exe

O23 - Service: Ati HotKey Poller - ATI Technologies Inc. - C:\WINDOWS\system32\Ati2evxx.exe

O23 - Service: ATI Smart - Unknown owner - C:\WINDOWS\system32\ati2sgag.exe

O23 - Service: NetLimiter (nlsvc) - Locktime Software - C:\Program Files\NetLimiter 2 Pro\nlsvc.exe

O23 - Service: ProtexisLicensing - Unknown owner - C:\WINDOWS\system32\PSIService.exe

O23 - Service: SiSoftware Database Agent Service (SandraDataSrv) - SiSoftware - C:\Program Files\SiSoftware\SiSoftware Sandra Professional Home XIIc\Win32\RpcDataSrv.exe

O23 - Service: SiSoftware Sandra Agent Service (SandraTheSrv) - SiSoftware - C:\Program Files\SiSoftware\SiSoftware Sandra Professional Home XIIc\RpcSandraSrv.exe

O23 - Service: StarWind AE Service (StarWindServiceAE) - Rocket Division Software - C:\Program Files\Alcohol Soft\Alcohol 120\StarWind\StarWindServiceAE.exe

What I'm wondering is: if there is a way to see what exactly NAT-PMP port mapping does to make the port forwarding work so that I can see the problem and possible find a permanent fix.

Link to comment
Share on other sites

O23 - Service: NetLimiter (nlsvc) - Locktime Software - C:\Program Files\NetLimiter 2 Pro\nlsvc.exe

O23 - Service: ProtexisLicensing - Unknown owner - C:\WINDOWS\system32\PSIService.exe

Do either of those services/programs come with the "feature" of a software firewall?

Edit: Of course there's the always useful testing using http://distribution.openoffice.org/p2p/ to see if that can get incoming connections... If not, yes you need to play with/finagle hardware settings and make sure no software is providing the functionality of a firewall (barring Windows Firewall, which can be bypassed in uT settings).

Link to comment
Share on other sites

Yeah, I did. Even if I forward the exact ports in the exact way that utorrent forwards them in my router configuration, the port will still not be forwarded when utorrent is closed.

Netlimiter comes with a firewall(but I disabled it), I uninstalled to test if it was the problem about 3 times. It doesn't make the difference.

I had to research on the second one earlier too. It has nothing to do with firewalls, it supposedly protects software from piracy of something of the sort.

Link to comment
Share on other sites

OK. Then yea you need to go through the full gamut on your router settings. Are you sure it doesn't support UPnP. I'm sorry about my earlier response. You need to make sure you went through the procedure described in the How-To about your router's port forwarding capabilities or make sure you follow the procedures from http://www.portforward.com/english/routers/port_forwarding/Dlink/DI-624/DI-624index.htm

For your IP you need to make sure that IP is under Virtual Server Instructions Private IP.

Link to comment
Share on other sites

Well depending upon your setup: as long as you aren't using a service port, and it's not a known port used for other traffic (3389 is used for RDP into Windows Terminal Services for example) it is not SPECIFICALLY being targeted.

If you think it is hardware double check that there aren't problems reported with the firmware version you are currently using. As a last resort, there's another tool which can tell if your uT is going through other hoops to connect to the internet/peers.. It is called Process Explorer and can be found @ http://www.sysinternals.com. What you'll want to do is download,unzip, and open the EXE. Then enable the lower pane (Ctrl-L) and show open DLLs (Ctrl-D). This list shows you EVERY DLL hooked into uTorrent's process. If you see ANY outside \system32 or NOT from Microsoft Corporation you should definitely know what they are, if you are not sure, paste it here (You'll need to Ctrl-A to save the list first).

But as mentioned above, it could still be the hardware firewall (router)...

Link to comment
Share on other sites

Just re-started modem settings and router settings, setting the modem onto bridge mode to disable it's router capabilities. I tried what ultima suggested but didn't work. Guess I'll just live with only having the port open when utorrent is. That's kind of strange how that works though.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...