Jump to content

My newbie slo prob ... your ez solution


Recommended Posts

Newbie here. Don't know what to expect but service seems slow. (daze to download 40 minute video !!!???!!!)

Given: 1.2Mb down 320 up DSL service (sbcglobal/att)

uTorrent 1.7.7 just installed


Yellow warning triangle at screen bottom (always).

< 5kb down and < 8kb up speed. Seeds 3(6) Peers 1(11) on this test.

I paused this torrent, and ran OO as test.

tested using OO (OpenOffice) and noted >150kb down. Unpaused current test,

it ran ~75kb for a short while then dropped to the 5 down, 8-ish up speed.

I've read lots of posts here and did some searching.

(4-5 hours worth)

First I tried to resolve the triangle issue. I visited my router, linksys BEFW11S4V4

and set according to the suggestions:

1) Block WAN Request: DISABLE

2) Set port forwarding (sample number: 21200)

External Port 21200 to 21200 TCP (Checked) UDP (Unchecked)

Set (internal) IP to this one computer (of 15), Enable(checked)


Then I went to the firewall (XP MC 2002, SP2, AMD 64 3700+)

LAN -> Properties -> Advanced -> Settings -> Exceptions

Add Programs: uTorrent (program path) Scope (Any Computer...)

Add Port: Name:: uTorrent 21200

Port number:21200

TCP (Checked)


Advanced Tab -> Services -> Add

Desc: uTorrent 21200

Computer name or IP: IP entered (192.168.0.xx)

External Port number for this service: 21200

Internal Port number for this service: 21200

Service is checked.

(All ICMP are unchecked)

Summary of initial setup:

I believe I have opened a port at the router, then forwarded it to one machine.

I then accessed that machines firewall and allowed the program access, and to that port. I have enabled that port on that machine.

I then rebooted the machine to force the changes (Is this really required ???).

I restarted uTorrent. I un-paused the 1st torrent and the results are as I posted in the beginningl, occuring at 9am PST 12 noon PST (GMT-8)

While it was runing (slowly), I re-read a number of posts by other users and the replies by "Pros" and the moderator(s).

While running I changed a number of settings one at a time, then gave 5+ minutes for change to have an effect:

In no particular order, but probably done in the order read on this forum)

Options-> Preferences -> BitTorrent

Global Max Connections now 100

Max connected peers now 70

Uploads per .. now 3

Encryption FORCED = Allow Legacy (unchecked)

Options-> Preferences -> Advanced

Net.max_halfopen changed from 8 to 4.

peer.lazy_bitfield = true.

peer.resolve_country = false.

There are some other things I investigate/confirmed were set as suggested etc...


1) with my ISP speed (1.2+384-ish) what should I expect?

2) how can I improve the thruput with settings?

--> 3) Why can't I get the yellow triangle to change to a green dot?

(Is this the first issue I should resolve ???)

I've tested the port(s) with Port Detective and it reports 21200 is in USE, but a

Open Port Check Tool (http://www.canyouseeme.org/) the results is that it can't see an open port at 21200.

The port tester which is linked from here is unavailable.

Now what can I do ???


Link to comment
Share on other sites

I've already set the "Conection Type" (speed) to be xx/256k. I also tried setting it to xx/384k.

I have also set the upload speed (right click the task bar icon) Upload Limit: to be Unlimited, then another time 250 kB for grins. Over time I return to check it, and when I set it to unlimited, then returned later it is between 20 and sometimes as high as 35kB. (it is currently 35kB.)

I presume the system is setting it based upon what it sees as effective thruput.

lower b = bits and upper B = Bytes. x/8

This 35kB is the setting. Actual performance is 1.5 kB/s right now.

15:50 PST

So my question remains, should I first address the yellow triangle issue?

Or is the fact that I am getting ANY transfer indicating that this "warning" is not valid?


a test using the CtrlG "Test if port forwarded properly" returns "Error".


Link to comment
Share on other sites

You don't need a green http://xrl.us/NetworkStatus to transfer as http://xrl.us/Shad0wFW shows... but it does HELP you connect to more peers on impacted (read as smaller) swarms by making sure you're connectable to all peers. When not in an open or correctly-forwarded state you can only connect to OTHER peers who are forwarded... two firewalled peers won't connect and on small swarms this may be disasterous.... like the one you were testing before OpenOffice. Since OpenOffice transfers near your expected 1.5Mbit down your ISP doesn't appear to shape traffic down... however your inability to upload consistently near your limit of 32 KiBps means something is amiss. It is possible the peers you're connected to don't have that much bandwidth available. With your xx/256 settings it allows 6 total slots by default. You may find you can increase your download by uploading to more peers slower. A rule of thumb is ~ 3 KiBps per peer's upload slot is great. Therefore @ 32 KiBps upload limit you can do 10 safely and maybe 12... You can split this however you wish. Many people prefer to run one-at-a-time very well... others prefer variety slower. So if you change 2 torrents @ 3 slots to 2 torrents @ 6 slots and see what happens... Or you could do 3 torrents @ 4 slots or 4 torrents @ 3 slots. The main limiter on your current tester is that it only has 17 total peers. I can recommend http://dattebayo.com as a large swarm activity for the recent releases as well... they can have up to 35000 active peers on one swarm on Thursdays. They are also only slightly larger than the test OOo file and as such don't take up alot of space and aren't that fast to complete that you can test many configurations with the same peerset.

If you have gone through Ultima's How-To for troubleshooting (linked below) for ideas already you can be sure of other programs interfering by scrolling to the bottom and doing what it asks to make the HJT and PE logfiles.

Link to comment
Share on other sites

OK, I got things working. Now I can begin seeding...

The solution to the problem included (physically) moving my router, and a WHOLE lot more.

I had to change the configuration of my DSL model, then change all the devices on my subnet, and change all the IPs on my "home" network, and more.

As a test I downloaded some really old video (black + White)in AVI format, but now I only get the audio track, and a "screen-saver" type display in my Windows Media Player. Do I need something called a codec?

Hmmm. Anyone have a suggestion on where (board) I can look for a solution?



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...