Jump to content

cpu slows with spikes in speed graph


Recommended Posts

While monitering the speed graph, i noticed spikes affects my cpu running speed.

When it happens i have music playing, msn messenger, Internet explorer running. , my mouse movement also becomes choppy simultanestly.

it spikes up to 112 kB/s on one torrent and thats when it happens. Also, on the graph, when green line spikes up, red line spikes down. Is this normal or are there settings to change to correct or possibly maintain this high download rate(or possibly higher) all settings are default right now, and there are 3 downloads happening.

Any suggestions?

Link to comment
Share on other sites

I asked already...

What anti-virus, firewall do you have? Are you saving across the network, to a USB drive,a laptop drive, a regular HDD? Is your drive old? Is the IDE controller set to PIO? (you can check by opening the control panel, clicking on System -> Hardware -> Device Manager, double click on IDE ATA/ATAPI controllers, then double click on what's inside there. Check what Primary Channel says for your HDD's transfer mode)

Link to comment
Share on other sites

Hey Firon

sorry for the delay,anyhow heres what i could come up with thru browsing the forum:

-i have a p4, 3.07GHz and 512mb of RAM

-i'm running windows xp SP2 (no patch- if recomended, please attach link)

-i have windows firewall----

-im using mcafee 10.0------Both firewalls have utorrent allowed access

-i have a cable modem, (not connected t a network-just me n my cpu @ home!) with a 2.9megabits per second bandwith speed, 351.6 kb/s storage and a rating of great (according to a test site found in the forum)

-i always have network OK and have never see a NAT error that many speak of.

-i tried many settings but no luck, put back to default

-i have not forwarded my port or anything, tried but my modem is not on the list provided. Its a motorola surfboard, model# SB5101

Primary IDE channel Properties

device 0

Transfer mode-DMA-if available

Current transfer- ultra DMA mode 5

device 1

device type- auto detection

transfer mode- DMAif available

Current transfer mode- not available

I have spent a lot of time reading within the foum and trying diff settings but still only get MAYBE a max dl speed of 20kb/s. most of the time its around 1 or under.

I tried torrents with a lot of seeds but still the same. i did try a test torrent and reached speeds over 300 but have never seen that with torrents i want. Another thing i noticed is that no matter how many peers or seeds are availabl i only connect to like 2-3 of them.

I hope this serves you well in providing me with some assistance.

Thanks in advance!


Link to comment
Share on other sites

I unistalled the mcafee firewall plus but my download speeds are still way down, well compared to wat other ppl are getting here. With the info i posted are there any base settings you can possibly suggest to start with?

Or if someone with a similar setup reads this can you post your settings for me? thanks!

Link to comment
Share on other sites

I have a very close system as Just-G, my bandwidth speed and storage is very close to the same, even right down to the same make and model modem. I have done all the recommendations as to the Utorrent faq's. And as you would guess I am having the same problem with spikes in downloads. this is some of the specs on the one file I'm downloading right now....

80 of 537 connected (871 in swarm)- peers

21 of 50 connected (195 in swarm)-seeds

27.7 kB/s- download speed

14.2 kB/s- up load speed

So anyway any help to get my download speeds to stay around 40 kb/s at least would be awsome thanks!!

btw, I just switched from bitlord whitch I was getting that kind of a speed on a more consitant basis

might go back I guess lol

Link to comment
Share on other sites

btw, I just switched from bitlord whitch I was getting that kind of a speed on a more consitant basis

might go back I guess lol

BitLord achieves its download speeds by cheating -- it doesn't follow the BitTorrent protocol and spoofs bad data to the tracker.

If you're consistantly getting more download speed than you're uploading, things are possibly already running correctly for a true BitTorrent client.

Link to comment
Share on other sites

Ok well now I will settle with the speed indiffrence, it seems to be better then bitlord as I have compared the two by downloading the same file with them both and with all the same settings and utorrent is killing bitlord!! so I have deleted bitlord (moving any of the files I have downloaded with it to another location) and went to start another torrent with utorrent and all that comes up as is " Temporary Internet Files\Content.IE5\K1IH47SP\[TBox]Movies2.torrent" Invalid Menu Handle. I tried a few diffrent torrents to see if the problem was with only that one and no it happened with them all and the same error. So I did a search in forums and only found this http://forum.utorrent.com/viewtopic.php?pid=31379 so I made sure that I associated torrents to utorrent and tried again and same thing!!! Damn some help with this would be awsome as I cant download nothing!!! Obviously I will have to find a diffrent torrent client if I dont get this fixxed and soon, but I hate being stumped!! Theres always a way to fix things!! Well ok usally anyway lol

btw if this is in the wrong thread, my appoligies and I expect a mod will move it. It was kind of a continuation of my previous thread that led to another problem..

Link to comment
Share on other sites

Torrents created by BitComet, BitLord, and BitSpirit are potentially unreadable by µTorrent due to how BitComet/BitLord (poorly) handles unicode. µTorrent only recently added Unicode support as well, so it may not be perfect either. BitTornado doesn't handle unicode at all. Azureus should handle unicode, but may not handle BitComet-created 'pseudo-unicode' torrents either. I don't know if that is what causing your problem though.

Link to comment
Share on other sites

It is a new torrent, not one that I started with bitlord, I started or tried to start the torrent after bitlord was completely deleted from my system, I even did a search for all files containing any phrase or word with bitlord and deleted the files that needed to be deleted. thanks for your help though!! any help is justifiable when lost!!

Link to comment
Share on other sites

So I tried to right click on a torrent file to get the "open with" but that doesn't come up when doing it from a site, I suspect that only will come up if you already have the torrent file in your hard drive (downloaded). So anyway I went to prefrences again and associated torrents to utoorent again, then I shut down and rebooted. Then when I restarted utorrent it asked me again!!!!! if I would like to associate all torrents to utorrent. Of course I said yes and went to a bit torrent site anf found the file I wanted and bang! it started to download with no error. wow awsome !! so I tried another file just to see and no problem again. So I stoped that file and deleted it because it was of no intersest to me but damn firon you were on the right track!! I have no idea why it did not accept my association to all torrents 4 times before that but it's all good now!! Well we got out of that stump, lol Thanks firon and switech for your support and I would be happy to buy ya a beer for that!!!!

Link to comment
Share on other sites

@ firon- Well doesnt seem to matter what i do i cant get high dl speeds, the ul will go up to 25kB/s and the dl will be at ~3. The only thing i havent done is port forwarding, and like i said earlier my modem is not listed.

Did the CPU spikes ever go away?-------for a while yes.

And what was your upload speed?-----it varies. When it spikes--~50kB/s

Right now i have 2 torrents running:

1)seeds -21 of 35(31 in swarm)

peers 24 of 75(63 in swarm)

ul limit capped to 150kB/s

share ratio+ 1.075

ul speed= 29.1

dl speed= 5.7

2)seeds=9 of 15(15 in swarm)

peers=10 of 28(26 in swarm)

ul capped to-150

share ratio= 0.899

ul speed=0.3

dl speed=4.5

Global max upload=200

Global max download=0

Globa max conn. 200

conn. peers 60

# of upload slots 8

Dont know what else to do but be patient! lol I know that works for sure!

Link to comment
Share on other sites

i tried , using a link from here within the forum, but my modem was not listed. i will try and then get back



I tried but my motorola sb5101 doesnt have a menu feature where i can access port forwarding. Thats as far as i got and i guess as far as ill go with this modem, maybe ill get a new 1! What is everyone else using?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...