Jump to content

uTorrent and Ubuntu


Recommended Posts

Hey guys,

Ok, I just installed Linux a couple nights ago on my computer. Specifically Ubuntu 8.04. I've been using Windows XP for the past few years. But I tried Linux and I loved it. So right now I have both Ubuntu and XP on my computer.

So, I installed Wine, and then uTorrent 1.7.7. And everything went fine. But...I'm having a problem with opening a port on Ubuntu. For the past two years or so I've been using uTorrent on Windows, and I was able to forward a port with no problem. uTorrent always had the green icon on the bottom of the client, and when I did the port test uTorrent always told me I was connectable.

But I can't achieve this on Ubuntu, and it's driving me crazy. I opened a separate port on my router(the same method that I always used in Windows) for Ubuntu. Then I added that port number in uTorrent. But I'm still unconnectable.

So does anyone know if there' sanything special I need to do since I'm using Ubuntu? I don't know if Ubuntu has a firewall or not. So maybe I'm behind a firewall, but I don't know how to find out.

Also, I opened the same port on Ubuntu as I have open on Windows. So is having the same port open on both OS's the problem? Should I open a different port on Ubuntu, then I have open on Windows?

Any info or help you can give me will be greatly appreciated. I've been messing with this for the past couple nights now.

Thank you.

EDIT: Ok, I tried using a different port for Ubuntu than the one I'm using on Windows, and that didn't work either. uTorrent is still showing me as unconnectable.

EDIT AGAIN: Wow, many views but no responses. Guess not too many here are experienced with Linux and Wine?

Link to comment
Share on other sites

i use utorrent in wine on ubuntu 7.10 since it's there, and have been doing so on 7.04 a few months before that. a few days ago (after deleting my wine folder several times during office2007 installation...) i decided to try the beta, and it works even better than the stable versions before. i never had a problem with it, i think even the upnp-portmapping works sometimes, but i'm absolutely not sure about that because of my crappy router. you should try the beta in wine, although i don't think it's gonna solve your problem.

for your problem: by default there is no firewall activated in ubuntu. to test if the utorrent port is reachable from the lan you could do the following: start utorrent in wine, go to another computer (linux or windows should do it), and type at a command prompt:

telnet <ipwhereutorrentruns> <utorrentport>

without the brackets.

when i do this on my localhost i get:

kendon@nx:~$ telnet localhost 3710


Connected to localhost.

Escape character is '^]'.

which means there is something listening on that port, otherwise you would see:

kendon@nx:~$ telnet localhost 3710


telnet: Unable to connect to remote host: Connection refused

and finally, what does the utorrent portchecker say? click "on test if port is forwarded properly" in the speedguide.

edit: there is one minor mistake in the beta, when i try to select multiple files by holding shift and using the arrow keys or shift + the left mouse button only two files are selected. it doesn't appear all the time, i wasn't able to find a system...

actually it's not that annoying, i can live with it.

Link to comment
Share on other sites

Thank you for your help. I would use the beta but serveral of the sites I use don't allow beta's.

And I don't have another computer to try what you mentioned. And when I try uTorrent portchecker, it gives me the red error message, saying my port is not open. So there's definitely something wrong, but I have no idea what.

Link to comment
Share on other sites

  • 3 weeks later...

hi. have similar problem with uTorrent 1.8 Beta on Ubnuntu via Wine. within several seconds after start uTorrent accepts incoming connections (forwarded through router and local with telnet command). then it stops responding on incoming port...

Link to comment
Share on other sites

Have been running different versions of uTorrent and don't have problem getting green signal. Port forward on Linksys WAG54gs. After installation I paste uTorrent on "desktop". When pasting a new uTorrent on desktop I click no for at startup at installation and may have to restart uTorrent a few times to get the green light. May also have to restart Ubuntu but after that I get green light more or less immediately every time. (I do however get a dump after one day - uTorrent beta 10198 and wine 1.0 rc1 - but that is another story - 1.7.7 works nice)

Link to comment
Share on other sites

This might be helpful.

I recently did a clean install of Ubuntu and spent several frustrated hours trying to figure out why Utorrent didn't read my set port as open. It turns out the native firewall was blocking connections even though my router was allowing them. Trying opening (or installing) Firestarter, go to the Policy tab's Inbound traffic policy, and open your torrent port. Worked like a charm for me.

Link to comment
Share on other sites

I did a clean Ubuntu 8.04 install, then Wine 1.0-rc2, then utorrent 1.8 b 10364.

utorrent worked, but the green icon didn't appear, it was yellow with (curious!) text "Network OK! Your network connection is working the way it should". Clearly it was not, sometimes the port checker found the ports open, sometimes not. Opening the ports with Firestarter didn't solve the problem, still no incoming connections.

I use a static IP address, in this case

What helped: The official Wine FAQ, #35: "My program fails to do networking, but Linux can get online". I added the required line in /etc/hosts and immediately the famous icon turned green!

utorrent isn't a Windows game with networkig problem, but... lol!

My /etc/hosts now looks as follows, the third line was added by me: localhost exposed exposed

# The following lines are desirable for IPv6 capable hosts

::1 ip6-localhost ip6-loopback

fe00::0 ip6-localnet

ff00::0 ip6-mcastprefix

ff02::1 ip6-allnodes

ff02::2 ip6-allrouters

ff02::3 ip6-allhosts

Hope this helps somebody!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...