Jump to content

Please help


Recommended Posts


I recently purchased a wireless router with a built-in hardware firewall. Prior to installing the router, I had an average speed of 110+ kb/s. However, after I installed the router, the download speed dropped significantly. Soon after, I learned of BitComet's impending demise and I switched over to UTorrent, assuming the problem stemmed from using BitComet. I was wrong. The slow speeds continued and I proceeded to do some more research.

I searched the forums and Google. I used all the tips that were available and I am still unable to resolve the issue. I have forwarded different ports and there has been little or no difference with speed. I also disabled the Windows firewall. Again, with no results. So here are my current settings:


Internet speed:

DL: 1536 kbps

UL: 160 kbps

Port forwarded (and used) by Utorrent: 32459 (I also tried 10000, 10001, and 10002)

UpNp disabled and enabled with no noticable difference.

Global upload rate set at 12 kb. I increased it to 45 kb. It improved the upload rate but made no difference to download rate.

Maximum connections: 45. I tried the default setting and had no results.

Max connections per torrent: 90. Again, I tinkered with this as advised on the forum with no results.

Max upload slots: 5. I've made little change to this. No noticable change.

Max torrent download: 2

Max number of active torrents: 3

DHT is enabled. It seems to malfunction when it is disabled.

Scraping is enabled

net.max.halfopen is set at 70

DHT rate is 4096

bt.connect.speed: 100

peer.lazy_bit: True. Hardly any difference when enabled or disabled.

If you need any more information, please let me know!


Edit: There is one more thing I forgot to mention. At times, I have been unable to connect to trackers.

Link to comment
Share on other sites

Well, I took your advice and reset the values back to default. I also increased the UL rate by 2 kb/s. No improvement.

I also disconnected the router and connected directly using my external modem. Nada.

I do know that my Speedstream also has an internal firewall. Unfortunately, I don't think there is a way to forward any ports.

I'm also having difficulty connecting to trackers. I usually get a time out or an HTTP 404 error.

Link to comment
Share on other sites

It's a regular external modem. Here's a link - http://subscriber.communications.siemens.com/subscriber_networks/4100.shtml

It's possible that SBC has come down on BitTorrent traffic. About a month or two ago, I used to get speeds of up to 150 kb/s. Anybody else on SBC having the same problem?

Edit: I just tried downloading http://distribution.openoffice.org/p2p/index.html and the DL speed jumped up to 160 kb/s. Any idea on why this doesn't happen with other torrents?

/Don't bump threads.

Link to comment
Share on other sites

Edit: I just tried downloading http://distribution.openoffice.org/p2p/index.html and the DL speed jumped up to 160 kb/s. Any idea on why this doesn't happen with other torrents?

Like Firon said, the other torrents may just be slow.

Also, your upload speed is pretty limited -- so you have to reduce your upload slots to only about 3 or 4 to get the upload speed PER slot above 3 KB/sec. Below that value, people are less likely to upload to you -- unless they have no one else to upload to...as is the case on the openoffice torrent.

Link to comment
Share on other sites

*If the swarm (number of seeds/leachers) isn't of good quality then you will not be downloading that torrent at very high kB/s no matter how good your uTorrent settings OR how high speed your connection!


*There are many torrents with low quality swarms.

My internet connection is regularly tested at

1200 kbps or 150 kB/s dowloading

270 kbps or 34 kB/s uploading

If the swarm is of high quality, I can reach downloads of over 100 kB/s for a single torrent. I only download 2 torrents max at a time.


I'm on WinXP SP2 with a Speedstream 5200 DSL Modem/Router using the USB connection (I had the ethernet plugged into my Xbox when I had a Live account).

I applied the TCPIP.sys patch for WinXP SP2.

I've turned off WinXP Firewall and am using my Seedstream 5200 firewall at the high setting.

max upload: 23 kB/s

max download: 110 kB/s

global connections: 270

per torrent connections: 100

upload slots: 5

Guide for good uTorrent settings.

Guides for port forwarding, firewall and router settings.

Good luck.

Link to comment
Share on other sites

Thanks for the reply. I installed the patch and it seems to have made matter worse. I now get a NAT error.

So i'll follow procedure.

Network: DSL, wireless LAN. U.S. ROBOTICS 5461

WinXP Pro SP2.

Speedstream 4100. Firmware is different from your average Speedstream 4100. SBC Yahoo!, in all it's infinite wisdom, thought it would be better to include a "custom" and over-simplified firmware for the modem.

As for the router, I have tried to forward ports. However, when the designated utorrent port is tested, it is shown as "stealth" or "blocked".

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...