Jump to content

Memory leak


Recommended Posts

I've had the same problem, had to reboot every so many days because my memory would rise above 100mb (!) and 2 days ago or so it started to become worse and yesterday I had to reboot 4/5(!) times. The UL speed would drop dramaticly to 0kb/sec in total and the download would rise to 500. Nothing worked, Taskmanager, start, couldnt open and close anything and after 15 minutes it would freeze totally.

I checked the forums and saw something about systemcache, checked it in taskmanager and my systemcache did drop.

So I went back here to check up on a solution and I saw this;

Change diskio_write_queue_size '-1' to '8000'. I tried that and untill now it's working fine, I'll see how it will be tomorrow :/

So dunno, I'd suggest you try that aswell maybe?

edit: Oh Yeah, I don't have incompatible software. I only use Windows XP SP2 firewall so. Afaik I don't have a nvidia firewall (don't have a nForce 4 board, just an old P4 S478) and no other Virus scanners of any kind.

Link to comment
Share on other sites

Can you post what firewall, anti-virus and anti-spywares you have?

It's knowed that a few security programs causes µTorrent to use allot of memory.

It could be good answer, but I don't use any firewalls, anti-virus and anti-spywares.

My system is Win2k + last service packs + uTorrent. I have only one problem, this problem is memory leak in uTorrent.

I ran a few days ago uTorrent. It used to be around 80 Mb used memory after rebooting. Today I see 234 Mb. I see uTorrent took just 11 Mb in task manager. I don't run something else on my computer. A few days I have been downloading by uTorrent. Where is my memory? I see maximum memory usage 11 Mb in uTorrent, but common memory usage is 234 Mb. It's memory leak in uTorrent.

Link to comment
Share on other sites

Also, uTorrent handles sockets pretty well. Some connections are lingering in one of the *_WAIT states, but those are moved to OS care and are cleaned away with time to OS discration (afaik, could be wrong here).

Are you kidding? You created that connection. It's yours trash. You should clean up all after. System doesn't care. I told you after a few days my system collected memory trash around 200 Mb. I tried 2 different computers - Win2k, no firewall, no antivirus software, nothing else. Absolutly same result.

What else? Just in case, Unix sockets and Windows sockets are different. You should use different function for closing - close / closesocket

Link to comment
Share on other sites

Hi Guys,

I'm experiencing the same memory leak issue with both 1.3 and 1.4. I've tried 4 different firewalls (NVidia, Sygate, Freedom and Windows) as well as no FW. uTorrent exhibits the same behavior. Memory gets slowly leaked as it is run.

I have read about the NVidia issue. So in my testing, I have installed, tested, and uninstalled all the firewalls (except Windows FW). The leak manifests itself irregardless of whether a firewall is used or not. Windows Process Viewer shows uTorrent slowly increasing mem usage while physical available memory is decreasing. I've had to reboot after 2 about days because the system was crawling and non responsive (A64 2.7Ghz DFI NF4 1GB ram raid0-boot and raid1-data).

Although I'm not a torrent expert, I can see that resources are constantly being allocated and then slightly deallocated, slowly resulting in a negative balance - a leak. I monitored the memory usage, hoping that the resources would get fully released after the file was completely downloaded. It never happened.

Am I setting up uTorrent incorrectly?

I'm going to get some exact numbers on before and after uTorrent to verify.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...