Jump to content

DHT = 100% CPU use, bug or settings?


Recommended Posts

I use WinXP SP2 with all patches up to date. Along with F-Secure Anti-Virus Client Security, Ad-aware, MS Antispyware etc. Upgrading to ver 1.4 (I seem to remember it was the same problem in the last beta also - although not sure).

When starting µTorrent it first tries to Login to DHT (which takes about 1minutes) - then it starts updating. When it starts updating the CPU use switch from almost zero to 100%. I have sticked with DHT turned on for around 10 minutes, got 200 seeders in the status bar - and still the CPU use is constant at 100%.

The file which uses all the CPU is fsdfwd.exe.

When I turn off DHT everything gets back to normal = almost no use of CPU.

So it seems that somekind µTorrent is messing with my F-Secure or vice-versa, anyone any suggestions how to fix this?

By the way, have you [ludde] considered making an IM-client which uses the same principle as µTorrent? (i.e. almost no memory or CPU used?) Could be a jolly good idea for a new project. Good luck with further developement and on other projects.



Link to comment
Share on other sites

Are you sure that it can't be MS Antispyware or some other security program?

Like a firewall for example?

Btw, ludde doesn't have the time to make an IM client +

there already is a IM client that takes very little resources =


EDIT: sorry, I missed that it said that 'fsdfwd.exe' took all the cpu.

I also recommend clamwin as 1c3d0g recommened,

but it doesn't have a active scanner.

If you want a active scanner, chose Avast but I think it's bloated and

its annoying that you must reinstall it every 60 days + get an new serial key for it :P

Link to comment
Share on other sites


A quick Google search revealed that fsdfwd.exe is part of F-Secure and cannot be removed, otherwise the program will malfunction. Sorry, you'll have to find yourself another program for your Anti-Virus (I recommend ClamWin [free]), or use Azureus instead. :/

Link to comment
Share on other sites

Thanks for the swift reply, and Miranda IM is great (thought that trillian was the most lightweight untill now).

I don`t know why F-Secure uses 100%CPU - but I can guess it is scanning all the incomming DHT or something. If it is possible to test it further, and help to solve the problem I would be happy to assist you ludde (or others).

Link to comment
Share on other sites

Well, I`m sure it will be alot faster, easier and better to update the µTorrent-code than wrestling and trying to explain something to F-Secure (or any other big company.) I haven`t experienced the same bug with other programs yet, and I haven`t re-installed my computer for 1 year or so (yes - I know it is about time, but gotta deliver some essays first, then I can have all the fun.) - so I think there is a fairly amount of unused files and registry entries here (although I clean regularly.)

Hm, gotta go find that DONATE - button, alot better than spending the money on support-calls to different companies.

Link to comment
Share on other sites

So I tried to start again, and checked the error-log of F-Secure, and I got error from several adresses saying:

Not Related ICMP-message.

Wish I knew what this means, after some googling it seems this points to some kind of information about the IP-adress...

EDIT: Also tried to find some UDP-naming thing in options to switch off - withouth success

SOLUTION: I went into the options of F-Secure Anti-Virus - Internet Shield - Advanced - Program - utorrent.exe - details. Then I switched from Controll: Program and port to Only Program on both server and client. And now it seems to work. Thanks for help in solving. Hope it can help others with the same problem.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...