Jump to content

High priority pieces not written to disk causing disk overload


Recommended Posts


I've been suffering from this issue for quite a while now, I think I have already posted it but I can't find it anymore, so...

The scenario is the following: when I start downloading a torrent that has big pieces the size of like 1, 2, or 4 MB and some fast seeders were seeding with at least 400 kB/s, a short while after starting the download it stalled with Disk overload 100% in the statusbar. I looked into it and saw that the disk cache was full. I tried turning it off, then it went on downloading but the pieces were still not being written to disk, thus being collected in memory. This situation was usually resolved with stopping, starting, pausing, resuming the torrent a couple of times and after a while everything went normal.

I finally resolved this issue with turning the first_last_prio option in the advanced settings off. This meant that there were initially no high priority pieces.

Now I've just started a download as described above and set a file's priority to high, and again I experienced the same issue, thus narrowing down the reproduction steps to having lots of high priority pieces at the beginning of a high speed download. Now the download has been going on for a while, but even now if I set a file priority to high it starts collecting high pieces for a while, but writes them to disk sooner.

Could you please look into this?

I'm using version 1.8.2, but this issue has been present since I dunno, 1.7.x maybe.

Best regards,


Link to comment
Share on other sites

  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...