Jump to content

Firefox problem - can anyone help?


Recommended Posts

I have FF 1.5, and many times when I try to load a page with several pictures in it,

e.g. the skins web page (which kicks ass BTW): http://utorrent.com/skins.php

FF starts to load the page, but stops before all the pictures have loaded. Sometimes 3-4 clicks on "Reload" solve the problem , and sometimes a few pictures are just not loading no matter what I do.

Any ideas will be appreciated...



Link to comment
Share on other sites

Boo: thanks for replying.

I have the following extensions (all are up to date):

- Dictionary Search extension for Firefox

- IE view extension for Firefox -

- Gmail manager extension for FireFox -

- ZoomFox extension for FireFox -

- Adblock extension for FireFox -

- Adblock updater extension for FireFox -

- Mouse gestures-

- the following two extensions which fix coding problems on two Israeli news sites:


- search button-


- Foxy tunes -

- Tab sidebar-


-Mozilla SpellCheck Libraries-

and yes, my ZA pro is set to stealth mode. (default mode for internet zone).

Link to comment
Share on other sites

No luck, with all extensions disabled and stealth mode deactivated I am still experiencing the same problem... :(

good idea though. Thanks...

Any other ideas are welcomed..

Edit: with IE I can see that page without any problems, so it's probably something internal to FF.

Link to comment
Share on other sites

I have a feeling it is ZoomFox.

Usually it's speed settings, like pipelining.

Disable ZoomFox and try this:


Install Tweak Network Settings. Try it first in Power mode, then in Default mode. (Power is what I use and typically it doesn't do this, though it does occassionally. Default is Firefox's factory settings, which another extension may have changed, hence why you're having the problems. Note that even if you disable these speed extensions, their changes still reflect in about:config)

EDIT: The reason why this might mess with images like this is that these "power" settings (which other "speed" extensions also set) do not work very well if you lose a lot of packets. Especially pipelining. Pipelining essentially requests several images at once, with only one HTTP request. If that request is lost, you may not load a big block of images. Usually the HTTP request is sent again, but it may time out before that big block of images comes to you. Without pipelining, you would only lose one or two images. With pipelining, you may lose half a page worth. Now mind you, on a good connection, pipelining is what truly makes FF fast. But if you're dropping packets, I'd turn it off.


Link to comment
Share on other sites

@hofshi: Yeah sorry, I read that but at first thought someone else had posted this message. I just misread. I thought two people were having this problem, and I thought the extension list was the original poster's, not yours. Don't ask, I just woke up lol :D

I actually had removed the part asking you for extensions before you replied. But you were probably in mid-reply yourself lol :D

So, go re-read my edit as well lol


Link to comment
Share on other sites

@Ares: thank you so much! you were right on the money.

I installed the extension that you recommended, and like you said, in default mode the problem disappeared, while in Power mode it came back. Finally I set to Power mode, but unchecked both pipeline options, and it seems that the problem is gone for good.

Thank you so much,


Link to comment
Share on other sites

Haha yeah I've tried several, including FasterFox and ZoomFox. This is by far the most effective, and the most simplistic (plus it was one of the first "speed" extensions). Every setting it makes can be changed in about:config. Specifically:








I actually had these all written down somewhere, before this extension came out. It makes tweaking them a lot quicker.


Link to comment
Share on other sites

Hmm well, I'm somewhat of an extension-whore really lol. Here's a list of the more useful ones:


* NoScript - If I had to recommend ONE extension, this would be it! It lets you enable JavaScript, Flash, etc on a site-per-site basis. Very handy for traversing the more shady parts of the web (spyware infested sites, etc).

* BugMeNot - Lets you right-click a username/password field and retrieve passwords from www.bugmenot.com automatically.

* CacheIt! - Lets you right-click a link and open it using either the Coral Cache or Google Cache. Really useful if you're a Slashdot user.

* DownThemAll! - Mass downloader.

* FireFTP - Very nice, full-featured FTP client.

* IETab - Good replacement for IEView. Actually renders certain tabs *inside* Firefox tabs. Still has a few kinks to work out, though.

* PDF Download - Lets you pick whether you want to open/save/view as html/etc for PDFs every time you click a PDF link.

* Tabbrowser Prefs - Gives you more control over your tabs.

* MinimizeToTray - Lets FF minimize to a tray icon.

* RestartFirefox - Lets you restart Firefox automatically by clicking a button. Great for people like me that install many extensions. :D

* ReloadEvery - Lets you reload a certain tab, or every tab, at a specified interval.


* MiniFox - A very small, minimal theme. Gives you more screen-space.


Link to comment
Share on other sites

Hey Hofshi, what's your TTL settings on whatever adapter you're using?

Use this to find out, if you don't already have something: http://www.speedguide.net/downloads.php

If it's set to 64, maybe try 128. ("Optimal" settings may be 64 for most, but since you are having problems)... This might give the packets longer to live, therefore they won't time out, and perhaps you can use pipelining again. Remember to reboot for it to take effect. =)


Link to comment
Share on other sites

Yes, 1c3d0g mentioned some of this stuff, I thought. It doesn't matter, if things are working nicely for you then no reason to fix something that ain't broke ;-) Just thought maybe it might help some more, that's all.


A simple way to use that program is to drag the slider at the top to your bandwidth average. You can measure it here:


After you put the slider on the right spot, tell it to apply to whatever networking adapter you are using in the drop-down list. Then select Optimal at the bottom, and hit OK.

Try it out.. if it breaks things, manually set TTL to 128. Or set them back to the defaults.


Link to comment
Share on other sites

I've tried some automatic ones before. Compare what your settings are now, to what that program tells you they should be (click current at the bottom, then optimized... see what changes).

Generally, I've found this program to be the most accurate.

Also read my edit above in post #23

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...