Jump to content

Windows 7 Socket Error


Recommended Posts

Hey guys, recently upgraded to Windows 7 Ultimate 32-bit and I am now back to getting the error I used to get on XP SP3 before I patched TCP-IP.SYS

An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full

This error shows for every single tracker for every single torrent. It does NOT show as an event in Event Viewer.

I am using the latest version of uTorrent

System is an AMD Barton 3200+, 2 GB RAM, system set to automatically manage swap.

Antivirus is AVG9 Free, firewall is PC Tools Firewall Free, set to allow all incoming and outgoing uTorrent connections. Default Windows 7 mainboard drivers (EpoX 8RDA3I, nForce 2 chipset, Realtek on-board nic)

I have read these threads:



No luck. I also looked here


I also followed the conservative network settings and am using the limits for 384kbps upload, which is what I have:

Max global connections 90, max connected peers per torrent 40, max slots 4. Max global upload speed set to 28kbps

I have changed bt.connect_speed to 8 and net.max_halfopen to 4

I have disabled UPnP and NAT-PMP

What the hell else can I try and should I do? What am I missing?

uTorrent seems to work just fine, I go to bed, wake up in the morning to that error and a dead connection. Can't surf the web, can't do anything. I have to restart to get it going again.

Like I said, I used to get the same thing in Windows XP SP3 but ever since I patched the tcpip, everything was fine and never had a problem.

Link to comment
Share on other sites

I think I disagree but I will uninstall and try it without PC Tools. The thing is I just tried uTorrent on my laptop, Windows 7 64-bit, same antivirus, same firewall and utorrent works just fine even with more aggressive connection limitations. 200 global, 80 per torrent. I will let you know if I have any luck.

Link to comment
Share on other sites

I have uninstalled PC Tools Firewall, bumped the connection limits a wee bit and it's been several hours now, absolutely no errors. I'll give it some more time but I think it turns out it was in fact PC Tools' doing. I don't seem to have this problem on my laptop, however.

Link to comment
Share on other sites

What I find absolutely irritating about Comodo's package is the Defense+ mechanism which drove me insane with notifications and alerts, no matter how long I had it in training.

Great link though, plenty to choose from. I personally like Outpost the best but on XP SP3 it's been giving me BSODs on this system. I'll give it a shot under Windows 7.

Link to comment
Share on other sites

I don't think I have the firewall engine installed I believe. I did find that PCtools keeps something running even when you shut it down.... PCToolsSSDMonitor and another process that goes with it.

Also, if you search microsoft issues, I found something discussing protocols running.... I ran the search option listed in the cmd prompt...listed several running.... apparently these can add to the socket full issue. I haven't been able to wrap my head around all of it yet though.

I played with some settings in utorrent and turned some things down...Maybe that will do it.

Also, The new windows firewall in windows 7, is a bit more in depth and u can add rules. I noticed Utorrent has inbound rules added automatically upon install, but no outbound rules.... I added a simple outbound rule...maybe that did the trick...we shall see...


nope once i started getting multiple connection types, it did it again


Restarted machine this morning due to another lock up..... when i did, I unistalled PC Tools Spyware Doctor.... After coming home from work today, No socket Errors...

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...