Jump to content

Speeds dropped seemingly for no reason.


Recommended Posts


I have used utorrent for years now and although I am basically clueless to the technicalities I have always managed to fix issues following guides and threads on these very helpful forums... Until now =(

My speed randomly dropped a few days ago from averaging 900kb+ to 7kb. I have read every guide I could find and changed some of my settings accordingly. I also tried disconnecting my router entirely and running it straight from modem. Still no joy.

Here is the information requested at the end of the "IF YOU HAVE SPEED ISSUES READ HERE FIRST" thread.

- I have tried changing my settings using the set up guide. Previous to this I am not sure what they were I did them manually following an older guide from these forums.

Upload Limit - 58.0kBs

Upload slots - 4

Connections per torrent - 85

Connections Global - 350

Max active Torrents - 4

Max active downloads - 3

I tried changing the net.max half open down from 100 to 4.

I checked my port forwarding finding that for some reason my IP had changed slightly, this is now coming up ok on my set up test.

I downloaded slackware to test and it's still running like crap.

I have Win7 64bit

Windows firewall, AVG antivirus, Microsoft Security essentials.

Router- Dlink Dir-301

ISP Virgin Media

Thanks for reading.

Link to comment
Share on other sites

Hi Chrissie.

I, too, experienced the same radical reduction in dowload speed over the past week or so. It may have started with the upgrade to version 2.04.

On my Windows XP machine, there is no reduction in speed.

On my Windows 7 machine, the download speed starts off fine, but then slows to a crawl.

I restored the proper behaviour by turning off uTP in the bandwidth settings for the Windows 7 machine.

On the XP machine, I turned it off, and the speed went down! I turned it on and the speed went back up to about 1.8Mb/s.

Hope this helps. I don't know what has changed to make this version so problematic with Windows 7, but I'm fairly sure it is related to the most recent version, and to uTP specifically.

/Steve, Canada

Link to comment
Share on other sites

Thanks for the input, DreadWingKnight.

I admit I have not done extensive testing on every bit of software that was updated recently, but I do not remember Vipre updating itself in the last few weeks other than for virus signatures. Regardless, I have Vipre running on both my XP machine and my I7-Windows7 machine. Only the Win7 box shows the behaviour.

I rolled back the machine's state to a point 1 day before I had upgraded uTorrent to 2.04, and had no speed reduction, regardless of uTP. Only when I installed the update (as suggested by uTorrent's auto-version-checking) did the problem reappear.

I'm working fine with uTP set off for Win7, so I am following this thread for interest's sake; I only hope to offer some clue as to what has happened with the many people complaining of speed reductions. In my case, the speeds dropped from 1.2MB/s to as little as 1kB/s for the exact same torrent downloading concurrently on both machines. When uTP is turned off, the speed climbs quickly to the original rate.

Hope this helps someone.

Link to comment
Share on other sites

Regardless, don't thread hijack.

Perhaps I have misinterpreted the rules for this forum - are you saying that I am not encouraged to offer my own experiences in the chance that they might help the original poster?

My apologies - please forgive me. I had assumed that it was an open forum.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...