Jump to content

uTorrent eating 10mb adsl connection


Recommended Posts

Hi Guys,

I've been noticing lately since 2.2.1 RC1& 2 that uTorrent is eating up my 10mb adsl connection, even with d/l speed limited to 300kbps in the tray. (I can't surf the net at all during usage, even google.com can't load at all). Only when I stop uTorrent and wait 5 minutes or so (or restart the modem) does my net speed return to normal.

I've jumped back to 2.2.0 Build 24683 and it is a "little" better. Any ideas why this is happening lately? Windows 7 x32 has been updated constantly and recently to sp1 (via updates). I'm just wondering if there is something to tweak because of that? It's been working totally fine before that.

Any help appreciated.

Link to comment
Share on other sites

Thanks for that link....


I've read through the various guides over the years and had some already done, etc

It seems one of the following worked (Any idea which one/s were more the culprit? (Now I'm d/l at 800kbps and surfing is unaffected (yay!), before the problem started recently, I had it set to a max of 400kbps d/l)

Try lowering net.max_halfopen to 4 or lower (Can be found in Preferences > Advanced)

- was 50, now 25...EDIT: now 4

Try lowering bt.connect_speed to 4 or lower (Can be found in Preferences > Advanced)

- was 7, now 4

Try disabling IP resolving in the Peers tab's context menu

- was enabled, now off

Try lowering maximum global number of connections to 200? 100? 50? Lower? (Can be found in Preferences > Bandwidth)

- was 120, now 100

Try disabling uTP? (Set Preferences > Advanced > bt.transp_disposition to 5)

- was 31, now 5

Link to comment
Share on other sites

I have a Zyxel P660HW-D1 (white)...everything is default except for some ports forwarded in NAT and Mac address' for my respective hardware.

I'm just wondering what's happened lately as I've had the same configuration for 3+ years? (of course my biggest suspect is the win7 x32 sp1 updates since it's the only thing that's changed on this machine since I started using win7 when it came out, apart from updating to the latest utorrent versions as they were released.)

SPI (as in Stateful Packet Inspection?), I don't even know where to look for it as the router has been working totally fine since day 1. (if it's not broken don't fix it and all that). But if it's something you think I should have a look at I will.

With these latest settings, as I mentioned earlier, uTorrent 2.2.0 Build 24683 does seem to be working much better than uTorrent 2.2.1 RC2 for some reason (things start to get slow again when I try using the RC1/RC2 builds)

Link to comment
Share on other sites

  • 3 weeks later...

Just in case anyone else has this problem...

OK, now I'm back using v2.2.1... it seems to have been the seeding torrents that were causing the problem, there was about 50 (max) of them and they've been seeding before the win7 SP1 came out. Even though with most of them I had the upload speed set very low. (OR even with a global limit of 1kbps upload via the taskbar icon)

All current 100% finished & seeding torrents deleted from the list = problem solved!


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...