Jump to content

Unable to download uTorrent at all!


Recommended Posts

Hello, I recently had to do a factory restore on my computer so I have to reinstall all of my programs, uTorrent being one that I have been using for years with no issues.

I use Firefox and I am able to click on the green download button, it asks me if I want to save the file, which I do. It appears to download into my d/l list within a couple seconds, which from there I would double click on the file and then it should install the app. But it does nothing at this point. I have tried several times with no luck. I have also tried disabling my ad blocker, my antivirus and my firewall with no luck.

I have downloaded a ton of other programs with no problems at all. I would really like to continue using uTorrent, so I hope someone could help me. I was hoping maybe you have had other people writing in with the same issue and are aware of it and are working on a fix. Please help!!! Much appreciated!!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...