Jump to content

Auto Exit/Shutdown


Recommended Posts



I am using windows 8.1 with HP Pavilion Laptop, the problem i am facing is that I start my download at utorrent in night and left my laptop ON, in morning when i try to check my download the utorrent icon is not available at status window. It automatically exit itself some how. When i start it again it do file checking. Suppose, If i put 5 downloads in night from those 3 are completed rest are undone. Please guide me.


Between I have changed customized power plan setting :-


- Turn off display : after 5 mins.

- Put the computer to sleep : Never 

- Turn off hdd : Never

- Wireless Adapter setting : Maximum performance

- hybrid : off

- lid closed action : do nothing



Link to comment
Share on other sites

I am having the same problem. uTorrent is shutting down on its own.

No error being reported, no pop-up box, no prompts, it just shuts down at random intervals.

Interestingly, it tends to leave the uT icon in the task bar near the clock if it was left minimised but when you go to put your mouse over it, it disappears. If left showing on the screen, it just exits as if the "X" has been clicked.


Like rahul, I usually run my torrents at night but when I come down to check, uT is not running.

I have tried running them during the day and it's just the same - uT seems to just "drop out" for no apparent reason.

Sometimes I have to restart it many times during a 12-hour period.

The "drop-out" can be from 10 minutes to several hours but I have never managed to get it to stay running for more than about 6 hours without it dropping out.

I have tried it with the scheduler and with it turned off - no difference.

Sometimes this happens on the odd Beta versions but this is (supposedly) a stable version.


Unlike rahul, this is on a PC tower with no powersave modes set and it runs 24/7.

Sometimes I have other Apps running: Currently Firefox 33 but it is sitting on my home page doing nothing. I do this sometimes so I can check that the PC hasn't rebooted itself without me realizing it. The other App is still running, so no re-boot has ocurred.

Have left this PC running nothing else for the past week - same result every day (crashed out).

A/V (BitDefender) and (Malware bytes) anti-malware scan every day and completed while it is still running: clean.

Have over 300 Gigs free on target drive, freshly defragged. Attempting to d/l a 21.2GB torrent.

Have run a MemTest (v5) to check Ram: clean.

Also run Intel Burn test for over 100 iterations: clean.


Setup -

WinXP SP3 [32 bit] on Abit Tigerforce IX48 mobo,

Core2 Quad 8600 CPU at 2.66GHz. 4GB Corsair Extreme [Platinum] RAM at 1333MHz.

Gigabit wired ethernet network - not wireless.

Turn off monitor: 2 hours. No screensaver.

nVidia 9600GT 1GB video card.

Wired PS/2 Kb & mouse.

1100W PSU.

Not overclocked.

uT version: 3.4.2 build 34727 Stable (downloaded 16/10/2014 at 10:58am from uT site).

Link to comment
Share on other sites

Why should that make any difference??

If uT can run for a few hours with BD running, then why should BD suddenly make it fail??

Anyways, there is NO way I am going to open my network of 14 PC's to potential threats by disabling my security.

Other PC's here (all XP but with different s/w) have the same issue with uT.

I just picked on the one that I use most often - and it happens to have BD running.

Others just have MSE and malware bytes, not BD. One still has AVG.

No matter what PC I try it on, it is still dropping out.

The issue is with uT alone, nothing else.


As I mentioned previously, sometimes this happens (usually) with a Beta build.

What I usually do is regress to an earlier build, or if it isn't too frequent, wait for the next beta or stable version and that usually cures it.

Whatever the problem is, it has only ever manifest itself periodically since v3.2.

All earlier versions never exhibited this problem.

So something fundamental in a sub-thread/process is getting modified or corrupted on a periodic basis for this to be happening.

Unfortunately, the bug only ever seems to be a solid event on a particular release.

As soon as the next one comes out, it seems to vanish until the next manifestation.


Random observation: From a programmers PoV it seems like a function is not clearing a stack or getting a pointer address wrong so the lower function (whatever it is) is just getting crap parameters/data and just crashing out. This would leave the upper (control) thread with no child process or the child process going AWOL so the next time it gets called it's pot luck if the function is stil memory resident. Obviously Windows thinks it is but it gets to execute random rubbish instead, thus hangs and eventually Windows terminates the process for being hung. That might explain the no warning or reason.

This is pure speculation on my part and probably completely wrong. lol.



So far, the Beta (build 36446) is holding up.

Link to comment
Share on other sites

Check if you have some HDD software running (f.e. Intel Rapid Storage) which has some mode like (f.e.) "Link Power Management".

This could cause your HDD goes to energy safe mode which will let your uTorrent crash.


Yes, Laptop is running that service...tell me what u suggest ?


btw i have a doubt on the AV Bitdefender...as @freedomdraft is using the same AV and is also facing the exact problem...and he doesnot have this service i.e. Intel Rapid Storage running in his computer. 


I have noticed i have been facing this problem only after i have uninstalled my AV Mcafee as it got expired and installed free ver of Bitdefender AV.


Shall i uninstall my AV and install smthing else ? plz suggest. 

Link to comment
Share on other sites

I don't have any power management software at all on here or any other PC.


The IX48 has BD running with malware bytes.

The PC with AVG (and malware bytes) is an old Packard Bell Utow Rio.

Another PC I've tried it on only has MSE and malware bytes, it's an old HP 850T.

None of them are the free versions (except MSE which is free).

The only common factor between them all is XP SP3 (corporate), Ms Office 2010, all installed with the same discs, malware bytes (Pro), and uT.

All are 32-bit. Most have malware bytes and MSE. One has BD, one has AVG.

Some have C1E function, some don't. Some are single core, some are dual/twin core, one is a core2 Quad.

Out of the 14 PC's, 11 are Intel processors, 3 are AMD.

Those that have SMART or other HD monitoring options are all disabled.


uT fails on all of them with the same issue - unexplained drop-out.


And as I said previously, this has only manifested itself periodically since v3.2.

And so far (fingers crossed) the beta I downloaded earlier today is still running on the IX48 without issue and hasn't crashed (yet).

But that isn't any help because I expect another release to work as I've never had 2 consecutive build updates running with the same problem. I don't mean 2 consecutive builds per se, just 2 consecutive downloads of builds when I get round to downloading them and they could be several releases apart from the previous one I used.

But once you get a build with this particular issue, it's a solid bug with that issue.

You can update a dozen times or more with different builds before you hit one with same issue.

Off-hand, with all the many updates/betas since v3.2 I think I've had maybe 4 with this particular issue and they (until now) have always been betas; this is the first stable release to have it to my knowledge.


And in all this time, I have not installed anything new on any of them except Ms and A/V product updates.

Link to comment
Share on other sites

Well last night i have uninstalled BitDefender from my laptop and installed Avira and then started download and today morning when i woke up and checked utorrent on my laptop...it is working just fine, my Problem Solved i guess.


So summary from my end, how much i understand it as @dreadwingknight said "BitDefender being aggressively hostile towards p2p applications lately". Its very true.


@freedomdraft i suggest u too to uninstalled BitDefender and install Avira or another AV in ur desktop...and please tell us does it worked for u ?  :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...