Jump to content

upload stops when time to write block to disk


Recommended Posts

when uTorrent decides to write block to slow media (USB drive) upload stops and download speed drop significantly. Also any file I/O like Checking practically stops upload/download. This is not Cache size issue, I am running Cache at 170Mb and when this happens cache is <15Mb, Version of uTorrent 1.7.2 under Win2k.

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...


As I think the roots of my problem might be the same as the ones previously described in this topic, I decided not to start a new thread & use this one instead, so:

I've tried to open .torrent file with uTorrent, pointing in the appearing dialog box to the removable USB flash drive as the place to store (& share after downloading) the torrent itself, but:

That torrent started, connected to some seeds almost immediately (some of them were local) & gained dl speed around some hundreds of kB/s very quickly, this speed was present for about some minute or a half, then speed started to drop down significantly & stopped dropping at almost exactly 10 kB/s (yes, I've repeated it several times & sustained speed was always between 9.5 - 10.5 kB/s!) & upload speed dropped to zero too!

First time I've turned on upload tasks higher priority against download right before this speed drop happened, so I suspected that this might be the cause of the problem, so I turned this priority off, but nothing has changed. I've checked all the other applicable restrictions, switching them on & off several times (from unlimited to say 100 kB/s & then back), again without success - dl speed was still 10 kB/s, upload almost 0.

Then I've stopped that torrent & resumed it again - still the same.

Then I've stopped that torrent & deleted it in uTorrent window (just task, not torrent data or .torrent file) & opened it again like new task, pointing at the same USB flash as the destination place - I got a message telling that this torrent is in process of deleting, so I've to wait for some time & try later.

Waiting didn't lead to any progress despite LED on a flash drive was constantly & continuously flashing & when I tried to look at the flash drive properties to check the status of the device, windoze explorer hanged to "no responding" & remained in that state even after several attempts to close & reopen it again in Task Manager.

So, I tried to restart the whole computer.

This wasn't easy, cos it didn't want to shutdown until flash drive was "still in use", so after several unsuccessful ordinary attempts to shutdown the machine from windoze I pushed the button by hand & just after keeping it pushed for about 5-10 seconds computer switched off at last.

Then I've turned it on by pushing the same button.

In the process of OS load I got a message that there's some error with the file system on one of the drives (this was that flash drive of course) & OS has to check it.

This check took just a few seconds, after that it said it's alright & loaded OS as usually.

I've checked what's the state of the flash drive in windoze explorer - it showed that there's a torrent data file inside it with the full size of it (despite as I've seen in the progress bar in uTorrent window earlier before shutdown just about 2% of it was really downloaded & I don't have "allocate space for data file" checked in uTorrent preferences).

As I wanted to repeat all the previous situation except changing any priorities or restrictions, I deleted torrent data file from flash drive & opened the same torrent file again, pointing to the same flash drive as a destination place.

NOTHING HAS CHANGED (even after computer restart), up to need to hold the on-off button for a long time to shutdown computer & the same flash drive file system check after switching it on again!

Then I've decided to check what will happen if I'll just try to "resume" that torrent, that is to open it (with the same data destination place) without deleting "still present" data file from flash drive.

As usually, data file check started (& flash drive LED continuous blinking too), but there was no any real progress in it - even after a few minutes of waiting, numbers were still "0.0%" (despite as previously about 2% of data file was already downloaded) - so, no success again, windoze explorer hang, one more restart.

Well, then I've decided to try to download some big data file using ordinary method (from a remote server), not by bit-torrent, to check if download process to that flash drive will be different.

YES, this time there were no any hangs or delays in downloading or writing to flash disk!

(average speed was around 100 kB/s)

Then I opened the same torrent file again, this time using one of HDD partitions (formated in FAT32 to be writable from both windoze & Linux) as a data file destination place - all worked fine as usually & after some time I've downloaded the whole torrent to my HDD.

The last thing to check was to try seeding that torrent from that flash drive, cos I've done this successfully with other torrents (which were previously downloaded to HDD & then moved to flash drive & reopened for seeding with the flash drive as a destination place) - but earlier that was the other flash drive from another manufacturer.

So I've moved the flash drive to be checked contents to another place (there wasn't enough space in it to move that last torrent here), deleted these files from flash drive (cos windoze does copying instead of moving in such cases) & moved (copied!) that torrent data file from HDD to flash drive.

Then I stopped that torrent, deleted it as a task from uTorrent & opened it again, this time with the flash drive (where the torrent data was moved) as a destination place.

I'm writing this just after file check ended with result "100%" & seeding began (I'm still not uploading cos torrent is well seeded - upload was the same rare when I was seeding it from HDD) - so, at least generally speaking, now it works!

DOES THIS MEAN that uTorrent just can't download torrents directly to the flash drives correct way?

Some more details:

uTorrent version - 1.7.5 (just checked - no newer available),

flash drives are connected through USB 1.1 ports (there aren't native USB 2.0 ports in my computers, later I'll try to install additional PCI cards for this), so transfer speed from/to flash drives is limited not by them, but by USB 1.1 itself & is in reality about 800-900 kB/s - when that speed is really used, flash drive LED (if present on the exact model) is constantly & continuously flashing (the same as it was when problems with uTorrent have occurred, but then speed has dropped to just 10 kB/s or no real transfers were present at all!) - when real speed is slower, flashing isn't continuous & is interrupted by pauses, with intervals depending on speed, for example, when I was downloading a file to a flash drive from a remote server with an average speed about 100 kB/s (as I've mentioned earlier), there was about 1 sec flashing followed by about 8 sec pause on & on until the file has been downloaded,

when uTorrent dl speed has dropped down to 10 kB/s, one more strange thing has occurred - this amount was equally divided through all connected seeds, that means about 4*2,5 KB or 5*2 kB - even slight speed changes were synchronous, despite seeds were from different places of the world!

Is someone still reading?

If yes, can anyone answer - is this problem common & caused by uTorrent design or is it happening just for me?

If it is common, can it be fixed somehow or at least why uTorrent just can't give a message like "sorry, I can't do this" & hangs a flash drive &/or windoze explorer instead in such cases?

I'm using Win2k SP4 on Celeron 1.2GHz, this is the file that was created by OS in the flash drive after it's file system check:

Checking file system on I:

The type of the file system is FAT.

One of your disks needs to be checked for consistency. You

may cancel the disk check, but it is strongly recommended

that you continue.

Windows will now check the disk.

Volume Serial Number is 74E9-33D5

Windows has checked the file system and found no problem.

2021326848 bytes total disk space.

32768 bytes in 1 folders.

1363345408 bytes in 2 files.

657948672 bytes available on disk.

32768 bytes in each allocation unit.

61686 total allocation units on disk.

20079 allocation units available on disk.

Torrent was about 1.26 GB in 2 files, but as I've mentioned, just about 2% of it was really downloaded.

At any rate, did µTorrent say "Disk overloaded" in the status bar?

As I can remember - yes, something like this appeared when the speed has dropped down at the left side of where DHT number is shown.

Anyway, alternative download to the same flash drive by using ordinary method didn't result in anything like this, despite the average speed was about 10 times higher - more than this, as I've described, in this alternative case writing to the flash drive was going on in short intervals at full USB 1.1 speed, interrupted by idle pauses.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...