Jump to content

Port is/isn't/is/isn't open...


Recommended Posts

I have properly configured uTorrent as per the guides. My router is currently passing all connections through (I know I should properly forward just the ports that I need, I'll get to it eventually) and my software firewall is set to allow uTorrent connections.

Each time I load uTorrent it's a toss-up whether the port test will pass or fail.

Just now, I loaded a torrent and after waiting 5 minutes or so, the green checkmark icon hadn't appeared, so I clicked on it, then on the port test button. It said that the port was not open. I closed uTorrent and then, without changing a single thing I re-ran uTorrent, tested the port again and it told me it was open and accepting connections.

What would cause uTorrent to find the port closed one time and open the next, without my having changed anything?

Link to comment
Share on other sites

I'm not using Peerguardian or Protowall. I do use the P2P IPfilter.dat from Bluetack, but I've checked to make sure that the IP address uTorrent uses to test the port isn't blocked.

It's still a crap-shoot whether the port will register as open or closed.

Yesterday, I ran uTorrent, checked the port and it was open. This morning I ran it and it said the port was closed. I re-ran it several times, but had no success. I closed all programs, rebooted my system, ran uTorrent again and the port was open. Also, changing the port after uTorrent has run always works. If 20740 is closed, I can change it to 20741 and the port is open. If I later run it and port 20741 is closed, I can change it back to 20740 and it works. The port is almost always open after I reboot my system.

Note that I don't change anything in my firewall or router, nor do I run any programs that would affect what ports can or can't be opened. Also, I run eMule occasionally and I can't recall it ever failing the port test.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...