Jump to content

coalesce_writes Problem

Computer Guru

Recommended Posts

Hello everybody,

coalesce_writes has defaulted to "true" since µTorrent 1.5; prior to that it was set to "false" on default because it had some potential problems - I think those problems may not have been fully resolved?

A while before that, I remember having an issue with uTorrent after I enabled coalesce_writes on my system regarding file system restrictions or something to that effect, and was advised to turn it off, solving the problem.

That was a year+ and many, many, formats and new machines ago.

I'm currently running Windows Vista and uTorrent 1.8 build 7795, and was dowloading a 6.4GB torrent when and it had reached around 13% when I experienced repeated errors about operation not being allowed due to filesystem limitations, which would switch the torrent to "stopped" on error.

Pressing "start" would resume the download for 3-5 minutes, then it would error out again with the same errror. I remembered my previous problem with uTorrent and disabled coalesce_writes, and everything was fine.

The drive is NTFS, chkdsk reveals no abnormalities. Cluster size is the default (4KB?). It's not a system drive, nor is it used for paging or hibernation, etc.

I did not experience this problem with any other torrents. It may have been a one-off thing, I don't know.

that's pretty much it :)

Link to comment
Share on other sites

... If you switch to the Speed tab and go to Disk Stats, you should notice a HIGHER throughput (data / iteration) with coalesce writes enabled...

From the CHM:

diskio.coalesce_writes: This option tells µTorrent to try to minimize the number of writes to disk by writing more data at once. It doesn't have any effect on download speeds, but might increase memory and CPU usage to achieve less disk writes.

I'd say it's possible your Disk Cache settings were not-default. Which options are enabled?

Link to comment
Share on other sites

@jewelishheaven: I know what it does, but I had the default settings for coalesce_writes (which is true), and disabling it (i.e. setting it to *non*-default) removed the problem.

@Firon: I do have sparse files enabled, but unless I'm mistaken that setting is useless under Vista, and full-size files are created any way.

My problem was not solved by disabling sparse files, rather by disabling coalesce_writes, just like a long time ago.

Link to comment
Share on other sites

You're right, I'm sorry.

What threw me off was trying to move a file that was 16GB but was only 300MB on disk.... Vista took such a LONG time that I assumed it was moving the full 16.

At any rate, the initial problem with coalesce_writes isn't related to sparse files unless there's some connection I'm missing here....

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...