Jump to content

The Browser Choke Problem -- Anyone solved yet?


Recommended Posts


I have been following a few posts on this:





UT is connecting and downloading fine, but the browser (in my case firefox) can't connect to anything. It appears that UT is maxing out the connections on the router, maybe.

I have tested only a few variables:

Followed Ultima's guide, no results

Lowered Global Max Connections to something safe® like 50, _halfopen to 4, nothing

The facts that make me think this might not be a speed/connection settings problem is this:

I'm connecting to the machine running UT over a VPN connection, and the performance is great -- no latency, no lag. If bandwidth was an issue, I don't suppose I'd be able to connect at all, or it would be really slow.

I have tested by stopping all down/uploads in UT, but left the app open, and still browser is choked

Cannot even access router admin page when UT has open downloads

Using another BT client, I was able to browse fine while max download rate was set to something like 200kB/s

I have more testing to do, but have to be in front of the machine to do it. Later. For now I thought this info might help.

The router is a linksys WRT54GL

I'll do my best to stick with this thread until a solution is found, and Moderators -- I will post more thorough information as soon as I can -- no need to light me up yet.

Link to comment
Share on other sites

So does that mean it went away? Many routers can't handle DHT, additionally DHT when you are properly forwarded (as you get magnitudes more connections).. I'd look into alternate firmwares personally. Searching here for Hyper-WRT DD-WRT and Tomato will bring up threads about the three most popular (the only 3 I know of) mods.

Link to comment
Share on other sites

  • 4 months later...

I'm going to bump this up as I'm having the exact same problem with the same router. I have tried using both dd-wrt and tomato firmware with and without QOS and there is no difference. As the topic starter states its not a matter of running out of pipe. Its almost like its flooding the router with requests that somehow take a higher priority than the browsing to my untrained eyes. Even after a web page will start to load the text will be displayed first followed by the gfx a 5-7 seconds later. Router does not seem to be over ridden with connections and the CPU is next to nothing. Similar/same settings with azures works like a charm. No web lag at all besides what should be due to the traffic. The uTorrent program can be running with no active transfers and the web functions fine. If I get anything even just 1 client with 5kbs it brings it to a stand still. Any thoughts or ideas are welcome. I tried versions stable, one back from stable, and the beta with the same results

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...