Jump to content

Problems on Exit


Recommended Posts

I'm having a problem I've never had with uTorrent before, I recently just did a fresh install of Windows, and when I run uTorrent, and connect to any peers, whether I'm sending or receiving data, the problem shows up when I exit.

Specifically, I'm not disconnecting from the peers I'm connected to prior to exiting the program. This cripples my internet connection, and the only reason I found out what was going on was when I ran a netstat -a to see if there were any lingering connections I found myself connected to several other computers.

I first tried to restart the program, and exit the program again, but this didn't resolve anything, I then moved on to flushing my IP and renewing it - this seemed to have done the trick.

But this has happened continuously.

Any advice on this one?

Link to comment
Share on other sites


Well, I did have a firewall installed prior to installing uTorrent, specifically the AVG Internet Security suite, but I removed it shortly after installing uTorrent, as it did a lot of things I didn't like in general.

Lingering garbage on my system from AVG you think?

Edit: At present I'm just sticking with the XP firewall for now, I'm resetting my Winsock to see if that won't resolve any of this.

Link to comment
Share on other sites

Not gonna waste your time with a HJT log, it was clean.

The only thing about the peer thing you were mentioning Jewel is that, in all prior installations of uTorrent or any other Torrent client, both on my Linux and Windows box when I need access to my connection for some reason, whether I want to stop the torrents and play a game or watch a video online I can always close out the Torrent client and essentially revitalize my internet connection. I can understand it being connected and slow while I'm running the client, but usually when I shut the client down the connection returns to it's normal speed.

This isn't happening for some reason, it's just slow constantly after exiting uTorrent. It's like it's not even disconnecting the peers, the program just disappears.

Edit: *Resolved*

Okay, well I think I got it resolved. Not entirely sure how, where, or what went wrong, but I think the Winsock reset cleared up whatever was giving uTorrent trouble.

Thanks for your time guys, sorry to have bothered you with this.

Link to comment
Share on other sites

This be the only Winsock reset I know of, doing so resets the LSP's back to there default configuration.

Commands in this context:

? - Displays a list of commands.

dump - Displays a configuration script.

help - Displays a list of commands.

reset - Resets the Winsock Catalog to a clean state.

show - Displays information.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...