Jump to content

mac- really slow download speeds


Recommended Posts


I am using a MAC and runnig OS X 10.5.6, and uTorrent version

my brothers laptop (regular IBM), seems to work fine. he gets the max speeds that we should be getting.

On my computer, I get super slow downloads of max 10kb total, but uploads seem ok, going at 50kb when speed restriction is removed. I will have about 4 torrents downloading, and each will be going at 1.2,1.3kb max..even sometimes it says downloading at .5kb and varying upto about 1.3kbs at the bottom, none of the torrents are showing any activity.

Oddly enough, randomly (which is very rarely) i can get a good download speed of 200kbs on a torrent, and it will download right away.

We are using the linksys WAG54GS, and my brother has updated all the firmware and done the tweaking necessary to get around the throttling of the lines by our ISP (Bell). But my laptop (OS X) just doesn't seem to give me good download speeds. I even installed uTorrent on my windows XP, while running integrated dual boot on Windows Parallels, and still the same slow, download speeds.

I can download perfectly fine on my firefox an IE. but not torrents. could it be some settings in OSX, or on my uTorrent??

I also notice that the light (bottom of the screen) is either yellow or red.

Any information would help....


Link to comment
Share on other sites

Try using a static 192.168.xxx.xxx address on your mac with the default gateway set.

For me, this made a noticeable difference in the speeds - still not quite what you would expect from Windows, but not far off.

Also, increase the connections in Preferences. I have Gloable limit of 1200, which is lots, but uTorrent never stumbles. Also, 300 for Per torrent.

Link to comment
Share on other sites

  • 1 month later...

I have noticed MUCH slower download speeds after using Apple Software Update. I understand slower downloads while I'm using software update, but even when the download has completed, the speeds don't go back up again to what they used to be. They stay slow.

Has anyone else seen this behavior? Any suggestions?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...