Jump to content

tracker reports an invalid external ip - embedded tracker


bunklung

Recommended Posts

I can not get the embedded tracker to work when setting up a private torrent.

I did some searching around here and noticed a few suggestions such as:

"just use a public tracker and set it to private, same thing!"

Please don't respond with this suggestion. This is a feature, and it should work.

The one thing I was able to nail down is that when testing this with another peer, the peer reports a tracker error in the log, "tracker reports an invalid external ip". The seeding machine is reporting no error messages.

I'm using dd-wrt pre-sp2 as a router. This isn't a high end commercial router, but it is popular and very powerful. I'm a bit reserved to say it's the router.

Some things I have done:

I can use utorrent fine on both test machines. Both machines have port forwarding configured correctly and I don't have a problem with any other torrents.

I can successfully seed a file IF I use a public tracker when using both test machines.

My embedded tracker/torrent is set to use the external IP. Both machines respond with the correct extrenal IP as the tracker/port and respond that it's working, again, except the PEER machine reports this error, "tracker reports an invalid external ip"

Yes, I can then manually add the seeded machine as a peer and the transfer will begin.

I have even gone further and turned off the Windows firewall and put the seed machine into DMZ.

The peer machine is on the internet and not on my LAN.

I am using the latest version of utorrent, 2/18296

So please don't say, 1) deal with it, 2) just use this hack work around, and/or 3) it's your router.

I want to better understand this error message. My gut feeling is that I'm not the only one who has this isssue, however, I think most users don't use the embedded tracker so it's just not getting the attention it deserves. And I don't think it's broken for everyone either.

My initial reaction is that the tracker/seeder is providing the peer with a local IP address. The peer can't do anything with a 10.x.x.x address and spits out the error "tracker reports an invalid external ip".

I even tried to enable the Web UI and change the port so that the embedded tracker runs on another incoming port. That didn't work either.

Re-adding the tracker (showing twice and using a space between the tracker list) in the peer machine does not help either.

I'm not going to rule out dd-wrt, but then again, I don't see others screaming in the dd-wrt forums either.

How do we further troubleshoot this? Thanks

Link to comment
Share on other sites

The error, "tracker reports an invalid external IP" is still reported in the logger of the peered machine. I am using your suggested solution on both seed/tracker and peer machine. Any other suggestions?

It appears to ignore this option on the seed/embedded tracker machine and go with the reserved IP address (192.168.x, etc). This is just my guess. This seems to be a bug? If there are no other suggestions, shall I put this in the bug forum? Thanks again.

Link to comment
Share on other sites

I did this on both the peer machine and the seed machine with the following results:

The seed/tracker machine reported it's own internet IP in x.x.x.x form

Once I started the peer up, the peer reported the seed/tracker's internet IP in x.x.x.x:0 form (note: yes, it said zero, not the correct port as configured in utorrent/router/firewall)

I had to "update tracker" in order for the seed/tracker to report the peer even existed. Once I did this, the peerlist copy changed to the peer's internet IP in the x.x.x.x:0 form (note: yes, it said zero, not the correct port as configured in utorrent/router/firewall)

Nothing ever visually shows up in the peer tab. I am just using your instructions using the peer list copy.

Is the port not being sent/recieved correctly by the tracker to the clients and vice versa?

edit- I also tried to put the port in the "ip/hostname to report to tracker" field and nothing changed.

edit2- I guess I'll move this discussion to the bug section, since there seems to be a lack of responses/input to troubleshooting this. Thanks.

Link to comment
Share on other sites

  • 2 weeks later...

Yeah, I don't think I'm the only one here. I just generally think the embedded tracker is:

A) not at all a high priority

B) used by a extremely small percentage of users

If you want a real tracker, use a real tracker. If you want any kind of "private" tracker behavior, you shouldn't be using utorrent or any other sharing style network.

Link to comment
Share on other sites

frustrating: I had used this quite extensively without a problem in past versions. Now with the latest build, I am getting the same symptoms: No errors, shows as seeding, but the msg: Tracker reports an invalid external IP in the logger. I was able to download succesfully on another computer from same IP address and it shows as two peers because of that, but no one else can connect. I have not changed routers or any other configuration at home. I have done hundreds of private torrents with the embedded tracker in past so I know what I am doing with it.

Link to comment
Share on other sites

Yes I am getting the same issue. I saw your post in bug too.

I have tried various combinations including adding a new tracker

http://192.168.0.20:port#/announce to the standard

http://IP:port/announce

Under the Peers tab I have set Log Traffic to Logger Tab and have some additional info below

I get the following

Disconnect: Can't sync DH3 and also

Disconnect: No such torrent:

I have loaded the torrent to download on the same PC and it picks up the 1 (3) peers but no seeds.

The uploading torrent picks up 0 (2) under Seeds.

So I think the problem lies on the uploading torrent file as there are no Peers in the tab where as I can see the other PC on my downloading torrent.

Wow I hope that makes sense in the morning :)

Please note this is my first embedded torrent even though I have used uTorrent for years.

Link to comment
Share on other sites

  • 4 months later...

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...