Jump to content

Stuck at a max of 24kbps


Recommended Posts

I switched ISP's, got a 5MB/800kbps DSL connection yesterday, and yesterday it was fine.

Added the port to the firewall on the router, tests ran fine, had four downloads totalling 498kbps.

Today, have six items downloading, one of which is popular and showing seeds of 56(2739) so expecting a bit more speed than 24kbps. Nothing was changed, added, updated... downloaded the files, shut down for the night. Came home today, turned on the computer, started uTorrent and now stuck.

Ran the uTorrent speed check,

Results: Upload: 524.28 kbits/s (64.0 kB/s) Download: 209.72 kbit/s (25.6 kB/s)

Not sure why so limited in speed...

Speakeasy speed test shows,

Download Speed: 4369 kbps (546.1 KB/sec transfer rate)

Upload Speed: 676 kbps (84.5 KB/sec transfer rate)

Tried using the recommended settings for a few hours, then went back to having the upload limit set to 0 (Unlimited) and still capped at 24kbps.

Running uTorrent 2.0.4, WinXP Pro 32bit SP3, Intel P4 duocore 3.4Ghz w/2GB ram.

Link to comment
Share on other sites

Well, not sure on this one...

Came home, flipped the computer on, ran the Setup Guide, was up around 36kbps.

Setup the same way as I have for years.

Went through the FAQ, ran the setup guide and used recommended settings, enabled protocol encryption, deleted and re-added the port to my modem. Checked the cables, everything plugged in fine. Running ethernet direct to the modem, 1 system running only.

Port was forwarded as outlined in the portforward site linked in the FAQ.

Restarted, tried the setup guide again and dropped to 28kbps.


And again, 2 days ago was running full tilt downloading at 498kbps... nothing added, changed etc.

Upgraded to the BETA version to see if any difference and still same issue.

.... and yet again, I logged into http://www.speakeasy.net/speedtest/ and my results are

Download Speed: 4297 kbps (537.1 KB/sec transfer rate)

Upload Speed: 673 kbps (84.1 KB/sec transfer rate)

So... I don't think it's an issue with my connection/network since I'm getting good speeds outside of uTorrent.

Link to comment
Share on other sites

Already tried that link... no luck. Tried everything in that link (I think I tried all suggestions) and then the other one just posted about the advanced settings changes, restarted the PC and the modem... about the same. 34kbps now, but then again, it seems to change every time I run Setup Guide.

My ISP (Teksavvy) doesn't throttle... I know a few people in my area using uTorrent with the same ISP and downloading approx. 500kbps.

I moved a few days ago, new ISP. Just got it setup 3 days ago and for 1 day it ran fine, the next 2 days it's been crap. :S

Well... downgraded back to 2.0.4 and renamed the settings.dat and settings.dat.old files, so everything is reset back. Port still open, Setup Guide gives 2 green checkmarks so everything works... but still the lousy speed.

Link to comment
Share on other sites

You've made no mention of disabling the special settings that are notorious for crashing/overloading/slowing poor networking, so I'm convinced you haven't tried that yet... :P

Nor do I see a Process Explorer uTorrent.exe DLL list which might give us clues what malware or commercial software (getting to be about the same thing really) is screwing with uTorrent.

Link to comment
Share on other sites

Well... I didn't mention many things, doesn't mean they weren't tried though. :D

As per http://www.utorrent.com/documentation/connection-setup

1 - Done and tests were OK, tried with default speed settings as well as trying higher/lower ones

2 - Enable protocol encryption - Tried with and without

3 - Firewall - Allowed in AVG firewall, and port opened in 2WIRE DSL modem

Also tried "Enable UPnP port mapping" and "Enable NAT-PMP port mapping" and the port manually forwarded on modem/router as per the portfoward site.


Tried all steps under "B. For improving low speed issues"

Downloading the process explorer now (about 240kbps before it finished, just a side note). :D

Will post results in new reply...

Just a reminder though... I tried the regular version of uTorrent, then the BETA to see if helped, and about 1h ago reverted back to the current release and reset everything to see if default settings worked.

Link to comment
Share on other sites

Process PID CPU Private Bytes Working Set Description Company Name

System Idle Process 0 97.73 0 K 16 K

Interrupts n/a 0 K 0 K Hardware Interrupts

DPCs n/a 0.76 0 K 0 K Deferred Procedure Calls

System 4 0 K 108,056 K

smss.exe 752 168 K 400 K Windows NT Session Manager Microsoft Corporation

csrss.exe 808 1,680 K 3,664 K Client Server Runtime Process Microsoft Corporation

winlogon.exe 844 6,696 K 3,372 K Windows NT Logon Application Microsoft Corporation

services.exe 888 0.76 2,944 K 3,960 K Services and Controller app Microsoft Corporation

nvsvc32.exe 1080 4,068 K 5,744 K NVIDIA Driver Helper Service, Version 258.96 NVIDIA Corporation

svchost.exe 1136 2,968 K 4,832 K Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1216 1,812 K 4,412 K Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1312 16,368 K 26,284 K Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1356 2,372 K 3,360 K Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1548 2,044 K 4,340 K Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1684 1,500 K 3,900 K Generic Host Process for Win32 Services Microsoft Corporation

spoolsv.exe 1968 3,204 K 5,016 K Spooler SubSystem App Microsoft Corporation

AVGIDSAgent.exe 2000 50,572 K 43,484 K AVG IDS application AVG Technologies CZ, s.r.o.

svchost.exe 456 1,292 K 3,748 K Generic Host Process for Win32 Services Microsoft Corporation

AppleMobileDeviceService.exe 488 1,988 K 3,332 K Apple Mobile Device Service Apple Inc.

avgwdsvc.exe 500 6,356 K 2,448 K AVG Watchdog Service AVG Technologies CZ, s.r.o.

avgam.exe 2120 4,360 K 592 K AVG Alert Manager AVG Technologies CZ, s.r.o.

avgnsx.exe 2176 12,264 K 2,404 K AVG Network scanner Service AVG Technologies CZ, s.r.o.

avgcsrvx.exe 4080 9,168 K 320 K AVG Scanning Core Module - Server Part AVG Technologies CZ, s.r.o.

avgfws9.exe 540 11,652 K 16,824 K AVG Firewall Service AVG Technologies CZ, s.r.o.

mDNSResponder.exe 564 1,184 K 3,664 K Bonjour Service Apple Inc.

jqs.exe 648 2,064 K 1,424 K Java Quick Starter Service Sun Microsystems, Inc.

NMSAccessU.exe 964 548 K 1,836 K

StarWindServiceAE.exe 1268 1,276 K 3,992 K StarWind iSCSI Target (Alcohol Edition) Rocket Division Software

avgemc.exe 2088 26,640 K 1,152 K AVG E-Mail Scanner AVG Technologies CZ, s.r.o.

avgcsrvx.exe 2296 2,888 K 4,268 K AVG Scanning Core Module - Server Part AVG Technologies CZ, s.r.o.

alg.exe 2636 1,164 K 3,612 K Application Layer Gateway Service Microsoft Corporation

iPodService.exe 2808 2,432 K 4,116 K iPodService Module (32-bit) Apple Inc.

lsass.exe 900 3,824 K 1,552 K LSA Shell (Export Version) Microsoft Corporation

avgchsvx.exe 1380 12,920 K 284 K AVG Cache Server AVG Technologies CZ, s.r.o.

avgrsx.exe 1388 1,420 K 484 K AVG Resident Shield Service AVG Technologies CZ, s.r.o.

avgcsrvx.exe 1600 6,976 K 332 K AVG Scanning Core Module - Server Part AVG Technologies CZ, s.r.o.

explorer.exe 3652 20,104 K 29,336 K Windows Explorer Microsoft Corporation

rundll32.exe 3420 3,764 K 5,048 K Run a DLL as an App Microsoft Corporation

RTHDCPL.EXE 3784 25,596 K 23,376 K Realtek HD Audio Control Panel Realtek Semiconductor Corp.

avgtray.exe 3824 5,076 K 5,060 K AVG Tray Monitor AVG Technologies CZ, s.r.o.

AVGIDSMonitor.exe 1148 1,068 K 3,440 K AVG IDS application AVG Technologies CZ, s.r.o.

jusched.exe 3932 788 K 2,816 K Java Update Scheduler Sun Microsystems, Inc.

iTunesHelper.exe 4056 9,204 K 14,176 K iTunesHelper Apple Inc.

ContentTransferWMDetector.exe 2204 2,076 K 4,228 K Content Transfer Walkman Detector Sony Corporation

ctfmon.exe 3008 912 K 3,732 K CTF Loader Microsoft Corporation

firefox.exe 3792 108,368 K 125,264 K Firefox Mozilla Corporation

plugin-container.exe 3080 14,868 K 20,064 K Plugin Container for Firefox Mozilla Corporation

uTorrent.exe 3848 0.76 18,636 K 16,724 K µTorrent BitTorrent, Inc.

procexp.exe 2816 9,184 K 14,172 K Sysinternals Process Explorer Sysinternals - www.sysinternals.com

Process: uTorrent.exe Pid: 3848

Name Description Company Name Version

ACTIVEDS.dll ADs Router Layer DLL Microsoft Corporation 5.1.2600.5512

adsldpc.dll ADs LDAP Provider C DLL Microsoft Corporation 5.1.2600.5512

ADVAPI32.dll Advanced Windows 32 Base API Microsoft Corporation 5.1.2600.5755

ATL.DLL ATL Module for Windows XP (Unicode) Microsoft Corporation 3.5.2284.2

CLBCATQ.DLL Microsoft Corporation 2001.12.4414.700

COMCTL32.dll User Experience Controls Library Microsoft Corporation 6.0.2900.5512

comdlg32.dll Common Dialogs DLL Microsoft Corporation 6.0.2900.5512

COMRes.dll Microsoft Corporation 2001.12.4414.700

credui.dll Credential Manager User Interface Microsoft Corporation 5.1.2600.5512

CRYPT32.dll Crypto API32 Microsoft Corporation 5.131.2600.5512

cryptdll.dll Cryptography Manager Microsoft Corporation 5.1.2600.5512


DnsApi.dll DNS Client API DLL Microsoft Corporation 5.1.2600.5625

dot3api.dll 802.3 Autoconfiguration API Microsoft Corporation 5.1.2600.5512

dot3dlg.dll 802.3 UI Helper Microsoft Corporation 5.1.2600.5512

eappcfg.dll Eap Peer Config Microsoft Corporation 5.1.2600.5512

eappprxy.dll Microsoft EAPHost Peer Client DLL Microsoft Corporation 5.1.2600.5512

GDI32.dll GDI Client DLL Microsoft Corporation 5.1.2600.5698

hnetcfg.dll Home Networking Configuration Manager Microsoft Corporation 5.1.2600.5512

iertutil.dll Run time utility for Internet Explorer Microsoft Corporation 8.0.6001.18939

IMM32.DLL Windows XP IMM32 API Client DLL Microsoft Corporation 5.1.2600.5512




Iphlpapi.dll IP Helper API Microsoft Corporation 5.1.2600.5512

kernel32.dll Windows NT BASE API Client DLL Microsoft Corporation 5.1.2600.5781


mdnsNSP.dll Bonjour Namespace Provider Apple Inc.

MPRAPI.dll Windows NT MP Router Administration DLL Microsoft Corporation 5.1.2600.5512

MSASN1.dll ASN.1 Runtime APIs Microsoft Corporation 5.1.2600.5875

MSCTF.dll MSCTF Server DLL Microsoft Corporation 5.1.2600.5512

msctfime.ime Microsoft Text Frame Work Service IME Microsoft Corporation 5.1.2600.5768

msv1_0.dll Microsoft Authentication Package v1.0 Microsoft Corporation 5.1.2600.5876

MSVCP60.dll Microsoft ® C++ Runtime Library Microsoft Corporation 6.2.3104.0

msvcrt.dll Windows NT CRT DLL Microsoft Corporation 7.0.2600.5512

mswsock.dll Microsoft Windows Sockets 2.0 Service Provider Microsoft Corporation 5.1.2600.5625

netapi32.dll Net Win32 API DLL Microsoft Corporation 5.1.2600.5694

netshell.dll Network Connections Shell Microsoft Corporation 5.1.2600.5512

Normaliz.dll Unicode Normalization DLL Microsoft Corporation 6.0.5441.0

ntdll.dll NT Layer DLL Microsoft Corporation 5.1.2600.5755

ole32.dll Microsoft OLE for Windows Microsoft Corporation 5.1.2600.5512

oleaut32.dll Microsoft Corporation 5.1.2600.5512

OneX.DLL IEEE 802.1X supplicant library Microsoft Corporation 5.1.2600.5512

rasadhlp.dll Remote Access AutoDial Helper Microsoft Corporation 5.1.2600.5512

RASAPI32.dll Remote Access API Microsoft Corporation 5.1.2600.5512

rasman.dll Remote Access Connection Manager Microsoft Corporation 5.1.2600.5512

RPCRT4.dll Remote Procedure Call Runtime Microsoft Corporation 5.1.2600.6015

rsaenh.dll Microsoft Enhanced Cryptographic Provider Microsoft Corporation 5.1.2600.5507

rtutils.dll Routing Utilities Microsoft Corporation 5.1.2600.5512

SAMLIB.dll SAM Library DLL Microsoft Corporation 5.1.2600.5512

Secur32.dll Security Support Provider Interface Microsoft Corporation 5.1.2600.5834

sensapi.dll SENS Connectivity API DLL Microsoft Corporation 5.1.2600.5512

SETUPAPI.dll Windows Setup API Microsoft Corporation 5.1.2600.5512

SHELL32.dll Windows Shell Common Dll Microsoft Corporation 6.0.2900.6018

shfolder.dll Shell Folder Service Microsoft Corporation 6.0.2900.5512

SHLWAPI.dll Shell Light-weight Utility Library Microsoft Corporation 6.0.2900.5912



TAPI32.dll Microsoft® Windows Telephony API Client DLL Microsoft Corporation 5.1.2600.5512


urlmon.dll OLE32 Extensions for Win32 Microsoft Corporation 8.0.6001.18939

USER32.dll Windows XP USER API Client DLL Microsoft Corporation 5.1.2600.5512

USERENV.dll Userenv Microsoft Corporation 5.1.2600.5512

uTorrent.exe µTorrent BitTorrent, Inc.

uxtheme.dll Microsoft UxTheme Library Microsoft Corporation 6.0.2900.5512

VERSION.dll Version Checking and File Installation Libraries Microsoft Corporation 5.1.2600.5512

wininet.dll Internet Extensions for Win32 Microsoft Corporation 8.0.6001.18939

WINMM.dll MCI API DLL Microsoft Corporation 5.1.2600.5512

WINSTA.dll Winstation Library Microsoft Corporation 5.1.2600.5512

WLDAP32.dll Win32 LDAP API DLL Microsoft Corporation 5.1.2600.5512

WS2_32.dll Windows Socket 2.0 32-Bit DLL Microsoft Corporation 5.1.2600.5512

WS2HELP.dll Windows Socket 2.0 Helper for Windows NT Microsoft Corporation 5.1.2600.5512

wshtcpip.dll Windows Sockets Helper DLL Microsoft Corporation 5.1.2600.5512

WTSAPI32.dll Windows Terminal Server SDK APIs Microsoft Corporation 5.1.2600.5512

xpsp2res.dll Service Pack 2 Messages Microsoft Corporation 5.1.2600.5512

Link to comment
Share on other sites

"We still don't know if you used the correct speed settings for your line though."

Not sure what you mean... I ran the setup guide, tried the speed settings it suggested, tried faster, slower, unlimited... that's all been mentioned so, if another setting somewhere I'm not sure where.

Sadly... this stuff is all based on the assumption that I'm an IT person or programmer of some sorts. If I missed something, well... might be due to the fact that I went to school for Graphic Design, not Networking IT. :D

Will check out the modem... though can't see it being the issue. It might be, but, same time it worked fine the first day. Additionally, not a new modem, I was using it with DSL a year ago and ran full speed no problems... my last ISP was cable so used a different modem until a few days ago. But... almost midnight and need to get some sleep so, will try the modem stuff tomorrow... next step is to try another client.

Link to comment
Share on other sites

That doesn't tell us what you chose for settings. MANY people have read the info, gotten their measured online speeds, then chosen totally the wrong settings for their line.

A year ago, uTorrent wasn't typically making uTP connections. And even Teredo/IPv6 was "new". And net.max_halfopen on Win Vista/Win 7 was increased from 8 to 100-400. So what used to work fine for the modem does not match the conditions now. :(

Link to comment
Share on other sites

And again, 2 days ago was running full tilt downloading at 498kbps... nothing added, changed etc.

If it worked 2 days ago there is no reason that it won't work today. In Setup Guide you should set the upload (and save) to 768 kbit/sec. What do you have in Bandwidth setting, "Maximum download rate"?.

Link to comment
Share on other sites

Finally, someone else thinks it's weird that it worked 3 days ago just fine...

I'll check when I get home, however, when I run that setup guide, it's what detects the max download as being between 24-32kbps and gives recommended settings. I've tried different settings but need to go look/confirm... but, the download test in setup guide, regardless what I set the preferences to, shouldn't it be detecting what my max speeds are?

Link to comment
Share on other sites

Setting to 768 kbps didn't help...and every time I reopen setup it defaults back to 573 oddly. And yes, I was hitting save/close. :)

Reading through the 2Wire deal and keep reading to manually enter the DNS but, can't tell if manually entering it on the network card under network properties for the TCP/IP, or... on the modem itself under Broadband DNS.

Also... which DNS numbers to use... I ran 'DNS Benchmark' and said and were the two fastest. IPCONFIG on my system shows my DNS as which I assume is locally assigned.

would I use these two on the modem? TCP/IP? both? different numbers?


Link to comment
Share on other sites

Well... ran DNSBenchmark a few times, pulled off 2 sets of numbers, manually set the DNS on both the modem and the network card, restarted the modem and computer. Ran DNSBenchmark again and everything is fine, no problems showing at all.

Ran a few different speed tests and line quality tests online, all working fine.

Came to uTorrent and doesn't work... well, works but no increase in speed. Additionally, for the past day, the test fails with Chicago but fine when I use New York #1.

Using the settings from the conservative settings chart (which could have been done a bit better, bit hard to line stuff up). Although supposed to get upload speed of 800kbps, Speakeasy test showed closer to 700kbps so, setup using those numbers.

Also, re-setup the basics seen in the troubleshooting guide since were all wiped out when I reset uTorrent yesterday.

At a total loss on this one.

Link to comment
Share on other sites

What do you have in Bandwidth setting, "Maximum download rate"?.

Your ISP might be disturbing bittorrent traffic. Try to run a good torrent at the same time that you got the 500 kB/s. Do you get the slow speeds from seeds/peers that are only from your country?.

"when I run that setup guide, it's what detects the max download as being between 24-32kbps". TOTALLY ignore speed test result. What speeds do torrents give you?.

Link to comment
Share on other sites

Well, as a test I tried redownloading the same torrent that gave me great speed and was getting stuck at around 20-25kbps.

I emailed the ISP last night and asked them if doing any throttling since I've tried just about everything else I can think of.

Again, online tests like speakeasy are showing proper download speeds... I had it once where someone on the ISP end kicked me down to DSL-LITE once but still charging me for full speed... spent hours trying to figure out what the deal was, turned out the ISP was just too lazy to full check my account when I asked them to.

In this case though... it's just uTorrent (and I tried VUZE as well) that's getting throttled.

I doubt it's the ISP though, simply because my two friends have the exact same dryloop DSL installed and running full speed with Teksavvy (ISP).

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...