Jump to content

For D-Link DSL-G604T or Similar Routers with P2P Problems


Recommended Posts

Do I have to run this every x hours? I've had to run it twice so far...

Another thing I've noticed is you need to ensure any VPN software is offline, mine runs two IP's -local network subnet 3, VPN software runs another on 1 -when connected uTorrent looks at subnet 1 :)

Just incase someone else is having issues ;)

Link to comment
Share on other sites

  • 4 weeks later...
  • Replies 51
  • Created
  • Last Reply


I truly hope someone can help as it probably is a simple fix, but I am not that versed in computer lingo or programming, so please be patient, go easy on me and I hope you can resolve my problem.

It's simple, it just doesn't want to work!!!

I have had everything up and running fine and I have downloaded several movies and sitcom's in the past. Problem is that I type in my search request into the search window hit enter and nothing happens under mininova, piratebay, isohunt or anything else. Nothing happens...usually a separate Internet Explorer would open and search for my request but after I hit the return button nothing.

Okay, I am beginning to get repitious, but it's frustrating...I really hope someone can help!!!



Link to comment
Share on other sites

  • 4 weeks later...

Hi there.

I also have g604t (EU upgraded to version V3.00B02.NZ.20060711) and it's driving me crazy. I get like 10-30 kB/s d/l max. And funny thing - on v1 it was working kinda fine (previously I was using bitspirit port forwarding and upnp enabled).

I have tried many things to fix it, first upgrading the firmware to v2, then to v3, i even tried to put firmware from g684t (well, worked fine, but adsl line couldn't synchronize, bummer). This telnet solution also doesn't help - ok, I have changed everything right, checked the values, but it's getting me nowhere. Damn madness.

Anyhow, I have a question - anyone tried to put a C54APRA firmware or even custom DarkWolf_V3.00B03 into that crappy dls-g604t?

You can't find both @ http://fredcrash.dyndns.org/g604t/index_for_firefox.htm. Unfortunately I can't speak French.

Anyone wants to try it out? Coz I'm desperate right not ; p.



saved configuration, rebooted router, used the telnet script, set u/l limit to unlimited in utorrent - works fine \o. Well, at least for now. Heh.

Link to comment
Share on other sites

  • 1 month later...

Hi all,

I have a wireless D-Link DSL-G604T I use with no problems at all when downloading torrents. The problem is when the download(s) is complete, and the seeding (uploading) begins. After approx 1 hour, the modem / connection just dies. When I manually reboot the modem, the connection is restored, but sure as sunshine, an hour or so later, connection fails again. Ports are forwarded correctly, and I have no problem when using an ethernet cable instead of the wireless. I have tried disabling DHT within utorrent but this has no effect. Will this telnet stuff work? I need it spelled out step by step to avoid confusion. I'm unsure how and where to run the script; using Start - Run command line or the TST10.exe program?? Any help would be appreciated to help clarify my dilemma

PS - the orignal link for the TST10.exe program is dead

Link to comment
Share on other sites

"This problem is extremely easy to identify. You utorrent downloads continue running, all connections continues. For example, a Internet explorer downloads continues with no problem. But "non-continuous" connections stops. You can't ping your router. Your MSN Disconnects. You can't use internet explorer to surf the web. Then this is most probably your problem"

I have this problem... but if my problem is my router, why does it only happen to my VISTA machine, and not my 2 XP machines running the same version of uTorrent? I desperatly need some help on this.. hahahah

Link to comment
Share on other sites

For the sake of the future useless and the current useless such as myself, can someone please take the time to post a step by step guide to running the TST10.exe script "workaround" for D-Link DSL-G604T modem/routers as first discussed in this thread. It would be muchly appreciated.

My routers IP is and not the default mentioned, but even changing this for the script, nothing seems to work????

Link to comment
Share on other sites

Ok, I thought that this script had been running fine for the past few months because I tend to start things running in the evening and not pay attention in the morning when I'm closing uTorrent down. Today though I was just looking through a few settings and I noticed that I was still getting "Tracker Status: offline (timed out)". I don't lose any www connectivity or anything and it's across the board (i.e. all torrents with multiple trackers) so I don't think the sites are offline -though I must confess I haven't checked that.

This time I decided to work through the telnet script stuff from the start and it didn't make any difference this time so I decided to tried running the script from telnet within CMD and got a very interesting response here's the output:

telnet 23

login: root


BusyBox v0.61.pre (2005.08.15-09:45+0000) Built-in shell (ash)

Enter 'help' for a list of built-in commands.

# cd /proc/sys/net/ipv4/netfilter\m

cd: can't cd to /proc/sys/net/ipv4/netfilterm


# echo 4096> ip_conntrack_max\m

cannot create ip_conntrack_maxm: Read-only file system


# echo 50 > ip_conntrack_generic_timeout\m

cannot create ip_conntrack_generic_timeoutm: Read-only file system


# echo 5 > ip_conntrack_tcp_timeout_close\m

cannot create ip_conntrack_tcp_timeout_closem: Read-only file system


# echo 120 > ip_conntrack_tcp_timeout_close_wait\m

cannot create ip_conntrack_tcp_timeout_close_waitm: Read-only file system


# echo 1200 > ip_conntrack_tcp_timeout_established\m

cannot create ip_conntrack_tcp_timeout_establishedm: Read-only file system


# echo 120 > ip_conntrack_tcp_timeout_fin_wait\m

cannot create ip_conntrack_tcp_timeout_fin_waitm: Read-only file system


# echo 60 > ip_conntrack_tcp_timeout_time_wait\m

cannot create ip_conntrack_tcp_timeout_time_waitm: Read-only file system


# echo 10 > ip_conntrack_udp_timeout\m

cannot create ip_conntrack_udp_timeoutm: Read-only file system



So basically the script I've been running all this time has been doing nothing!

Any ideas where I've gone wrong with this?


Link to comment
Share on other sites

Hi muncher027,

I think the reason no-one has done that is they are a little confused as to what you want as the complete step-by-step instructions were posted as the first message in this thread. If you do as it says (creating a text file, copying the instructions into it and saving it in the same folder as the Telnet Script runner) it should work as expect.

What I did was telnet to the router using the built in telnet application in Windows which is not how you should be doing it if you are a novice.

If you are not completely loosing all internet activity I think enabling UPnP is sufficient, to do this log onto the router, click the "Advanced" tab and then UPnP. Choose the connection you would like to enable and click the "Enable UPnP for this connection" checkbox before clicking save. (You'll also need to enable it in uTorrent)



Link to comment
Share on other sites

That telnet website doesnt download file now found in a different language!

Login doesnt work

i type

login : (i type admin)

for password : i type admin

login failure, is it me or am i a dumbass

Link to comment
Share on other sites

I have a DSL -302G and am experiencing all the same symptoms as stated. I would like to do something as simple as enabling uPnP, but it doen't seem to exist anywhere in the advanced section of my router.

Port seems to be fowarded ok, and sometimes I get really high transfer rates, but inevitably it slows right down to about 0.5k, and I am never able to surf the net while utorrent is running. Everything seems to come back to normal a few moments after quitting out of utorrent.

Will this telnet thing work for me?

Shall I even give it a go, seeings as it sound pretty complicated.

Should I just get another modem, from what I am reading D-Links all sound like a pain in the ass

Link to comment
Share on other sites

I have sort of the same problem.

Either Browser I used (Firefox or IE) sometimes don't load any webpage I type, after several times (reload) I get into the pages.

Also whenever I'm downloading something lasting longer than 10 seconds, it stops and never goes back.

MSN connects and disconnects by itself.

Strangely, some p2p-tvstreaming software like "SopCast" works very good (I have a good broadband connection).

More rare is that, if I take my laptop to my office (where there is another D-link router) it also decreases my loading times, although it gives me more seconds.

At this point it is imposible to watch any youtube video cause I can't load even the short ones.

I cleaned my pc from spyware (did use Adware) and also I checked for viruses, and defrag my pc, but nothing worked so far.

These problems started few weeks ago, a year ago I didn't have any problem either with the same router at home or the one at my office, same laptop, same OS, same web-browser.

But the most rare stuff is that, I have another OS running on my lappy besides XP, when I switch to Fedora, I don't get any trouble at all.

What can it be?

Link to comment
Share on other sites

My downloads cap around 40kB/s and my uploads around 50kB/s.

I followed PortForwording instructions. When I do "test if port is fowarded properly", it sends me:

"Checking port 30060 on

Error! Port 30060 does not appear to be open."

But my IP is not at all! And the last 3 digits of this IP change when I restart computer. I have a static IP ( that I set up through the PortForwarding site instructions. Why does the test go for this other IP adress and how do I fix this?

Link to comment
Share on other sites

Why does the test go for this other IP adress and how do I fix this?

Because the 66.254 ip address is the public IP address on your router and the 192.168 ip address is the private IP. There's nothing that needs fixing as far as the test is concerned.

What is the range of IP addresses your router gives out?

Do you have any software firewalls installed?

Link to comment
Share on other sites

DHCP IP Range: 100 to 199

Firewall: AVG (utorrent is in list of allowed applications) It doesn't seem to make much difference if my firewall is activated or not.

Speed test results: D/L 600kbs U/L 215kbs

Everything I've tried from FAQ or tried to understand if applies to my situation failed so far. Any futher advice?

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...

i have a d-link ebr-2310 and its is a new router i put in. I previously had a us robotics router but didn't like it because it had frequent drops of connection (constantly had to reboot the router/renew IP) and couldn't handle high traffic (I could only download about 2-3 torrents at about max 60 kbps). Before that router I had a D-link DI-604 and was perfect until it died.

But now i have the new ebr-2310 and i have the same problem as stated on the first post, but I am unsure if it uses telnet. I can either go online fully, and not turn on uTorrent, but i turn on utorrent, downloads are fine and at optimal (even without port-forwarding) but I cannot use MSN or go to any sites without constant waiting and renewing IP. I cant update firmware (its at 2.00 and is the latest). I am wondering if there is a simple way to fix. Thanks

Link to comment
Share on other sites

  • 1 month later...

Thanks for this. I had similar (browser) problems with my Netgear DG384v3 router, which came with firmware version 4.01.17.

I upgraded to version 4.01.30 (released 5 Sep 2007) and the problem seems to have been fixed. (Later edit: Only 99.5% fixed - browser still very occasionally screws up - acceptable I guess.)

I am running uT 1.7.5 with a global no of connections set to 30 - I don't know whether that's relevant.

See Also: Stuff on router problems in the FAQ at http://utorrent.com/faq.php#Special_note_for_users_with_Linksys_WRT54G_GL_GS_routers

When browsing the forum some more I came across another report of browser problems, and the poster was referred to a post by Ultima called IF YOU HAVE SPEED ISSUES READ HERE FIRST, at http://forum.utorrent.com/viewtopic.php?id=15992 . This list does not mention router problems and fixes/workarounds.

If a moderator is listening (Firon?), I would like to suggest adding the symptoms & solutions discussed here to the FAQ and possily also to That List.

Also needed please: a list of routers which work OK or have a workaround, and how to do it, plus a means for punters to easily add extra routers to the list.

Link to comment
Share on other sites

  • 3 weeks later...

Hi all,

Thanks for this brilliant post. My D/L speed shot up and I can still write and send this message. MSN, SKype all are working! My Router (DLink DSL-504T) is stable now. Now allow me to help those with very few scripting and Linux skills (though you should really learn up). Lemme summarize what you need to do:

Google up

1. Port forwarding and how to open firewall ports for your router, set up static IP for yr PC

2. utorrent tweaks for higher speed D/L and U/L

Once you have got all those working.

3. Download Putty and install. Launch it.

4. At the sessions tab, "Host Name (or IP address)", enter your router's IP. Mine is Protocol has to be TELNET and at port 23.You do not need to change anything else. press "OPEN"

5. you should be presented with the "login" prompt. Enter "admin" and your password

6. now copy the text below and just right-click on the terminal.

cd /proc/sys/net/ipv4/netfilter

echo 2048 > ip_conntrack_max

echo 50 > ip_conntrack_generic_timeout

echo 5 > ip_conntrack_tcp_timeout_close

echo 120 > ip_conntrack_tcp_timeout_close_wait

echo 1200 > ip_conntrack_tcp_timeout_established

echo 120 > ip_conntrack_tcp_timeout_fin_wait

echo 60 > ip_conntrack_tcp_timeout_time_wait

echo 10 > ip_conntrack_udp_timeout

7. To check whether the settings have changed, just enter (applies to other files), make sure you are in the right directory of course.

cat ip_conntrack_max

OUTPUT: 2048

It may be manual but it's very easy manual work!!

Hope this helps you guys as much as it has helped me.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...