Jump to content

Write to Disk: Access Denied


Recommended Posts

Hi! I've been through about a dozen+ threads and google links to no avail, so I am posting here to see if anyone can provide some hint as to what I might try.

The "WriteToDisk: Access Denied" seems a common problem reported, however, where my instance differs than any I've read so far is that I have been able to download several files in parallel with the one single download that it erring out. There is plenty of space (the other successful downloads were larger). The program is running with admin rights. The disk is local.

It initially ran for a good length of time until it hit about 60% complete. Thereafter, it errors out after running for anywhere from 10 seconds to 2 minutes after re Starting it. I've done this restart many times, but the max it ever got was 1% downloaded before failing. It is now at 87.6%.

I've seen one suggestion that it may be file name length. Because of the number of files within the download, it is near impossible for me to tell if this is the case. If it were, wouldn't there be a different error message vs "Access Denied"? Also, I'm not sure why it would continue for another 27% (albeit a bit at a time) before failing completely. Is there a "simple" way to validate that this might be the cause?

Any other suggestions would be appreciated, thanks.

Link to comment
Share on other sites

Thanks. :)

These were two of the messages I did find earlier. I read the How-to-Geek instructions again to see if I missed something. Alas, nothing.

AFAIK, running with Administrator permission should effectively have all the permission necessary to write to the disk, unless something has changed in Win 7, or I misunderstand it all.

Also, why would only one download exhibit this problem, yet ALL other downloads to the same file/directory on the local hard drive have no such problem? If there was a permission problem, it seems that it should be a universal problem, not "random".

Link to comment
Share on other sites

Running with elevated priviliges does not give an application, full, unfettered reign over all the files and drives, there are still some parts of the filing system where file ownership takes precedence of permissions, "run as administrator" is like 'sudo' on linux/unix system where the user is allowed to do a bit more but not quite enough to break things.

Link to comment
Share on other sites

Ok, followed through and still get the same error.

I was wondering why one download has this problem but not any of the others - perhaps we thought each would have their own permission level requirement (even though they are media file types).

I did a check disk and no errors were detected (though if there were, it would seem strange that it keeps accumulating some of the files but eventually quits, while other downloads don't randomly run into that problem section of the disk).

I still theorize that it may be a name length issue, as that would fit the behavior I see. The problem is that there is no visibility to the file list from the torrent site (that is obvious to me), and I imagine the number of files to be numerous, given the overall size of the download. If it is a name length issue, would rather have an error message that says just that.

Link to comment
Share on other sites

  • 1 month later...

I have the same problem, downloading a 32GByte archive.

Environment: Win 7 64bit , uTorrent 3.2.3; Internet access 10Mbps in/out

All other torrents work, this one I have to restart every 30 seconds due to this error:

Error: WriteToDisk: The process cannot access the file because it is being used by another process.

Now there is no other process outside uTorrent 3.2.3 that should work on any of these files being downloaded,all being text or PDF files.

Thus I assumed it has to be the disk cache or disk access issues due to the number of files on the torrent, so set utorrent cache to 200Mbyte and ticked all the options under Options->Advanced-> DIsk Cache-> Override Automatic size. STILL NO DIFFERENCE.

Could not see any funny file names in the Torrent file list either, although there are some pretty long directory/filename combinations.

Any help will be much appreciated, I am at 3% of the 32G file!!

Link to comment
Share on other sites

This fix has worked for numerous people, unsure if it will help in any of the cases above.

Posted by cavalry 69.

1. right click on the torrent displaying the message error: write disk...

2. go to "advanced"

3. go to "set download location"

4a. simply click the "downloads" option under favorites (if you have windows 7 like me)

4b. if you don't have windows 7, simply choose the folder where your downloads usually go (don't know if it will work but i'm really sure it will work)

5. then right click the torrent again

6. choose the "start" option and it should start downloading after a few seconds

The main link in utorrent forum on this subject:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...