Jump to content

"Run Program After Torrent Finishes" doesn't do anything?


Recommended Posts

I can't seem to get the "Run this program when a torrent finishes" to work... at all.


I had used this feature for a while, but when my favorite torrent site told me that don't support 3.4.X yet, I had to downgrade to 3.3.1. Ever since then, I haven't been able to get uTorrent to run my specified program upon completion. However, "Run this program when torrent changes state" works just fine. I've used the exact same script for the "changes state" function and it runs properly, so I know it's not what I'm inputting into those fields that is the problem. It honestly seems like uTorrent just doesn't trigger that feature anymore. Nothing in the Logger tab shows up when a torrent finishes either.


Is anyone else having this issue? I've tried several different versions and builds of uTorrent and I just can't seem to get it to work. I've even noticed that you can right click on a downloading torrent, click on Properties and then Advanced, and you can set the program you want to run for that specific torrent. Still, it fails.


This is probably my favorite feature of uTorrent and I just want it to work again. What am I missing?!



Link to comment
Share on other sites

Nothing is working for me. Traditionally, I've used this:


filebot -script fn:amc --output "D:" --log-file amc.log --action copy --conflict override -non-strict --def music=y subtitles=en artwork=y "ut_label=%L" "ut_state=%S" "ut_title=%N" "ut_kind=%K" "ut_file=%F" "ut_dir=%D"


But now even just using notepad does nothing. As I have stated before, the command to be executed when the torrent changes state works, but  just not when the torrent finishes. It's almost like the download skips the state of Finished.


Is there a log or anything I can post?


**Edit** I'm currently using 3.4.2 (build 33394) for this testing

Link to comment
Share on other sites

I figured it out.


For some reason, my directories for "Put new downloads in:" and "Move completed downloads to:" were the same path. When a torrent finished downloading, uTorrent tried to move it from Folder A to Folder A, freaked out because it had no idea why any dumbass would program it to do such a thing, and then just abandoned everything afterwards.


I hope this helps anyone else who runs into this issue in the future.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...