Jump to content

Certain Tracker Connections Actively Refused


Recommended Posts

Not sure if this a bug or if its me but here is my problem:

- First, for about 50% of the torrents I try to download uTorrent works splendidly. Very fast seeds and no issues to report.

- For the remaining 50% of I seem to be running in to an error "Tracker Status: No connection could be made because the target machine actively refused it."

Now, I've ready all the posts and thought to myself that the tracker is dead or overload, right...well maybe not. I tried the same torrent on ABC also no dice but when I tried it on Azureus it works. If you watch the status of Azures checking the tracker it gets a connection error for ever 2nd or 3rd update but it does succeed to update.

So I have come to the conclusion that perhaps uTorrent handles problem trackers differently than Azureus allowing Azureus to be more effective at dealing with problem trackers. Or maybe its something else…any help would be greatly appreciate as I like uTorrent much better and it has been much faster on the majority of the downloads.



Here are a few details on my setup:

- I don't get a network OK box and instead I get the following


- I have cable modem connection

- Using XP Pro SP2 and the latest version of uTorrent 1.2

- I have a d-link router though and I have DMZ enabled on this machine (I know, bit security hole but that is only use this box for downloading)

- I don't think my ISP does anything crazy.

Hers is a capture of the error I'm getting in uTorrent:

[image removed for content]

EDIT by silverfire: Please blur out tracker URL's and torrent names.

Link to comment
Share on other sites

Not a problem with µTorrent. Pretty much everything tracker status says is a problem with the tracker. The tracker's overloaded and refusing your connection. The pirate bay is commonly unresponsive, just give it time. I usually see it say offline (timeout), though.

Link to comment
Share on other sites

Yeah, I hear you though I'm not so sure. I've tried downloading,a side-by-side, the same file in both uTorrent and Azureus. uTurrent never starts while Azureus sputters for a min or two but starts chuggin' along eventually. I left the file open in uTorrent for a couple of days and it never downloaded. I've tried torrents both from [trackers' names removed for content] with the same issue. Any additional thoughts...

Link to comment
Share on other sites

Do you mean a software or hardware firewall...well I have both....

On my hardware firewall I have the IP the machine is on set to DMS (i.e. wide open). On the software firewall I believe I have it wideopen as well but maybe there is some special settings I'm missing. Again, strange that one app would work OK and uTorrent wouldn't. Does anyone know if uTorrent handles problem trackers differently than Azureus?

Link to comment
Share on other sites

For crummy routers, maybe. :P I DMZ because port forwarding is a pain in the ass, and I honestly don't care. DMZed for years now and never a problem.

My router's never caused that problem, and the 99.9% error isn't the problem he's having anyway. He's getting connection refused on prq.to, instead of a timeout.

Link to comment
Share on other sites

Yes, I have encountered the 99.9% error in Azureus (never with uTorrent) running DMZ. I heard that the issue could be a result of both DMZ NAT/Router issues or Anti-Leeching protocols. My experiance has been that once the ration reaches 1.0, all of the torrents go 100%. Again, I've only had the 99.9% issue with Azureus and ABC and not uTorrent.

Totally agree on port forwarding being safer. To be honest, I'm just too lazy to configure/reconfigure the port forwarding. I only use that machine to download stuff (bittorent, emule, etc.) so I'm not too concerned if it gets hosed. I keep playing around with different clients and network apps and updating the forwarding becomes a chore.

Link to comment
Share on other sites

Piratebay sends out very random messages. I even get HTTP Error 504 - Gateway timeout every once in a while from the prq-url.

And there's no problems with your UPnP settings. It does say " UPnP(32459) OK ", right?

I think Azureus has a longer time-out setting. That could explain why it works there.

Link to comment
Share on other sites

I think it says OK...but all i can read is "UPnP(32459) O"...can't make the window bigger, hehe.

Do you guys know of a way to change the time-out settings in uTorrent? Also, in Azureus, are the time-out settings you are referring to the Tracker/Client Connect/Read settings?

Link to comment
Share on other sites

I don't know if/where there are such settings in Azureus. I'm just guessing that this is the case. And as long as you have no problems with other things, UPnP configuration is correct. And I can't think of any other short word than OK to be written in the statusbar. If you're curious, just change the dpi-settings (Control Panel -> Display -> Settings -> Advanced -> "DPI Settings"

Link to comment
Share on other sites

I've mainly been using azureus but i have also got and test, utorrent, ABC and BitTornado. Regarding [tracker name removed for content] i too have the same problem with uTorrent;

"Tracker Status: No connection could be made because the target machine actively refused it."

On the three other clients it picks up the tracker after several minutes. My assumption is that [tracker name removed for content] isn't active all the time, to reduce server load.

I have tested uTorrent with three computers and all got that same message with [tracker name removed for content] when thay actually connect. When it doesn't connect you will recieve the TimeOut message.

With three computers, One of the computers was directly connected, and the other two where on a different wireless networks. eg. three test subjects on different connections.

My only assumption is that there is something up with either uTorrent, or PirateBay is refusing the client.

Off topic.

Regarding DHT, public trackers which half the time are down, can still be downloaded from using the DHT. It acts like a decentralized tracker, but is not as effective. Azureus' DHT obviously has more members = better download.

The problem with DHT is that private tracker torrents will be distrubuted and server load will be effected on the private tracker. DHT should be disabled when using private trackers.

On topic.

With DHT disabled on azureus, you can still connect and download from [tracker name removed for content]. Due to the fact that i can't connect to [tracker name removed for content] with uTorrent, i believe there is a problem with either the client or tracker, not the router or firewalls etc.

I am guessing that the people that do download from [tracker name removed for content] are using the DHT rather than the tracker.

Can someone that does download from [tracker name removed for content] disable the DHT and post there findings.

I hope this helps someone :-)

I also hope a solution will be posted, or an update created as uTorrent is a nice program

Link to comment
Share on other sites

Sorry for naming the tracker, i was hoping that with more info, people could test it out to see if it is a problem.

@jroc, on a current torrent i am testing i have using Azureus with DHT disabled (seeds 237, peers 2048) when using uTorrent i get the actively refused error.

Can anyone for sure explain why the actively refused error occurs? Where is the problem, as other clients don't get it?

Just found this on a private tracker

"Ok due to all of the requests about all of the 'ghost' leechers that are not showing up on the site we have

taken the following actions uTorrent is now banned in the hope that this will stop this problem..

their may be more client's banned . But at this point it has dropped the level of the extra peers down...

sorry if this has caused any problems for you, but we feel that it in the best interest for the community......"

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...