Jump to content

µTorrent (1.22) and problem with userswitching/initializing d3d window


Recommended Posts

currently when i have µTorrent running, and i switch (using fast user switching) to another account.. this is fine.. whenever i log back into the acct running µTorrent and then switch to the other one *again*, it fails to initialize the video hook driver for that logon, and tells me i should either "try again, or if this's happened before in the session, reboot"

same thing with µTorrent running+a game (all games i currently play are using d3d as API, so i don't know if it's also the case with OpenGL..). First time i run the game, it's fine.. 2nd time, it won't start (failed to init 3d window). this's happened with Rome:Total War as well as CivIV, so i doubt it's game related..

first time i run the game (specifically CivIV) with µTorrent running, it'll play for a while, but then 'freeze', and i have to blindly kill the process in the overview (Mighty annoying, too many processes running that start with a C ;)).. or it CTDs spouting a mem read/allocation clash.

any idea how to fix this? :)

Link to comment
Share on other sites

animorc: i'd really rather not.. 5.7 and higher drivers cause random freezes (ati is still shit at programming).. running 5.6 now, and they work mighty fine in all other situations..

@Firon: i sincerely doubt that.. unless you're trying to tell me a videocard that otherwise works fine goes crazy when it has mutorrent/azureus running.

i've had this problem for about a year with azureus, and have had to reinstall winxp for different reasons about 3x in that period.. so it's not that either..

in any case, it only happens with either of these 2 programs running.. when i close them i can have a game running for 6hrs+ easily without crashes.

anyway, that's half the problem.. the other half is when i have mutorrent running and i use FastUserSwitching more than once in a single session.

this problem is very easily reproducable (here), and happens without 'fail' ;)

config: nForce2 mobo (asus a7n8x-x), AMD Barton 2800+, Asus 9200se (5.6 drivers), 1gb kingston valueram.

Link to comment
Share on other sites

Either a driver installation issue or something seriously wrong with your hardware. You should check the harddrive's integrity aswell as the RAM just to be sure (as you commented to had the issue with azureus as well, and other programs, i doubt its uTorrent's fault, and maybe when your comp gets overloaded it freezes\crashes due to somekind of hardware error).

Link to comment
Share on other sites

not other programs.. just mutorrent and az.

i'm using cat 5.6, yeah..

no dual monitors.

as for the rest of my pc.. like i said.. the only time i have trouble is when i run a game (specifically, any program not using d3d works fine, no matter how much ram it uses), and a d3d window has to be initialized, and with the fast user switching, where mutorrent prevents the video hook driver to start properly after switching to another account a second time.

this NEVER happens with other programs running (if the userswitching happens with az i wouldn't know, í've recently uninstalled that horrible piece of java bloatedness :))

anyway, i can sort of understand how java (being the shitty language that it is) could get games not to function when running.. but mutorrent is written in a totally different language (well, not totally, but still no java), so tbh i'm not really sure why these 2 programs would cause the same sorts of problems..

regardless, it's only with either running that games won't load, even though they will as soon as i've unloaded it.

@chaos: ram is otherwise fine, harddrive integrity checking would be utterly nonsensical, since if it would be something having to do with (one of my 4) harddrives, i would've noticed it in other programs as well, and my pc behaves perfectly aside from this.. and anyway, like i said, my pc doesn't crash/freeze.. the game freezes (ie. it's a software error).. my pc keeps running fine.

Link to comment
Share on other sites

µTorrent/Azureus is probably causing a conflict with your network drivers, the motherboard panics and decides to send a "KILL ALL" signal to the graphics card, effectively crashing its driver as well... :( I dunno if what I said even makes sense, but that's what I'd do if I was your motherboard... :|

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...