Jump to content

uTorrent stopped working properly


Recommended Posts

I have been using uTorrent for years now and it has always worked flawlessly. However a few days ago it stopped working properly. It will take a very long time (more than 30 mins) to connect to a tracker and sometime it will never connect. Sometime it will connect very fast but the download speeds are very slow (less than 10kb/sec) even though the torrent is very healthy. I tried removing uTorrent and reinstalling it and it started working again for a few days and now it's back to the slow mode. I run Win Vista Ultimate and I did not change anything on my computer, router, hardware or software for the past year. I also tried restarting the router, change the port number, enable and disable DHT bu nothing has worked. In my dilemma I installed another torrent client to see if the problem is from ISP or something and that other client (which I will not name) works just like uTorrent used to: very fast connections and downloads at full speed within 2-3 minutes of updating the trackers.

Please let me know what I can try. I have not firewall installed and I scanned my computer for viruses and there are none.

Link to comment
Share on other sites

i am having exactly the same problem. Extremely slow connection, dwnloads rarely get below 6 days ETA and sometimes up to a year !! tried the same solutions plus spent 2hours de-fragmenting.. never had a problem in the past and yet have changed nothing to my knowledge.

how would my isp affect dwnload speed ?? and wot can i do to fix this...????

please help!

Link to comment
Share on other sites


Just FYI, another user has been having tracker troubles while using Qwest. Beginning to look suspicious to me.

At any rate:

a) get HijackThis from trendsecure.com, run it, view the log, and post the contents here

B) get Process Explorer from sysinternals.com, run it, Ctrl+D (to show the lower DLL pane), select the µTorrent process from the list, Ctrl+S (and save the list somewhere you'll find easily -- like the Desktop), then post the contents of the saved process list in the .txt file here


And check this link for additional suggestions (and if they don't help, provide the requested information).

Link to comment
Share on other sites

ok m8 iv "hijacked" my computer for you ! looking forward to finding out wot you make of this...!?

Logfile of Trend Micro HijackThis v2.0.2

Scan saved at 17:27:05, on 01/11/2008

Platform: Windows Vista SP1 (WinNT 6.00.1905)

MSIE: Internet Explorer v7.00 (7.00.6001.18000)

Boot mode: Normal

Running processes:




C:\Program Files\Windows Defender\MSASCui.exe

C:\Program Files\Java\jre1.6.0_07\bin\jusched.exe





C:\Program Files\AVG\AVG8\avgtray.exe

C:\Program Files\iTunes\iTunesHelper.exe

C:\Program Files\Kontiki\KHost.exe


C:\Program Files\Windows Media Player\wmpnscfg.exe


C:\Program Files\iTunes\iTunes.exe

C:\Program Files\Mozilla Firefox\firefox.exe


C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =

R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyOverride = *.local

R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName =

O1 - Hosts: ::1 localhost

O2 - BHO: AcroIEHelperStub - {18DF081C-E8AD-4283-A596-FA578C2EBDC3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelperShim.dll

O2 - BHO: WormRadar.com IESiteBlocker.NavFilter - {3CA2F312-6F6E-4B53-A66E-4E65E497C8C0} - C:\Program Files\AVG\AVG8\avgssie.dll

O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll

O2 - BHO: (no name) - {7E853D72-626A-48EC-A868-BA8D5E23E045} - (no file)

O2 - BHO: AVG Security Toolbar - {A057A204-BACC-4D26-9990-79A187E2698E} - C:\PROGRA~1\AVG\AVG8\AVGTOO~1.DLL

O3 - Toolbar: AVG Security Toolbar - {A057A204-BACC-4D26-9990-79A187E2698E} - C:\PROGRA~1\AVG\AVG8\AVGTOO~1.DLL

O4 - HKLM\..\Run: [Windows Defender] %ProgramFiles%\Windows Defender\MSASCui.exe -hide

O4 - HKLM\..\Run: [sunJavaUpdateSched] "C:\Program Files\Java\jre1.6.0_07\bin\jusched.exe"

O4 - HKLM\..\Run: [igfxTray] C:\Windows\system32\igfxtray.exe

O4 - HKLM\..\Run: [HotKeysCmds] C:\Windows\system32\hkcmd.exe

O4 - HKLM\..\Run: [Persistence] C:\Windows\system32\igfxpers.exe

O4 - HKLM\..\Run: [AVG8_TRAY] C:\PROGRA~1\AVG\AVG8\avgtray.exe

O4 - HKLM\..\Run: [4oD] "C:\Program Files\Kontiki\KHost.exe" -all

O4 - HKLM\..\Run: [Adobe Reader Speed Launcher] "C:\Program Files\Adobe\Reader 9.0\Reader\Reader_sl.exe"

O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\QTTask.exe" -atboottime

O4 - HKLM\..\Run: [iTunesHelper] "C:\Program Files\iTunes\iTunesHelper.exe"

O4 - HKCU\..\Run: [kdx] C:\Program Files\Kontiki\KHost.exe -all

O4 - HKCU\..\Run: [ehTray.exe] C:\Windows\ehome\ehTray.exe

O4 - HKCU\..\Run: [WMPNSCFG] C:\Program Files\Windows Media Player\WMPNSCFG.exe

O4 - HKUS\S-1-5-19\..\Run: [sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'LOCAL SERVICE')

O4 - HKUS\S-1-5-19\..\Run: [WindowsWelcomeCenter] rundll32.exe oobefldr.dll,ShowWelcomeCenter (User 'LOCAL SERVICE')

O4 - HKUS\S-1-5-20\..\Run: [sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'NETWORK SERVICE')

O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~3\Office10\EXCEL.EXE/3000

O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\PROGRA~1\Java\JRE16~1.0_0\bin\ssv.dll

O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\PROGRA~1\Java\JRE16~1.0_0\bin\ssv.dll

O13 - Gopher Prefix:

O16 - DPF: {678940D3-080C-4FCE-A54D-D443E1177F01} - https://www.coolroom.com/ActiveX/ax.dll

O18 - Protocol: linkscanner - {F274614C-63F8-47D5-A4D1-FBDDE494F8D1} - C:\Program Files\AVG\AVG8\avgpp.dll

O20 - AppInit_DLLs: avgrsstx.dll

O23 - Service: Lavasoft Ad-Aware Service (aawservice) - Lavasoft - C:\Program Files\Lavasoft\Ad-Aware\aawservice.exe

O23 - Service: Apple Mobile Device - Apple Inc. - C:\Program Files\Common Files\Apple\Mobile Device Support\bin\AppleMobileDeviceService.exe

O23 - Service: AVG Free8 WatchDog (avg8wd) - AVG Technologies CZ, s.r.o. - C:\PROGRA~1\AVG\AVG8\avgwdsvc.exe

O23 - Service: Bonjour Service - Apple Inc. - C:\Program Files\Bonjour\mDNSResponder.exe

O23 - Service: iPod Service - Apple Inc. - C:\Program Files\iPod\bin\iPodService.exe

O23 - Service: KService - Kontiki Inc. - C:\Program Files\Kontiki\KService.exe


End of file - 5259 bytes

thanks for the help!

Link to comment
Share on other sites

From here, ISP :( It's been reported depending on the ISP you can get to their support, get escalated to a higher-up, or be transferred to billing and really demand your service improve irregardless of their policy on filesharing, or bandwidth usage as long as you're not going overboard... or drop them as a provider.

Note that doesn't work if you and they BOTH know you don't have a choice in ISPs (especially a problem in the US with POOR broadband penetration outside the top-50 metropolitan areas).

Link to comment
Share on other sites

Well, in wozza21's case, he's behind as####.net, which is related to Tiscali -- a known throttling ISP -- so you'd be correct on that hunch. cnico88 is behind Qwest, which, as I mentioned earlier, is arousing my suspicions.

Indeed, it seems like ISPs are to blame here.

Link to comment
Share on other sites


Why would the ISP block affect only uTorrent though? That is my question. I am using a different client now and it works just fine. It's just that I don't like using other clients since uTorrent is so easy to use.

Oh and by the way I checked to see if Qwest is throttling my bittorent traffic and the results came out clean on all the major ports. (which makes sense when I use the other client)

Oh and on the Wiki it says Qwest throttles encrypted traffic. Should I disable encryption>?

Link to comment
Share on other sites

My net.max_halfopen is set to *80 and the statistics show it at 8 (connecting)

I never said I had tracker problems. The tracker always shows as working. It's just that it downloads extremely slow, below dialup speeds on healthy torrents like the Ubuntu that was just released with 6000+ seeders and only 2000+ peers.

Link to comment
Share on other sites

Hello, I'm hoping someone could kindly give me some technical advice. I have been using utorrent for some time now and think it is an excellent product. Unfortunately around I week ago, it stopped working for me? I have around a 4mbps line and usually easily achieve up to 350 KB/s down loads.

I changed 3 things as follows,

1) Added pier guardian,

2) Used a blue tack block list

3) Upgraded to Xp service pack 3

I have no idea what if any of the above is causing my problems. I have removed pier guardian, the block lists and their download software, removed and reinstalled utorrent and tried different clients. I have also tried a fixed line modem and 3 different ADSL routers; to no avail the problems remain constant.

I am able to configure fire walls and open the correct ports; the net.max_halfopen was set at 8 and has been tried at 6 & 4. The problem remains, my download speeds are now 0.3KB/s to 3.0KB/s.

I am connecting to many peers - seeds & lechers, but none are downloading bits to me.

Glasnost 7 minute test suggests my ISP, AOL is not throttling the service when bit torrent is used.

I have tried Ultima's Troubleshooting Guide?: http://forum.utorrent.com/viewtopic.php?id=15992

and checked the recommended uTorrent settings: http://forum.utorrent.com/viewtopic.php?id=34259

etc: Canned bad news replies: http://forum.utorrent.com/viewtopic.php … 27#p192027

etc: Sequential downloading DESTROYS torrents!: http://www.azureuswiki.com/index.php/Se … ing_is_bad

The torrents used are good, high speed torrents, SLACKWARE downloads have also been tried and the results are no better. Please help if you can, I will provide whatever information is required.

Kind regards


Link to comment
Share on other sites

hi guys! have used Utorrent for a while, have Vista, i use firefox as my Isp, and regularly have DL speeds of between 10kb-50kb is this normal? On speed tests, I have DL of 5000kbps and UL of 600kbps.. so i presume that is pretty good, so why the slow torrent DLoads? Also the last 2 days, I haven't been able to DL anything.. All the things I've selected has 100's or 1000's of seeds, but when selected and attempt to download they have seeds in the brackets

seeds peers

0(1123) 0(500)

But where before there were numbers before the brackets, there is none now!

My computer seems to have to have lost the ability to DL or pick up avail seeds...

Have tried various items to DL, but have the same problem on everything I attempt to DL.

It was fine 2 days ago, but nothing now..

Any Ideas please?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...