Jump to content

WebUI stops working after a few hours


Recommended Posts


I've been running uTorrent under Wine on Linux for some time.

I normally use the webU I(0.361), mUI or uRemote to connect and have never had any real problems, until now.

Now what happens is that it works fine on a fresh start - whether that be rebooting the system or exiting uTorrent (which I annoyingly end up having to kill in System Monitor before it lets me re-load). The webUI and uRemote work on my LAN and the mUI works fine over the HSDPA on my HTC.

All very useful.

Now what happens is that after an unspecified amount of time it all stops working - apart from uTorrent which continues to up/down load. However the only way I can access it is through the Linux box it's running on. Even on this box I can't access the webUI, using my IP, or localhost in the address.

Firefox gives me the following error:

Failed to Connect

The connection was refused when attempting to contact localhost:xxxx.

Though the site seems valid, the browser was unable to establish a connection.

* Could the site be temporarily unavailable? Try again later.

* Are you unable to browse other sites? Check the computer's network connection.

* Is your computer or network protected by a firewall or proxy? Incorrect settings can interfere with Web browsing.


I have a static IP and know that the address is correct because it works to start with. I also know that the Linux box is fine (I use NoMachine through ssh to access it from anywhere I like and have also set up a ssh tunnel for a friend who moved to LA so he can watch BBC iPlayer).

I do use MoBlock but this, along with my firewall, is running when the webUI works. Also killing it doesn't help.

Please help - I am getting more and more tempted to move over to Deluge but it doesn't have all the add-ons and I have been happy with uTorrent for years.

Link to comment
Share on other sites

... uTorrent doesn't have a plugin system. Have you enabled logging and tracked WebUI requests under verbose and error sections? You can launch uT with logging by using /LOGFILE launch parameter.

You need to figure out whether the request is actually hitting the backend (uTorrent) or if it's intercepted. If it's intercepted check your software firewall, hardware firewall, or... uhm, 'top' for additional processes??

Edit: Maybe the needing to kill System Monitor is a symptom of something else...

Link to comment
Share on other sites

Sorry for the misunderstanding.

I don't have a problem with System Monitor and I don't have to kill it. I do have to kill the running uTorrent process through System Monitor (or I could use top as you mentioned) after exiting uTorrent because for some reason the "exit" option doesn't do the job.

Also I wasn't referring to plug-ins but to all of the addition and 3rd party add-ons such as the mUI, Firefox plug-in, uRemote etc.

Right .....

Log gives me "Bad username/password" which is odd since it works for a while then stops

I have re-entered the details and now there's no problems.... apart from .....

All works - mUI over 3G, webUI on another machine but the browser on the Linux box running uTorrent gives the same error as before if i enter the IP (external - which works with the mUI) but if I use localhost or the LAN IP it's fine !!

What's going on ??!

Ok - update

It's stopped working AGAIN

Nothing new in log file

Link to comment
Share on other sites

  • 8 months later...

I am having the same type of issue on ubuntu jaunty 32bit and wine 1.1.35 and wine stable (tried both). Everything works fine for a day or so and then without changing anything in uT the webui just doesn't come up anymore. I either just get loading forever or connectin reset like above poster mentioned. Any help would be appreciated

Link to comment
Share on other sites

  • 2 weeks later...
  • 5 weeks later...
  • 3 weeks later...

If connection count was an issue, then connection attempts would either time out (in which case the above-mentioned problem handling would inform the user), or it would keep updating once a connection is actually established. It wouldn't cause a perpetual no-update situation without the user knowing explicitly that a problem occurred. At least not with v0.370 (which orb360 hasn't clarified on whether or not he's using it).

Link to comment
Share on other sites

  • 1 month later...

Yea, I'm having this same kind of issue.

OS: Windows 7 x86 Home Premium

I have WebUI running, and it works fine.

It works both locally, and remotely.

I have it port forwarded, and works fine when using my iPhone to access it over 3G (wifi off)

After awhile, it just decides to not working anymore remotely.

I thought maybe it was justing doing it because i changed my router DNS to point to openDNS, and that openDNS had some kind of security for that in my account settings and didn't want to look into it yet; and i mainly did this becausen when i'm on my friend's network his internet speeds and gaming is off the charts. And we have the same internet and live right by each other, so he told me he uses openDNS. So I decided to give it a go.

So, i go back, and change the router DNS settings to get automatically from ISP.

Router resets, and uTorrent WebUI is working again.

Few hours later, i'm not home, decided to add a torrent to my downloads.

Stopped working again.

Link to comment
Share on other sites

  • 3 months later...

I've got exactly the same problem here.

I'm running uTorront in Whine on Ubuntu. When I start uTorrent the WebUI works fine, from inside the network aswell as from the outside. But after about 1 to 2 hours the WebUI doesn't react anymore. But uTorrent itself works fine...

Any news on this problem yet?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...