Jump to content

uTorrent 2.0 (Build 17920) - Unresponsive in Taskbar


Recommended Posts

Okay, so I recently got the notification asking me if I wanted to upgrade to uTorrent 2.0. I did so and am a bit annoyed, because of a bug that keeps me from being able to download. This has happened more than 5 times (just about every time since I downloaded 2.0), but it seems to only happen when uTorrent is minimized to the taskbar.

So at some point, uTorrent just stops working all together. It stops downloading, uploading and becomes unresponsive. Trying to double-click on it does nothing. Right-clicking on it to try to Exit it doesn't work either. The first time, the process was even locked, and I couldn't quit it via Task Manager, I had to downloaded Process Explorer.

Has anyone else had this problem? I'm running Windows 7 Ultimate (32-bit)... also, I'm not sure but I think this problem may only occur when I have the torrents running (downloading / uploading.)

Edit: Sorry, just read the "How to report a bug"... I didn't take logs at the time, so here's some logs of right now (these were NOT taken while the bug was occurring... if I catch the bug again, I'll definitely take a HT and Process Explorer log.)


Logfile of Trend Micro HijackThis v2.0.2
Scan saved at 4:10:50 PM, on 2/16/2010
Platform: Unknown Windows (WinNT 6.01.3504)
MSIE: Unable to get Internet Explorer version!
Boot mode: Normal

Running processes:
C:\Program Files\PowerISO\PWRISOVM.EXE
C:\Program Files\Microsoft Office\Office12\GrooveMonitor.exe
C:\Program Files\Synaptics\SynTP\SynTPEnh.exe
C:\Program Files\Common Files\Java\Java Update\jusched.exe
C:\Program Files\Adobe\Acrobat 9.0\Acrobat\acrotray.exe
C:\Program Files\Synaptics\SynTP\SynTPHelper.exe
C:\Program Files\DynDNS Updater\DynTray.exe
C:\Program Files\Windows Live\Messenger\msnmsgr.exe
C:\Program Files\Windows Live\Contacts\wlcomm.exe
C:\Program Files\Xfire\Xfire.exe
C:\Users\John\Downloads\Torrents\Counter Stike Source\CSS_FULL_Oct-15-07_DiGiTALZonE_1START.exe
C:\Program Files\Mozilla Firefox\firefox.exe
C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Local Page =
R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName =
O1 - Hosts: ::1 localhost
O2 - BHO: ContributeBHO Class - {074C1DC5-9320-4A9A-947D-C042949C6216} - C:\Program Files\Adobe\/Adobe Contribute CS4/contributeieplugin.dll
O2 - BHO: AcroIEHelperStub - {18DF081C-E8AD-4283-A596-FA578C2EBDC3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelperShim.dll
O2 - BHO: (no name) - {5C255C8A-E604-49b4-9D64-90988571CECB} - (no file)
O2 - BHO: Groove GFS Browser Helper - {72853161-30C5-4D22-B7F9-0BBC1D38A37E} - C:\Program Files\Microsoft Office\Office12\GrooveShellExtensions.dll
O2 - BHO: Windows Live Sign-in Helper - {9030D464-4C02-4ABF-8ECC-5164760863C6} - C:\Program Files\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll
O2 - BHO: Adobe PDF Conversion Toolbar Helper - {AE7CD045-E861-484f-8273-0445EE161910} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEFavClient.dll
O2 - BHO: Ask Toolbar BHO - {D4027C7F-154A-4066-A1AD-4243D8127440} - (no file)
O2 - BHO: Java(tm) Plug-In 2 SSV Helper - {DBC80044-A445-435b-BC74-9C25C1C588A9} - C:\Program Files\Java\jre6\bin\jp2ssv.dll
O2 - BHO: SmartSelect - {F4971EE7-DAA0-4053-9964-665D8EE6A077} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEFavClient.dll
O3 - Toolbar: (no name) - {D4027C7F-154A-4066-A1AD-4243D8127440} - (no file)
O3 - Toolbar: Adobe PDF - {47833539-D0C5-4125-9FA8-0819E2EAAC93} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEFavClient.dll
O3 - Toolbar: Contribute Toolbar - {517BDDE4-E3A7-4570-B21E-2B52B6139FC7} - C:\Program Files\Adobe\/Adobe Contribute CS4/contributeieplugin.dll
O4 - HKLM\..\Run: [PWRISOVM.EXE] C:\Program Files\PowerISO\PWRISOVM.EXE
O4 - HKLM\..\Run: [GrooveMonitor] "C:\Program Files\Microsoft Office\Office12\GrooveMonitor.exe"
O4 - HKLM\..\Run: [SynTPEnh] %ProgramFiles%\Synaptics\SynTP\SynTPEnh.exe
O4 - HKLM\..\Run: [IgfxTray] C:\Windows\system32\igfxtray.exe
O4 - HKLM\..\Run: [HotKeysCmds] C:\Windows\system32\hkcmd.exe
O4 - HKLM\..\Run: [Persistence] C:\Windows\system32\igfxpers.exe
O4 - HKLM\..\Run: [SunJavaUpdateSched] "C:\Program Files\Common Files\Java\Java Update\jusched.exe"
O4 - HKLM\..\Run: [AdobeCS4ServiceManager] "C:\Program Files\Common Files\Adobe\CS4ServiceManager\CS4ServiceManager.exe" -launchedbylogin
O4 - HKLM\..\Run: [Adobe Acrobat Speed Launcher] "C:\Program Files\Adobe\Acrobat 9.0\Acrobat\Acrobat_sl.exe"
O4 - HKLM\..\Run: [Acrobat Assistant 8.0] "C:\Program Files\Adobe\Acrobat 9.0\Acrobat\Acrotray.exe"
O4 - HKLM\..\Run: [Adobe_ID0ENQBO] C:\PROGRA~1\COMMON~1\Adobe\ADOBEV~1\Server\bin\VERSIO~2.EXE
O4 - HKCU\..\Run: [uTorrent] "C:\Users\John\Downloads\Programs\utorrent.exe"
O4 - HKCU\..\Run: [msnmsgr] "C:\Program Files\Windows Live\Messenger\msnmsgr.exe" /background
O4 - HKCU\..\Run: [DisplayFusion] "C:\Program Files\DisplayFusion\DisplayFusion.exe"
O4 - HKUS\S-1-5-19\..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /autoRun (User 'LOCAL SERVICE')
O4 - HKUS\S-1-5-19\..\RunOnce: [mctadmin] C:\Windows\System32\mctadmin.exe (User 'LOCAL SERVICE')
O4 - HKUS\S-1-5-20\..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /autoRun (User 'NETWORK SERVICE')
O4 - HKUS\S-1-5-20\..\RunOnce: [mctadmin] C:\Windows\System32\mctadmin.exe (User 'NETWORK SERVICE')
O4 - Global Startup: DynDNS Updater Tray Icon.lnk = C:\Program Files\DynDNS Updater\DynTray.exe
O8 - Extra context menu item: Add to &Evernote - res://C:\Program Files\Evernote\Evernote3.5\enbar.dll/2000
O8 - Extra context menu item: Append to existing PDF - res://C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEFavClient.dll/AcroIEAppend.html
O8 - Extra context menu item: Convert link target to Adobe PDF - res://C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEFavClient.dll/AcroIECaptureSelLinks.html
O8 - Extra context menu item: Convert link target to existing PDF - res://C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEFavClient.dll/AcroIEAppendSelLinks.html
O8 - Extra context menu item: Convert to Adobe PDF - res://C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEFavClient.dll/AcroIECapture.html
O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\Office12\EXCEL.EXE/3000
O9 - Extra button: Send to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\PROGRA~1\MICROS~2\Office12\ONBttnIE.dll
O9 - Extra 'Tools' menuitem: S&end to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\PROGRA~1\MICROS~2\Office12\ONBttnIE.dll
O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~2\Office12\REFIEBAR.DLL
O9 - Extra button: Add to Evernote - {E0B8C461-F8FB-49b4-8373-FE32E92528A6} - C:\Program Files\Evernote\Evernote3.5\enbar.dll
O9 - Extra 'Tools' menuitem: Add to Evernote - {E0B8C461-F8FB-49b4-8373-FE32E92528A6} - C:\Program Files\Evernote\Evernote3.5\enbar.dll
O13 - Gopher Prefix:
O18 - Protocol: grooveLocalGWS - {88FED34C-F0CA-4636-A375-3CB6248B04CD} - C:\Program Files\Microsoft Office\Office12\GrooveSystemServices.dll
O23 - Service: Adobe Version Cue CS4 - Adobe Systems Incorporated - C:\Program Files\Common Files\Adobe\Adobe Version Cue CS4\Server\bin\VersionCueCS4.exe
O23 - Service: Apache2.2 - Apache Software Foundation - C:\xampp\apache\bin\httpd.exe
O23 - Service: DynDNS Updater - Dynamic Network Services, Inc. - C:\Program Files\DynDNS Updater\DynUpSvc.exe
O23 - Service: FileZilla Server - FileZilla Project - C:\xampp\FileZillaFTP\FileZilla server.exe
O23 - Service: FLEXnet Licensing Service - Acresso Software Inc. - C:\Program Files\Common Files\Macrovision Shared\FLEXnet Publisher\FNPLicensingService.exe
O23 - Service: MySQL - MySQL AB - C:\xampp\mysql\bin\mysqld.exe
O23 - Service: PnkBstrA - Unknown owner - C:\Windows\system32\PnkBstrA.exe
O23 - Service: Remote Packet Capture Protocol v.0 (experimental) (rpcapd) - CACE Technologies, Inc. - C:\Program Files\WinPcap\rpcapd.exe
O23 - Service: TeamViewer 5 (TeamViewer5) - TeamViewer GmbH - C:\Program Files\TeamViewer\Version5\TeamViewer_Service.exe

End of file - 7742 bytes

Process Explorer:

Process    PID    CPU    Description    Company Name    User Name    Window Title    Path    Command Line    Version    Window Status    DEP    Virtualized
System Idle Process 0 66.67 NT AUTHORITY\SYSTEM <n/a>
Interrupts n/a Hardware Interrupts <n/a>
DPCs n/a 0.76 Deferred Procedure Calls <n/a>
System 4 1.52 <access denied> <n/a>
smss.exe 360 <access denied> <n/a>
csrss.exe 456 <access denied> <n/a>
wininit.exe 508 <access denied> <n/a>
services.exe 568 <access denied> <n/a>
svchost.exe 748 <access denied> <n/a>
igfxsrvc.exe 3064 igfxsrvc Module Intel Corporation JOHN-LAPTOP\John C:\Windows\System32\igfxsrvc.exe C:\Windows\system32\igfxsrvc.exe -Embedding
wlcomm.exe 3892 Windows Live Communications Platform Microsoft Corporation JOHN-LAPTOP\John C:\Program Files\Windows Live\Contacts\wlcomm.exe "C:\Program Files\Windows Live\Contacts\wlcomm.exe" -Embedding 14.0.8098.930 DEP (permanent) Virtualized
svchost.exe 824 <access denied> <n/a>
svchost.exe 896 <access denied> <n/a>
audiodg.exe 3816 <access denied> <n/a>
svchost.exe 960 <access denied> <n/a>
dwm.exe 380 3.03 Desktop Window Manager Microsoft Corporation JOHN-LAPTOP\John C:\Windows\System32\dwm.exe "C:\Windows\system32\Dwm.exe" 6.1.7600.16385 DEP (permanent)
svchost.exe 1004 <access denied> <n/a>
wuauclt.exe 4884 Windows Update Microsoft Corporation JOHN-LAPTOP\John C:\Windows\System32\wuauclt.exe "C:\Windows\system32\wuauclt.exe" 7.3.7600.16385 DEP (permanent)
taskeng.exe 3008 JOHN-LAPTOP\John <n/a>
svchost.exe 1176 <access denied> <n/a>
svchost.exe 1280 <access denied> <n/a>
spoolsv.exe 1500 <access denied> <n/a>
svchost.exe 1552 <access denied> <n/a>
httpd.exe 1660 <access denied> <n/a>
httpd.exe 3040 <access denied> <n/a>
FileZilla Server.exe 1700 <access denied> <n/a>
mysqld.exe 1764 <access denied> <n/a>
PnkBstrA.exe 1832 <access denied> <n/a>
svchost.exe 1860 <access denied> <n/a>
taskhost.exe 1972 Host Process for Windows Tasks Microsoft Corporation JOHN-LAPTOP\John C:\Windows\System32\taskhost.exe "taskhost.exe" 6.1.7600.16385 DEP (permanent) Virtualized
TeamViewer_Service.exe 2012 <access denied> <n/a>
TeamViewer.exe 608 <access denied> <n/a>
DynUpSvc.exe 1512 <access denied> <n/a>
svchost.exe 3996 <access denied> <n/a>
dllhost.exe 1928 <access denied> <n/a>
msdtc.exe 2308 <access denied> <n/a>
SearchIndexer.exe 2788 0.76 <access denied> <n/a>
wmpnetwk.exe 2268 <access denied> <n/a>
svchost.exe 2408 <access denied> <n/a>
svchost.exe 4408 <access denied> <n/a>
svchost.exe 5480 <access denied> <n/a>
svchost.exe 5312 <access denied> <n/a>
taskhost.exe 4660 JOHN-LAPTOP\John <n/a>
lsass.exe 584 <access denied> <n/a>
lsm.exe 592 <access denied> <n/a>
csrss.exe 520 <access denied> <n/a>
winlogon.exe 680 <access denied> <n/a>
procexp.exe 2716 5.30 Sysinternals Process Explorer Sysinternals - www.sysinternals.com JOHN-LAPTOP\John Process Explorer - Sysinternals: www.sysinternals.com [JOHN-LAPTOP\John] C:\PROGRAM FILES\PROCESSEXPLORER\procexp.exe "C:\PROGRAM FILES\PROCESSEXPLORER\PROCEXP.EXE" taskmgr.exe /3 Running DEP (permanent)
explorer.exe 384 0.76 Windows Explorer Microsoft Corporation JOHN-LAPTOP\John Counter Stike Source C:\Windows\explorer.exe C:\Windows\Explorer.EXE 6.1.7600.16450 Running DEP (permanent)
PWRISOVM.EXE 2708 PowerISO Virtual Drive Manager PowerISO Computing, Inc. JOHN-LAPTOP\John C:\Program Files\PowerISO\PWRISOVM.EXE "C:\Program Files\PowerISO\PWRISOVM.EXE" Virtualized
GrooveMonitor.exe 2700 GrooveMonitor Utility Microsoft Corporation JOHN-LAPTOP\John C:\Program Files\Microsoft Office\Office12\GrooveMonitor.exe "C:\Program Files\Microsoft Office\Office12\GrooveMonitor.exe" 12.0.6413.1000
SynTPEnh.exe 2732 Synaptics TouchPad Enhancements Synaptics Incorporated JOHN-LAPTOP\John C:\Program Files\Synaptics\SynTP\SynTPEnh.exe "C:\Program Files\Synaptics\SynTP\SynTPEnh.exe"
SynTPHelper.exe 372 JOHN-LAPTOP\John <n/a>
igfxtray.exe 2800 igfxTray Module Intel Corporation JOHN-LAPTOP\John C:\Windows\System32\igfxtray.exe "C:\Windows\System32\igfxtray.exe"
hkcmd.exe 2784 hkcmd Module Intel Corporation JOHN-LAPTOP\John C:\Windows\System32\hkcmd.exe "C:\Windows\System32\hkcmd.exe"
igfxpers.exe 2824 persistence Module Intel Corporation JOHN-LAPTOP\John C:\Windows\System32\igfxpers.exe "C:\Windows\System32\igfxpers.exe"
jusched.exe 2868 Java(TM) Update Scheduler Sun Microsystems, Inc. JOHN-LAPTOP\John C:\Program Files\Common Files\Java\Java Update\jusched.exe "C:\Program Files\Common Files\Java\Java Update\jusched.exe"
acrotray.exe 2936 AcroTray Adobe Systems Inc. JOHN-LAPTOP\John C:\Program Files\Adobe\Acrobat 9.0\Acrobat\acrotray.exe "C:\Program Files\Adobe\Acrobat 9.0\Acrobat\acrotray.exe"
DynTray.exe 1400 DynDNS® Notification Icon Dynamic Network Services, Inc. JOHN-LAPTOP\John C:\Program Files\DynDNS Updater\DynTray.exe "C:\Program Files\DynDNS Updater\DynTray.exe"
msnmsgr.exe 4604 1.52 Windows Live Messenger Microsoft Corporation JOHN-LAPTOP\John C???5 <hacker2k9@live.jp> C:\Program Files\Windows Live\Messenger\msnmsgr.exe "C:\Program Files\Windows Live\Messenger\msnmsgr.exe" 14.0.8089.726 Running DEP (permanent)
Xfire.exe 4868 Xfire Xfire Inc. JOHN-LAPTOP\John C:\Program Files\Xfire\Xfire.exe "C:\Program Files\Xfire\Xfire.exe" Virtualized
utorrent.exe 3740 0.76 µTorrent BitTorrent, Inc. JOHN-LAPTOP\John C:\Users\John\Downloads\Programs\utorrent.exe "C:\Users\John\Downloads\Programs\utorrent.exe" DEP (permanent)
CSS_FULL_Oct-15-07_DiGiTALZonE_1START.exe 836 18.94 JOHN-LAPTOP\John CSS FULL DZ [Oct 15 2007] v18.1 Setup Running <n/a>
firefox.exe 2532 Firefox Mozilla Corporation JOHN-LAPTOP\John HijackThis - Trend Micro USA - Mozilla Firefox C:\Program Files\Mozilla Firefox\firefox.exe "C:\Program Files\Mozilla Firefox\firefox.exe" Running DEP (permanent)

Link to comment
Share on other sites

well I left it running again and it got stuck again. I thought uT will create dump when I kill the process but it did not. My "net.low_cpu" is set to false all the time. I have dual core so it took whole core. some loop perhaps? :) Since Insomniaque had CPU idle I'd say my problem is different...

Process    PID    CPU    Description    Company Name
uTorrent.exe 3920 50.77 µTorrent BitTorrent, Inc.
System Idle Process 0 43.08
cmdagent.exe 1276 6.15 COMODO Internet Security COMODO
wmiapsrv.exe 4004 WMI Performance Adapter Service Microsoft Corporation
winlogon.exe 832 Windows NT Logon Application Microsoft Corporation
WebCam10.exe 504 Camera Software Labtec Inc.
System 4
svchost.exe 1328 Generic Host Process for Win32 Services Microsoft Corporation
svchost.exe 1652 Generic Host Process for Win32 Services Microsoft Corporation
svchost.exe 1544 Generic Host Process for Win32 Services Microsoft Corporation
svchost.exe 1164 Generic Host Process for Win32 Services Microsoft Corporation
svchost.exe 1096 Generic Host Process for Win32 Services Microsoft Corporation
svchost.exe 1396 Generic Host Process for Win32 Services Microsoft Corporation
svchost.exe 1088 Generic Host Process for Win32 Services Microsoft Corporation
svchost.exe 3164 Generic Host Process for Win32 Services Microsoft Corporation
spoolsv.exe 1892 Spooler SubSystem App Microsoft Corporation
smss.exe 740 Správce relací systému Windows NT Microsoft Corporation
services.exe 876 Services and Controller app Microsoft Corporation
rundll32.exe 536 Run a DLL as an App Microsoft Corporation
realsched.exe 3080 RealNetworks Scheduler RealNetworks, Inc.
procexp.exe 3192 Sysinternals Process Explorer Sysinternals - www.sysinternals.com
nvsvc32.exe 1044 NVIDIA Driver Helper Service, Version 190.62 NVIDIA Corporation
NokiaMServer.exe 624 Nokia M Platform Nokia
NetworkLicenseServer.exe 1632 ABBYY network license server ABBYY (BIT Software)
mdm.exe 3096 Machine Debug Manager Microsoft Corporation
LVComSX.exe 1676 LVCom Server Labtec Inc.
lsass.exe 888 LSA Shell (Export Version) Microsoft Corporation
jqs.exe 2760 Java(TM) Quick Starter Service Sun Microsystems, Inc.
Interrupts n/a Hardware Interrupts
IAANTmon.exe 2692 RAID Monitor Intel Corporation
IAAnotif.exe 2008 Event Monitor User Notification Tool Intel Corporation
hpcmpmgr.exe 356 HP Framework Component Manager Service Hewlett-Packard Company
FileZilla server.exe 2524 FileZilla Server FileZilla Project
explorer.exe 1924 Průzkumník Windows Microsoft Corporation
DPCs n/a Deferred Procedure Calls
daemon.exe 1300 DAEMON Tools Lite DT Soft Ltd
CTHELPER.EXE 2036 CtHelper Application Creative Technology Ltd
ctfmon.exe 576 CTF Loader Microsoft Corporation
csrss.exe 800 Client Server Runtime Process Microsoft Corporation
Communications_Helper.exe 484 Communications Manager Labtec Inc,
cfp.exe 1504 COMODO Internet Security COMODO
CALMAIN.exe 3408 Canon Camera Access Library 8 Canon Inc.
AVerScheduleService.exe 2452 ScheduleService Module
AVerRemote.exe 2316 AVerRemote MFC Application AVerMedia
AVerQuick.exe 1624 AVerQuick AVerMedia TECHNOLOGIES, Inc.
AVerHIDReceiver.exe 1248 HIDRec Application
alg.exe 528 Application Layer Gateway Service Microsoft Corporation

Process: uTorrent.exe Pid: 3920

Name Description Company Name Version
ACTIVEDS.dll ADs Router Layer DLL Microsoft Corporation 5.01.2600.5512
adsldpc.dll ADs LDAP Provider C DLL Microsoft Corporation 5.01.2600.5512
ADVAPI32.dll Advanced Windows 32 Base API Microsoft Corporation 5.01.2600.5755
ATL.DLL ATL Module for Windows XP (Unicode) Microsoft Corporation 3.05.2284.0002
COMCTL32.dll User Experience Controls Library Microsoft Corporation 6.00.2900.5512
comdlg32.dll Common Dialogs DLL Microsoft Corporation 6.00.2900.5512
ctagent.dll ctagent Creative Technology Ltd 1.00.0000.0012
DnsApi.dll DNS Client API DLL Microsoft Corporation 5.01.2600.5625
fltlib.dll Filter Library Microsoft Corporation 5.01.2600.5512
GDI32.dll GDI Client DLL Microsoft Corporation 5.01.2600.5698
guard32.dll COMODO Internet Security COMODO 3.14.64351.0586
hnetcfg.dll Home Networking Configuration Manager Microsoft Corporation 5.01.2600.5512
iertutil.dll Run time utility for Internet Explorer Microsoft Corporation 8.00.6001.18876
IMM32.DLL Windows XP IMM32 API Client DLL Microsoft Corporation 5.01.2600.5512
Iphlpapi.dll IP Helper API Microsoft Corporation 5.01.2600.5512
kernel32.dll Windows NT BASE API Client DLL Microsoft Corporation 5.01.2600.5781
MPRAPI.dll Windows NT MP Router Administration DLL Microsoft Corporation 5.01.2600.5512
MSCTF.dll MSCTF Server DLL Microsoft Corporation 5.01.2600.5512
msctfime.ime Microsoft Text Frame Work Service IME Microsoft Corporation 5.01.2600.5512
msvcrt.dll Windows NT CRT DLL Microsoft Corporation 7.00.2600.5512
mswsock.dll Poskytovatel služeb Microsoft Windows Sockets 2.0 Microsoft Corporation 5.01.2600.5625
netapi32.dll Net Win32 API DLL Microsoft Corporation 5.01.2600.5694
Normaliz.dll Unicode Normalization DLL Microsoft Corporation 6.00.5441.0000
ntdll.dll NT Layer DLL Microsoft Corporation 5.01.2600.5755
ole32.dll Microsoft OLE for Windows Microsoft Corporation 5.01.2600.5512
oleaut32.dll Microsoft Corporation 5.01.2600.5512
rasadhlp.dll Remote Access AutoDial Helper Microsoft Corporation 5.01.2600.5512
RASAPI32.dll Rozhraní API pro vzdálený přístup Microsoft Corporation 5.01.2600.5512
rasman.dll Remote Access Connection Manager Microsoft Corporation 5.01.2600.5512
RPCRT4.dll Remote Procedure Call Runtime Microsoft Corporation 5.01.2600.5795
rsaenh.dll Microsoft Enhanced Cryptographic Provider Microsoft Corporation 5.01.2600.5507
rtutils.dll Routing Utilities Microsoft Corporation 5.01.2600.5512
SAMLIB.dll SAM Library DLL Microsoft Corporation 5.01.2600.5512
Secur32.dll Security Support Provider Interface Microsoft Corporation 5.01.2600.5834
sensapi.dll SENS Connectivity API DLL Microsoft Corporation 5.01.2600.5512
SETUPAPI.dll Windows Setup API Microsoft Corporation 5.01.2600.5512
SHELL32.dll Windows Shell Common Dll Microsoft Corporation 6.00.2900.5622
shfolder.dll Shell Folder Service Microsoft Corporation 6.00.2900.5512
SHLWAPI.dll Shell Light-weight Utility Library Microsoft Corporation 6.00.2900.5912
TAPI32.dll Microsoft® Windows(TM) Telephony API Client DLL Microsoft Corporation 5.01.2600.5512
urlmon.dll OLE32 Extensions for Win32 Microsoft Corporation 8.00.6001.18876
USER32.dll Windows XP USER API Client DLL Microsoft Corporation 5.01.2600.5512
USERENV.dll Userenv Microsoft Corporation 5.01.2600.5512
uTorrent.exe µTorrent BitTorrent, Inc. 2.00.0000.17920
UxTheme.dll Microsoft UxTheme Library Microsoft Corporation 6.00.2900.5512
VERSION.dll Version Checking and File Installation Libraries Microsoft Corporation 5.01.2600.5512
wininet.dll Internet Extensions for Win32 Microsoft Corporation 8.00.6001.18876
WINMM.dll MCI API DLL Microsoft Corporation 5.01.2600.5512
WLDAP32.dll Win32 LDAP API DLL Microsoft Corporation 5.01.2600.5512
WS2_32.dll Windows Socket 2.0 32-Bit DLL Microsoft Corporation 5.01.2600.5512
WS2HELP.dll Windows Socket 2.0 Helper for Windows NT Microsoft Corporation 5.01.2600.5512
wshtcpip.dll Windows Sockets Helper DLL Microsoft Corporation 5.01.2600.5512

Link to comment
Share on other sites

soo I played a little and got you recreation steps for my problem :)

pretty simple actually. start WebUI (I did on port 80), go here http://www.canyouseeme.org/ test whether your port 80 is open. uTorrent at max CPU and not responding. what was shooting me down was probably some portscan from somewhere.

My first DoS attack :D Now I'm a little tempted to try few IPs from peer list what will happen. But I guess killing my uT makes me happy enough. Anyway I guess this should be fixed quickly

BTW. I tried net.low_cpu to TRUE and did not help with this

Link to comment
Share on other sites

Firon, I catched this problem in the debugger. The problem is that one thread (not a main one) runs into the endless loop between addresses 0x042432A & 0x0424369 (in 2.0 release bld. 17920). Also all another builds seem to have this problem. If you want, you can use me as the remote debugger :) I'm the professional software developer.

If you would send me a 'checked build', or simply PDB files, I will provide you with much more detailed info. Feel free to send me direct emails.

Here is the stack trace of that thread:

> uTorrent.exe!00424366()

[Frames below may be incorrect and/or missing, no symbols loaded for uTorrent.exe]



kernel32.dll!BaseThreadInitThunk() + 0x12 bytes

ntdll.dll!___RtlUserThreadStart@8() + 0x27 bytes

ntdll.dll!__RtlUserThreadStart@8() + 0x1b bytes

Link to comment
Share on other sites

Thanks to everyone for solving this one! You don't know how frustrated I've been with this bug. I can report that this bug starts from alpha/beta 1.9 already. I've been using utorrent betas through wine on ubuntu and kept getting constant crashes with 100% cpu usage. Then after spending a lot time browsing and searching these forums I gave up and went back to 1.8.5 and it worked perfectly. After 2.0 release I gave this new version a go and same results again. Constant crashing.

Trying the webui port in canyouseeme.org resulted in same crash as what others have reported. So my crashes were because someone port scanned me on my webui port. I did as suggested and closed my port forward for webui and I'm not getting crashes anymore. Thanks! I hope you can get the webui back working again soon.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...