Archived

This topic is now archived and is closed to further replies.

ashnoom

utorrent the torrent you are trying to add is already in the list of..

Recommended Posts

We all know the yada-yada.

I also read the other threads F7 -> Torrents/All etc.

Allright, what happened:

- Opened magnet link

- uTorrent opens (completely new instance, uTorrent wasn't running as of yet)

- New Version Available window pops-up. I pressed yes

- Add Torrent window pops-up

- uTorrent shutsdown for update.

- Waited for uTorrent to restart

- There was no torrent added.

- Clicked on magnet link again and then I got the message about it being already in the list. But there is nothing there.

- Added a new (different torrent), that works.

- Adding the .torrent file (that belongs to the magnet link) doesn't work either.

- Options -> Preferences -> Directories are all not set.

I am running the beta's. And updated to latest beta (3.2 beta (build 27272) [32-bit]

Share this post


Link to post
Share on other sites

Try checking your completed and seeding torrents (if you don't delete torrent + data after completing download)...the torrent you're trying to readd is probably in there (if you've already downloaded it the first time).

Share this post


Link to post
Share on other sites
It just ain't there. Nowhere.

In no any label/list/whatever. It has never downloaded either.

Hmm...that's an odd bug or something. I think I've hepled as far as I can help.

Can an appropriate authority help this person out.

Share this post


Link to post
Share on other sites

Similar problem. Added torrent via mirror link. Let the Add New Dialog load the file info. (Great feature!) uTorrent hung. Restarted it. Tried to reload torrent. Got the "already in list message."

Added a different torrent. Deleted it. Added it again. Got the "already in list message" again.

Checked directories for vestiges of the torrents. (Torrent files, d/l directories, etc.) Deleted it. Exited uTorrent. Made sure uTorrent process stopped. Restarted. Still could not add above torrents.

At this point, simply cannot use the above torrents: can't add them, but there is no entry for them in UI.

Viewed "resume.dat" in a hex editor. Found text that matched the two deleted torrents. Might this be the problem?

If so, suggested fix is to purge "orphan" entries at startup; or provide some way to do that manually.

Using build 27295.

Share this post


Link to post
Share on other sites

Even simpler to reproduce: Click on a magnet link. "Add New" dialog appears. Click cancel. Click on magnet link again. Get the "already in list" message.

Wait a few minutes. Click the magnet link again. Now the "Add New" dialog does appear and the torrent can be added. (This workaround DOES NOT work for torrents corrupted in the crash, however.)

Build 27295.

Share this post


Link to post
Share on other sites

same problem here, loaded a torrent via magnet link, utorrent froze. I had to force close via task manager, then upon relaunch from shortcut, the torrent isn't listed but I can't re-load it since utorrent thinks its still there. Any temporary fixes for this until a patch is released? I tried renaming resume.dat to resume.old along with clearing out my %appdata%\utorrent, still no joy.

Share this post


Link to post
Share on other sites

i am having this problem since i installed the latest version of µtorrent for mac yesterday. the program said a new version was available, and did i want to install. i said yes.

when i restarted the program, the torrents list was blank -- i figured that was ok. but then i ran into two problems:

1) unlike prior versions, it will no longer let me drag & drop torrents into the window.

2) if i try to use the menu option to open a torrent, it tells me the torrent is already in the list... even though the list is blank.

i uninstalled the new version, and reinstalled the older version, but it is still showing the same behavior. installing the update screwed up something... :-(

Share this post


Link to post
Share on other sites
%appdata%\utorrent

Where is this located to get that resume.dat? Or how do I get there?

That sounds like that could fix it.

I am having the exact same problem.

Share this post


Link to post
Share on other sites
%appdata%\utorrent

Where is this located to get that resume.dat? Or how do I get there?

That sounds like that could fix it.

I am having the exact same problem.

hit 'run' from the start menu, or press windows-key +R.

This both brings up the 'Run' window. In the input field type %appdata%\utorrent and hit ok/enter.

Share this post


Link to post
Share on other sites

I would like to confirm that I have seen this bug several times as well, even after upgrading to build 27430. I was trying to open a magnet link and encountered this issue.

Share this post


Link to post
Share on other sites

1. exit utorrent

2. delete resume.dat

3. delete resume.dat.old

4. Click the magnet torrent link

5. Download!!

Hope it works...

remember.. sharing is caring

seed after you download

Share this post


Link to post
Share on other sites

had this a few times now, first 2 times deleting resume.dat and resume.dat.old worked but this time it didn't. only thing that fixed it this time was renaming %appdata%/utorrent to utorrentOLD, and then adding the torrents again and they worked fine.

I then copied the contents of utorrentOLD (but not the 2 resume files) into the new folder it had created. It worked without this but i wanted my old settings back :D

Annoying bug, hope they fix it soon. In the meantime hope this helps.

Share this post


Link to post
Share on other sites

BUMP. Just had the same thing happen as original post: hit magnet link, prompted for new version, said yes to download, uTorrent closes without the previously linked torrent being visible in my download list, can't add from magnet link as uTorrent says its already in my download list. Removing resume.dat / .old resolved, but of course deleted everything from my DL list. Still a bug in build 28447.

Share this post


Link to post
Share on other sites

As a "By the way"

There is a Firefox extension called Magrent that is reasonably successful at converting Magnet links to .torrent files, you right click on a magnet then use Magrent to locate the torrent file for that hash.

Share this post


Link to post
Share on other sites

If there is only a specific file that is causing you an issue, and you don't want to delete resume.dat, then:

1. Exit uTorrent.

2. Get BEncode Editor from here: http://forum.utorrent.com/viewtopic.php?id=31306

3. Extract BEncode Editor to your Desktop and open it.

4. Go to File -> Open and find resume.dat (Windows users: it will be somewhere here: C:\Users\<username>\AppData\Roaming\uTorrent).

5. Select the torrent that is giving you issues and press Delete on your keyboard.

6. Save and exit.

Share this post


Link to post
Share on other sites