Jump to content

Invalid Data Error ? (a solution)


Recommended Posts

Do you have this problem.

Check the torrent download folder for the torrent you get this error with. See if the ~uTorrentPartFile_numbersandletters.dat is 2GB (partfile)

Workable Solution.

1. Remove problem torrent

2. Go to the exact download folder where files for the torrent have been downloading to (as above). Backup to another drive the partfile (just in-case) and delete the partfile from the folder.

3. Add back the torrent file in the pop-up add torrent file that appears, deselect all torrents. Then add a few from those that you need to download. I know selecting 4GB of files makes about a 1.2GB partfile. If you have many files and time could find the exact size able to download before hit 2GB partfile problem.

4. When download complete go back to Number 1. (above). Repeat 1 to 5 until all the files you need have been downloaded.

5. To seed will still need a partfile so seed a few at a time or as you downloaded them.

6. If possible tell the torrent author to remake the torrent so it is made correctly. Not made upon for file size, normal torrents built to a folder structure that descends

Link to comment
Share on other sites

I read here when search for a solution to this that others here on this forum have same problem. Using new versions of utorrent I use an older version this post is for everyone until is fixed. I wrote the above as a workable solution until utorrent can handle this better.

I know the solution works since am seeding half the files I downloaded now. The partfile is 1.2GB and will be again 2Gbif try to seed all at once. Am seeding half then other half.

Link to comment
Share on other sites

If that's the only version you've tried, you have NOT tried ANY currently supported versions.

It happens for 2.2.1 and 3.3 as far as I can tell. IOERROR 13 once size of part file meets a value slightly larger than 2GB.

Selecting all files including shits generated by bitcomet may work around the problem.

Link to comment
Share on other sites

The partfile is made up from pieces that are from the DEselected 'files'.

Not exactly. Partfile is used to fill the blocks that cross file boundaries. It comes from either selected or deselected files as long as they expose unaligned file boundaries. As for shitty padding files generated by bitcomets, they're used to align file boundaries to blocks, so deselecting them makes huge partfile.

Link to comment
Share on other sites

Anyway the problem is submitted. The file I had was over 100GB not that should have caused this. What caused it was the files were made by file size no folder and file structure that normally are. Or maybe it is by some other unknown reason I do not know of.

No I didn't test with any other versions but have read many even with new versions having this problem so is/was current (was if has now been fixed).

Mentioned also because someday I hope utorrent will again have a non bloat version. Noting that v2.0.4.22150 was the last best version before utorrent went downhill.

This post is not for utorrent v2 differences it was for reporting an error only there is a forum for utorrent v2 thread here for that (a sort of discussion thing with no developer feedback). Though I guess it would be an easy build for a utorrent development team to build and keep updated. With the fix also I have submitted here maybe!

Again this thread is for utorrent v2.x (non bloat etc etc) and why you like them above v3.xx builds. That is the one to put your feedback and complaints into, not this one :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...