Jump to content

uTorrent kills my internet connection


MindsMirror

Recommended Posts

When I am running uTorrent my internet slows down to almost nothing.

This problem started about 4 weeks ago. I have always been able to dl/ul torrents and browse or watch videos or do pretty much anything at the same time (my connection is 30Mbit down, 5Mbit up). Then suddenly about 4 weeks ago this problem started. My internet will be working perfectly before opening uTorrent. Then when I open uTorrent, it takes about 5 seconds and then the internet becomes unusable.

When the problem is occuring, I try to load webpages and they do nothing for about 15 seconds before timing out and saying the page is unavailable. Sometimes tiny parts of the pages come through, and I see unformatted text, like its just bare HTML or something, and with the little red X's on images and applets and things. I still get some traffic through uTorrent, but it is much slower than before/usual. When I close utorrent, it can take around 30 seconds for the internet to start working again. If I stop all torrents and leave utorrent open, everything will work normaly. If one torrent is running, but not really doing anything, the internet will be pretty slow but still usable, and if several torrents are running, even if they aren't really doing anything, I cant hardly use the internet at all.

I have obviously restarted the router and everything several times since this started. The problem occurs for everyone on the connection, using windows 7 and ubuntu, wired or wirelessly connected. When one person is trying to use a torrent program, everyone else experiences the issue. I have reset the modem/router to factory default setting which gave no improvement. This lead me to believe that it was either my modem had gone bad or the ISP was causing the issue (time warner cable). I called them and they ran diagnostics on the connection and modem and also changed a channel in the modem but apparently it all checked out.

I have reinstalled utorrent, tried a few different versions, restored to all default settings, and tried using Vuse instead, but I get the same problem whatever I do.

There was no change that I was aware of when the problem started so I have no idea what could be causing this or what else I can to to diagnose the issue.

I would greatly appreciate and help or suggestions of things to try. Thanks.

Link to comment
Share on other sites

Sorry, Im new to this forum, am I supposed to put my setting somewhere in my propile? I looked quickly and didnt see anywhere for it.

Well, I have reset the utorrent settings, so they will mostly be default. i still have the problem with default settings. If i use the auto setup thing in utorrent and use the default settings for 5Mbit ul, there is no change. Are there any specific settings I should provide? I am led to believe that, since multiple people have the exact same issue, with several different bittorrent clients, that it is not an issue with the settings. Its probably not utorrent specific, so i dont know if this is the right forumto post in. I just thought that there could be some knowlegable people on here that could help.

Link to comment
Share on other sites

I'm connected directly to the modem, an SBG6580.

I ran the utorrent setup, UL speed is 5Mbit, DL is from 2 to 4Mbit (should be 30). Settings are 506kbps UL limit, 600 global max connections, 100 connections per torrent, 8 UL slots per torrent, 9 max active, 8 max DL

Both speed and port forwarding give green checks.

The utorrent network status indicator goes between green and yellow.

Downloading the open office installer I got an average speed of 645kB/s. When it was downloading, the status was green. When it stopped, and I was just trying to seed a few things, it turns yellow sometimes.

I also downloaded ubuntu which averaged 1017kB/s, and topped out at around 3MB/s near the end.

I did look though that guide before, but I don't feel it's strictly relevant to my problem, because the issue is not uTorrent specific, and most of the issue is with browsing. None of those settings in the guide were changed when the problem started (they were at default), but I tried each of these anyway:

COMMON PROCEDURES

Restart µTorrent, your computer, modem, and/or router after performing any of the suggestions below

Try using Switeck's conservative settings

Try lowering net.max_halfopen to 4 or lower (Can be found in Preferences > Advanced)

Try lowering bt.connect_speed to 4 or lower (Can be found in Preferences > Advanced)

Try disabling IP resolving in the Peers tab's context menu

Try disabling DHT (Can be found in Preferences > BitTorrent)

Try disabling UPnP and NAT-PMP (Can be found in Preferences > Connection)

Try disabling peer.resolve_country if it isn't already set to false (Can be found in Preferences > Advanced)

Try lowering maximum global number of connections to 200? 100? 50? Lower? (Can be found in Preferences > Bandwidth)

Try disabling uTP? (Set Preferences > Advanced > bt.transp_disposition to 5)

Try enabling Protocol Encryption? (Can be found in Preferences > BitTorrent)

They didn't solve anything.

I run windows firewall (with utorrent exception), but other than that, no antivirus or network protection.

Anything else?

Link to comment
Share on other sites

  • 2 months later...

I still have this problem, I have discovered some other details which I think are related.

When I turn my computer on, I experience the problem with websites timing out. About a minout after logging on, it stops and I can browse normally.

Also when I close uTorrent, I experience the same thing, even if no torrents were running.

I have tried lowering the max number of connections to 15, and active torrents to just 1. It helps a little, but it is still not working like it used to. When I attempt to load a website, it might time out the first time, but after maybe 1 or 2 more attempts it works. Also, if I attempt to load a site for the first time it may not work, but after it has successfully loaded once, the site will not have the problem again.

Link to comment
Share on other sites

Also when I close uTorrent, I experience the same thing, even if no torrents were running.

So probably nothing to do with uTorrent at all then.

Have your machine checked for malware or hijackers, Delta search and/or Alot are particularly prevalent.

Also, if I attempt to load a site for the first time it may not work, but after it has successfully loaded once, the site will not have the problem again

And clear your browser cache, flush the machine DNS cache and power cycle your router with a two minute off period.

Link to comment
Share on other sites

  • 1 month later...

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...